FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 

Cirklon/Usamo troubles
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author Cirklon/Usamo troubles

I have a recurring problem that I'm not able to solve, so figured I'd check if Os or anyone else have any suggestions. Since I'm uncertain if this is a Cirklon, Usamo or Live issue, I also just posted this over on the Sequentix forum.

Anyway, my setup is as follows:

I have Ableton Live running on an iMac, which is providing a master clock for my Cirklon. The Cirklon sequences everything else in my studio. For the clock, I'm using an Expert Sleepers Usamo to send clock as audio, via an output on my RME Fireface 800. Fairly straight forward really.

Now, this has worked fantastic for a long time. Today, not so much unfortunately. The Cirklon still receives clock, and starts as it should. But when I stop Live, the Cirklon only pauses (since there's no clock). The play button remains lighted, and when I start playback in Live the Cirklon just continues on from whatever step it was on when it stopped receiving clock from Live. Any devices receiving just clock the Cirklon doesn't start again until I've hit the stop button on the Cirklon and then play button again (or started it once more from Live).

Usamo is just sending clock btw. I've tried turning on song position pointer, but that doesn't do anything.

I've experienced this on occasion in the past too, but have never managed to figure out what the issue is about. I've changed no settings whatsoever in neither Live or the Usamo plugin or for that sake on the Cirklon. Turning stuff off and on again has no effect.

Edit: 5 minutes after posting this, I managed to fix this. I have had my FF800 set to 48.000 Hz for the longest time. Decided to change that to 44.100 Hz the other day. When setting it back to 48.000 Hz, everything works as it should again.

I have no good explanation for it, but I'm guessing this has to do with the settings of my audio interface, particularly the sync settings. I have a Behringer ADA8200 connected to the FF via ADAT.

Would still be interested in hearing an explanation for this behavior, but good to have it solved for now.

Does the USAMO plug-in say it's sending a MIDI stop? (In the sent messages window.)

Have you run the self-test recently?
Haven't done the self test since I installed it. I'll check the sent message window later.

I got this reply from Colin Fraser over at the Sequentix forum:

"MIDI baud rate is 31.25 kHz.
Using an audio output for MIDI data, you need to have a high enough sample rate such that none of the bits in the MIDI stream are lost.
The MIDI bits won't line up exactly with the audio samples, but as long as the transitions between bit states are close enough to the right places, it can work.
MIDI clock uses code F8, which in the actual transmission has the sequence 0000111111 (10 bits including a start and stop bit)
MIDI Start and Stop are FA and FC, which have the bit sequences 0101011111 and 000111111.
My guess is that at the lower sample rate, the bit sequence for stop was being distorted to the point that it would read as an incorrect code, thus the Start and Clock bytes were working, but Stop was ignored."

This could certainly explain it. Switching back and forth between 44.1kHz and 48kHz does at least make the problem come and go. Every single time.
It won't surprise you to hear that the USAMO has stuff in it to handle that situation - that's why it works as well as it does at 44.1kHz. That said, it's still easier to handle it at 48kHz.

I would run the self-test again.
Okay, will do.
I'm considering going the USAMO to cirklon route. Have you been able to figure out how to make this work consistently?

I would hate to give up my solid but oversized esx/8md - ES40 rig to something that is a little more inconsistent.
To be frank, I can't even remember having this problem or how it was solved. ;-) All I know is that it's been rock solid for a long time now. Knock on wood.
Awesome. Thanks.
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group