MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Tm3030 problem
MUFF WIGGLER Forum Index -> Oakley Sound Systems  
Author Tm3030 problem
househead
Hi I've finished my tm3030 and am really stunned with how good it sounds !!... I've got a problem when using it with creator on the Atari st, when I press stop the 3030 stops working and I have to restart the machine !!.... I've tested it with ableton and logic and it works fine but for some reason it doesn't work with the Atari (my main sequencer).
Synthbuilder
Interesting. Creator is very old and is probably sending some unusual midi command when stop is pressed. You may be able to control which commands are sent in the preferences/options part of Creator.

It could be something like 'reset all CC or controllers'. If it is, then what it is probably doing is sending a modulation wheel value of zero. This will enable the TM3030's mod wheel control over cut-off frequency mode and set it to zero - effectively turning the filter completely off. If so, simply moving your mod wheel should get your TM3030 to work again.

Probably best switch 'reset all controllers' off in Creator though if you can.

Tony
househead
Unfortunately there's no option to turn off reset controls when stop is pressed, I recorded the data being sent out by creator when stop is pressed and it does indeed send out a mass reset through 1-16. Although this doesn't seem to be the problem, when I press the continue button to start playback and the continue again to pause playback it makes the tm3030 fail and need a reset. When the 3030 fails it's more than the filter being set to zero, the midi led ceases to show any activity as we'll. I recorded the continue action to have a look at the data and it doesn't send any recordable data into logic!!.... now I'm really confused!!...
househead
I decided to record the midi pause data that's making the 3030 fail into midiox.


Synthbuilder
OK. All those 'all notes off' (CC#123) commands may well be confusing the TM3030's midi chip. I let Colin Fraser, who wrote the code, know and see what he says. He's currently relocating to Germany so it might take some time.

I'm a little puzzled why there's three ports showing, 10, 11, 12. Or is that midiox sharing it's input into three virtual ports? If that is the case Creator is probably only sending one set of CC123 to each available midi channel. That shouldn't crash the TM3030.

I wonder whether the TM3030's opto-coupler is not working fast enough. Can you try another opto in there?

Tony
Synthbuilder
I've forwarded this onto Colin and he will see if he can replicate this. I'll be back to this thread as soon as we know more.

Tony
househead
Thanks Tony, i tried changing the opto-coupler but it still fails.... look forward to an update.
MUFF WIGGLER Forum Index -> Oakley Sound Systems  
Page 1 of 1
Powered by phpBB © phpBB Group