MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Buchla USB Firmware Card not flashing
MUFF WIGGLER Forum Index -> Buchla, EMS & Serge  
Author Buchla USB Firmware Card not flashing
deltaphoenix
Hi,

Trying to update a 210e to Primo and the firmware card is not flashing every 1.5 seconds in order to indicate that the hex file is loaded onto it. The Firmware utility indicates that the hexfile is loaded onto the firmware card though. The 210e is not being updated.

Is this some sort of known issue (that has a fix) or is the USB firmware card messed up?

Thanks
ArguZ
Maybe you are missing a step in the chain...
As in the coder loader loader wink

I thought primo is only for the 206e and 225e ?

or do you have something newer than this :

210e Control and Signal Router 30.2 1/12/12 210Ev302.hex.zip First public release
deltaphoenix
You are correct, 30.2 for the 210e.

I must be missing that step. I have the latest firmware utility on my Mac. I then open the appropriate hexfile. I get a message that shows success (firmware flashed onto USB firmware card basically) but the LEDs on the card are not flashing which is supposed to signal success.

Can someone point me to the code loader loader?

Thanks!
Oxix52
Do you know if your 210e is pre-v30.x? If so, then you will need the code loader, code loader loader, and the new firmware. I only have the firmware for the 210e since I didn't get a 210e until after the v30.x upgrades. The upgrade instructions are here: https://buchla.com/guides/Buchla_200e_v30_Upgrade_Guide.pdf
but you will need those 2 code loader files. I don't know why they aren't on the Buchla site. They used to be.

Good luck!
deltaphoenix
Thanks, yes mine is pre-version 30.X, can someone send me those 2 code loader files? It would cool to get this up and running this weekend!
Kent
IIRC, you will need the USB debugger device too. The regular Buchla firmware card can’t address the loader-loader file.
Oxix52
Kent wrote:
IIRC, you will need the USB debugger device too. The regular Buchla firmware card can’t address the loader-loader file.


Is the 210e one of the modules that won't update with the Buchla USB firmware card? Most of mine did, except for the 259e, 281e, and 291e. Had to send those in for the v30.x update.
dougcl
Kent wrote:
IIRC, you will need the USB debugger device too. The regular Buchla firmware card can’t address the loader-loader file.


Hi Kent, it has been a long time, but I recall downloading code loader loaders and code loaders and loading them. This must mean that I used the USB firmware card to install. Maybe I just misunderstand what you mean by "regular firmware card."

Regarding the old code loader and loader loader downloads, Google search led me back to MW and an old thread here
https://www.muffwiggler.com/forum/viewtopic.php?t=122949
with a post by batchas,

which led to this magical place
https://web.archive.org/web/20130611212759/http://www.buchla.com/serie s200e_firmware.html

I guess I need to download all of this stuff for safe keeping?

Doug
deltaphoenix
Thanks everyone, I did a little Googling and hadn't gone into that thread yet.

Here is the error that I am getting with the code loader loader and code loader:

Attempting to write new firmware to USB card... please wait.

Generating v1 I2C Card Header...

Reading hex file...
Error reading hex record from file.
Couldn't copy hex data to internal buffer.


Finished parsing Hex records. returning total bytes copied: 0.


I did email BEMI and Lewis replied quickly letting me know that he forwarded my email to someone else and to expect a reply.
batchas
dougcl wrote:
Hi Kent, it has been a long time, but I recall downloading code loader loaders and code loaders and loading them. This must mean that I used the USB firmware card to install.

Back then I also used the USB utility card to install 30.x on my 210e pre-version 30.x (as well as all my "e" modules actually).
The 206e in the system and its preset manager was primo ready.

There's a difference though between "firmware card" (which won't work afaik on pre 30.x modules) and "USB utility card" which obv. does.

BTW I often recommend to check web.archive.org if you look for data which seems not to be available anymore.
As well as saving all files locally when it comes to firmware, code and so on like dougcl mentionned in his last post. It does not take space and can be sometimes of great help.
deltaphoenix
Thanks batchas!

I will definitely archive these files for later (if they work that is). Can any verify that the code loader loader and code loader work on their USB firmware card? If they do then I must have a faulty USB firmware card...
MUFF WIGGLER Forum Index -> Buchla, EMS & Serge  
Page 1 of 1
Powered by phpBB © phpBB Group