MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Juno-66, ModyPoly, SH-1oh1 midi output configuration
MUFF WIGGLER Forum Index -> Tubbutec  
Author Juno-66, ModyPoly, SH-1oh1 midi output configuration
tubbutec
Keywords:
Double midi, phasing, as-played, as-sounds, channels, loop

Tubbutec synth upgrades have two midi output channels: An as-sounds channel and a as-played channel.
While this is a very useful feature, and well documented in the user manuals, many people seem to be confused by this and we had to answer "bug reports" way to many times.

So here is an explanation of some common issues:

Double notes:
The as played channel outputs what you play on the keyboard. Basically the keyboard of your synth acts like a midi keyboard.
The as-sounds channel outputs all notes that the synth actually plays. This includes arpeggiator, sequencer, chord memory and so on.
Both channels can be active simultaneously - and are so by default.

This means if your midi receiver (DAW, other synth) is set to receive midi signals on ALL channels, it will receive as-sounds and as-played. This results in double notes, which can result in
- phasing effects
- incorrect note off
and other undesirable effects.

Loops:
When receiving midi data, Juno-66, SH-1oh1 and Modypoly will not send this data on the as-played channel to avoid loops. It will however send data on the as-sounds channel, as these notes are potentially different from the received notes.
If your DAW sends the received as-sounds notes back to the output, this will cause a midi loop.
Midi loops can cause stutter, phasing, lockup,...

Solutions:
- Make sure your synth or DAW only receives on one channel, not omni.
- Make sure you synth/DAW does not send midi data received on the as-sounds channel back to the ouput.
- You can turn off output midi channels in your Tubbutec synths. This also seems to confuse people from time to time.
a) Enter the synths config menu. Consult the user manual how to do this.
b) In the config menu you first press the key selecting the midi channel (as-sounds, as-played, input). Then you press one off the lowest 17 keys to turn the channel off (lowest key), or select midi channel 1-16 (key 2-17).
goldplate
Thank you for clarifying the subject.

Quote:
When receiving midi data, Juno-66, SH-1oh1 and Modypoly will not send this data on the as-played channel to avoid loops. It will however send data on the as-sounds channel, as these notes are potentially different from the received notes.

I can't see the usefulness of sending as-sounds notes for notes which have been triggered by MIDI input. I don't have any other synth behaving like this, and I know why: the MIDI output of my SH-1oh1 is ready to be connected but it remains unplugged because otherwise I have a bad MIDI loop with how works my sequencer (Sequentix Cirklon), but using Ableton Live would works the same.

Quote:
- You can turn off output midi channels in your Tubbutec synths. This also seems to confuse people from time to time.
a) Enter the synths config menu. Consult the user manual how to do this.
b) In the config menu you first press the key selecting the midi channel (as-sounds, as-played, input). Then you press one off the lowest 17 keys to turn the channel off (lowest key), or select midi channel 1-16 (key 2-17).

Now I see that I should disable the as-sounds channel, but then I won't be able to get arpeggiator, sequencer and chord memory, so plugging back the MIDI output will only give me a quarter of the features it could (without constant hidden menus diving).

Echoing MIDI triggered notes to the MIDI output is like a MIDI Thru and in this matter it could be seen as useful, but it's obvious that it would be needed to be possible to disable it on its own.
tubbutec
goldplate wrote:

I can't see the usefulness of sending as-sounds notes for notes which have been triggered by MIDI input. I don't have any other synth behaving like this, and I know why: the MIDI output of my SH-1oh1 is ready to be connected but it remains unplugged because otherwise I have a bad MIDI loop with how works my sequencer (Sequentix Cirklon), but using Ableton Live would works the same.


Well, I guess other synths usually do not have an 'as-sounds' feature. I don't see any way this would work without sending midi. By definition the 'as-sounds' sends what you hear. You can not NOT send midi because midi in notes might be completely different from the output notes. If you turn on the sequencer, you can transpose it with incoming midi notes and send the sequencer data to the output for example.
If you don't want that feature, turn off the as-sounds, only use the as-played and it will work fine. But I see no way or point to have an as-sounds channel, that does not send midi.

It is possible to avoid the midi loop in Ableton, and I am sure it is also possible with Circlon.

goldplate wrote:

Now I see that I should disable the as-sounds channel, but then I won't be able to get arpeggiator, sequencer and chord memory, so plugging back the MIDI output will only give me a quarter of the features it could (without constant hidden menus diving).

Again: what is the alternative? How would this work? What are you expecting?
goldplate
To only send notes which were generated by the synth or its sequencer/arpeggiator/chords memory and not notes which were received from external MIDI. Sending received notes as-is is a Thru and could exist because could be useful in some situation where you have limited equipments to make connections, otherwise I can only see it as a source of issues if being mixed to the MIDI Out and stuck as not being possible to be disabled.

Yes, Cirklon is able to switch its "Edit Track Thru" on & off quickly for some situation like this one. Even after the as-sounds channel is disabled on my SH-1oh1, I still have to switch the no-edtrk-thru Cirklon feature on & off as soon as I want to use the synth keyboard to play it while also being able to record notes from it. A modern feature which resolve the loop issue generated in this case is called "local off" which of course has to be implemented in the synth.
tubbutec
So the following example:

SH-1oh1:
I play a D over midi and by doing this select a sequence. The sequence starts playing.
Currently the D is not sent to the 'as-sounds' output (because you can not hear it) but of course the sequence is sent.

Given this example: What would you change? Please explain.
If you send back the received notes from the sequencer, you will change the sequence continuously. Obviously this is not what you want and the solution is to not send it back. I don't see any alternative

This is not the same as midi-through. As a matter of fact you CAN activate midi through on the SH-1oh1. But it is optional.

Local off:
This is a completely different scenario. You want to use the 101 as a midi keyboard and at the same time as a separate synthesizer. Local off is great if you have a dedicated button for it, otherwise extremely confusing. So we chose not to implement it.
goldplate
Quote:
SH-1oh1:
I play a D over midi and by doing this select a sequence. The sequence starts playing.
Currently the D is not sent to the 'as-sounds' output (because you can not hear it) but of course the sequence is sent.

Given this example: What would you change? Please explain.


The issue is that if the as-sounds channel is enabled in order to be able to receive the notes in my sequencer, switching back to the normal mode of the SH-1oh1 will produce a MIDI loop because of the Thru feature of my sequencer, so I will need to disable the as-sounds channel.

I would like to limit the menu diving if I want to use the SH-1oh1 sequencer or arpeggiator. So let's say that local off is not always ideal so we won't have it and I will need to switch the Thru feature of my sequencer, OK. But because of the "as-sounds Thru" I will also need to enable/disable the as-sounds channel each time.

I'm not in the urge of this, but the reality is that it's more simple to disconnect the MIDI Out, so that's what happens to the guy who prefer the workflow over the risk of frustrating MIDI loops if he didn't do the correct menu manipulations.
fanwander
I know, a little late reply...
tubbutec wrote:

Well, I guess other synths usually do not have an 'as-sounds' feature.

The DX7 Supermax extension has also a 'as-sounds' feature. And the Roland SH-01a sends only 'as-sounds' (Octave-Switch, Transpose, Arp, Sequencer).
They all behave like the SH-1oh1.

Of course one has to get used to this behaviour, but it is the only logical one.
MUFF WIGGLER Forum Index -> Tubbutec  
Page 1 of 1
Powered by phpBB © phpBB Group