MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Why? Overdrive pedals having jumpy Gain controls on my Send
MUFF WIGGLER Forum Index -> Guitars, Basses, Amps & FX  
Author Why? Overdrive pedals having jumpy Gain controls on my Send
Technologear?
I've tried a number of overdrive pedals on my mixer sends, and they all seem to do the same thing: their controls become really sensitive, going from 'not much' to 'heaps' from barely a twist of the knob.
I haven't tried boutique pedals just what I have available, stuff from danelectro, behri, mooer, ehx.
Could this be a line level impedance issue, or just something associated with cheaper pedals? My tube amp and mixer channel gains don't behave like this.
BailyDread
The pedals are expecting instrument level signal and you're feeding it a line level signal. That coupled with the fact that your sends are almost certainly balanced connections while the pedal is expecting unbalanced is where this is coming from.

A re-amping device from Radial would help you, or you could use a DI box in reverse. There's lots of information online about how to do both of those things thumbs up
Technologear?
I have plenty of DIs floating around, I'll utilise them, thanks (again) BD!
MUFF WIGGLER Forum Index -> Guitars, Basses, Amps & FX  
Page 1 of 1
Powered by phpBB © phpBB Group