MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Wiard 1200 Series Info
MUFF WIGGLER Forum Index -> Wiard Goto page Previous  1, 2, 3 [all]
Author Wiard 1200 Series Info
21hertz
Thanks for all the info!

I'm waiting for a Boogie, probably gonna arrive tomorrow.
The seller says it has gotten a "bad/wobbly" frequency knob so I got it very cheap. I hope I might be able to fix it. I usually use CV input to control it anyways. Also I should be able to connect to my Liivatera with Offset to get around the problem...
slow_riot
You may find that you need to replace the pot, it seems like there was a bad batch of pots used on these modules and several users have experienced errors of this nature. If you get erratic changes in filter cutoff this is why. Luckily it's a simple procedure for a skilled technician to carry out. (This is assuming you are talking about the 1200 Boogie).
21hertz
slow_riot wrote:
You may find that you need to replace the pot, it seems like there was a bad batch of pots used on these modules and several users have experienced errors of this nature. If you get erratic changes in filter cutoff this is why. Luckily it's a simple procedure for a skilled technician to carry out. (This is assuming you are talking about the 1200 Boogie).


I am talking about the Malekko Wiard Boogie Filter. The module works, but the Frequency knob is indeed physically wobbly.

I only have basic soldering skills. What can be done to fix it? I guess it requires a new knob. I just mailed Malekko to see if it is possible to fix myself somehow.
slow_riot
Yes you need to speak with Malekko who built the module.

The problem I was referring to was with the 1200 modules only.

Although replacement of a pot is not the most advanced repair work that can be done, your module is built with lead free solder and rework is trickier as the temperature needed to melt the solder can be twice as high as leaded. This means you may need a better iron and need to use careful soldering techniques not to damage the board.
21hertz
It is the same issue I guess. Erratic behavior of the pot. Works fine when using CV.

I just got an answer from Malekko. I will probably send it in to be repaired. Malekko are US-based so it will take time I guess.
MUFF WIGGLER Forum Index -> Wiard Goto page Previous  1, 2, 3 [all]
Page 3 of 3
Powered by phpBB © phpBB Group