FX AID - multi audio effect module

Cwejman, Livewire, TipTop Audio, Doepfer etc... Get your euro on!

Moderators: Kent, luketeaford, Joe.

Post Reply
User avatar
xcc
Veteran Wiggler
Posts: 692
Joined: Fri Mar 23, 2018 8:37 am
Location: TX

Re: FX AID - multi audio effect module

Post by xcc » Thu Apr 08, 2021 8:36 am

Oh wow that’s handy. Great idea, thanks!

SavageMessiah
Wiggling with Experience
Posts: 357
Joined: Thu Apr 05, 2018 5:48 pm

Re: FX AID - multi audio effect module

Post by SavageMessiah » Thu Apr 08, 2021 1:59 pm

igorrr wrote:
Thu Apr 08, 2021 7:29 am
Tuner effect generates three fixed frequencies: 220 Hz, 440 Hz, 880 Hz. Left output - sawtooth wave, right output – triangle wave.
4hp FX AID version should have its CV input routed to the Sample Rate and kept unconnected for proper frequencies.
Some warm up time around 10 minutes is required for correct operation.
Huh, I wouldn't expect a digital circuit to need warm up time. Interesting.

orbita
Wiggling with Experience
Posts: 353
Joined: Tue Feb 20, 2018 8:00 am
Location: London

Re: FX AID - multi audio effect module

Post by orbita » Fri Apr 09, 2021 4:05 pm

igorrr wrote:
Thu Apr 08, 2021 7:29 am
Tuner effect generates three fixed frequencies: 220 Hz, 440 Hz, 880 Hz. Left output - sawtooth wave, right output – triangle wave.
4hp FX AID version should have its CV input routed to the Sample Rate and kept unconnected for proper frequencies.
Some warm up time around 10 minutes is required for correct operation.
Hi Igorrr,

I've just been playing with my Fxaid for the first time. It sounds very nice.

I would really like to use it in a dual mono configuration but most of the delays that I want to use are mono in, stereo out.

Would it be possible to have dual mono operation for them. I want to keep the channels separate but performing the same effect.

The DelayComb seems to work ok but its the Tape delay, Magneto, Shimmer and other character delays I'd like to use.


Also - would it be possible to have a mode where WET/DRY knob maintains dry signal and just adds WET?

Thanks!
Last edited by orbita on Sat Apr 10, 2021 8:26 am, edited 1 time in total.

bjoerngiesler
Learning to Wiggle
Posts: 22
Joined: Sun Dec 07, 2014 2:07 pm

Re: FX AID - multi audio effect module

Post by bjoerngiesler » Sat Apr 10, 2021 3:16 am

I have a silver FX Aid that I love to bits but that sticks out like a sore thumb in my all-black rack... yeah I know, cosmetics, feel free to ridicule me... but does anyone know if there are replacement panels for these? Haven't found any...

User avatar
hel1
Common Wiggler
Posts: 110
Joined: Sat Aug 25, 2018 6:31 am
Location: Netherlands/Italy

Re: FX AID - multi audio effect module

Post by hel1 » Sat Apr 10, 2021 3:47 am

buy a black one, sell the silver one...

User avatar
bemushroomed
Super Deluxe Wiggler
Posts: 2754
Joined: Sat Oct 25, 2014 10:30 am
Location: Sweden

Re: FX AID - multi audio effect module

Post by bemushroomed » Sat Apr 10, 2021 3:50 am

let it be the module that breaks that ridiculous habit instead ;) you're missing out on tons of modules, you're making the hobby more cumbersome than necessary for no gain.

User avatar
Kosmikos
Wiggling with Experience
Posts: 261
Joined: Thu Nov 26, 2020 1:21 pm
Location: London
Contact:

Re: FX AID - multi audio effect module

Post by Kosmikos » Sat Apr 10, 2021 4:02 am

bjoerngiesler wrote:
Sat Apr 10, 2021 3:16 am
I have a silver FX Aid that I love to bits but that sticks out like a sore thumb in my all-black rack... yeah I know, cosmetics, feel free to ridicule me... but does anyone know if there are replacement panels for these? Haven't found any...
You can buy a Black & Gold panel:
https://www.signalsounds.com/happy-nerd ... black-gold

Bear in mind as I recently found out :doh: that unlike the silver or black, I believe these are not the same metallic material (kind of similar to PCB). But the gold do look nice and shiny and is very readable in low light.

User avatar
hel1
Common Wiggler
Posts: 110
Joined: Sat Aug 25, 2018 6:31 am
Location: Netherlands/Italy

Re: FX AID - multi audio effect module

Post by hel1 » Sat Apr 10, 2021 4:06 am

2 bemushroomed: well, I am having this habit too. my only exception is Pam's. might even make a dark panel for it myself, but on the other hand: as it is my main clock/start-stop devise, I can accept it having a silver panel. (I know it'll end up with a dark panel)

bjoerngiesler
Learning to Wiggle
Posts: 22
Joined: Sun Dec 07, 2014 2:07 pm

Re: FX AID - multi audio effect module

Post by bjoerngiesler » Sat Apr 10, 2021 4:28 am

Getting one from @igorrr ❤️

benamanou
Learning to Wiggle
Posts: 18
Joined: Tue Dec 08, 2020 6:45 am
Location: Belgique

Re: FX AID - multi audio effect module

Post by benamanou » Thu Apr 15, 2021 9:43 am

Something went wrong in my case this afternoon, power related, the vast majority of my modules are okay but my FX AID doesn't outpout at the same level anymore.. It's like wayyyyy lower, when i crank my mixer to hear it i mostly hear gain noise but the L input audio is back there i can hear it a little. What can i possibly to do to get it to work again ? Is it.. Fried ? :(

Did a reflashing of the banks too, not much else i can do

User avatar
xcc
Veteran Wiggler
Posts: 692
Joined: Fri Mar 23, 2018 8:37 am
Location: TX

Re: FX AID - multi audio effect module

Post by xcc » Thu Apr 15, 2021 12:02 pm

benamanou wrote:
Thu Apr 15, 2021 9:43 am
Something went wrong in my case this afternoon, power related, the vast majority of my modules are okay but my FX AID doesn't outpout at the same level anymore.. It's like wayyyyy lower, when i crank my mixer to hear it i mostly hear gain noise but the L input audio is back there i can hear it a little. What can i possibly to do to get it to work again ? Is it.. Fried ? :(

Did a reflashing of the banks too, not much else i can do
Contact Igor through his website. He’ll know what to do.

User avatar
Kosmikos
Wiggling with Experience
Posts: 261
Joined: Thu Nov 26, 2020 1:21 pm
Location: London
Contact:

Re: FX AID - multi audio effect module

Post by Kosmikos » Thu Apr 15, 2021 1:59 pm

benamanou wrote:
Thu Apr 15, 2021 9:43 am
Something went wrong in my case this afternoon, power related, the vast majority of my modules are okay but my FX AID doesn't outpout at the same level anymore.. It's like wayyyyy lower, when i crank my mixer to hear it i mostly hear gain noise but the L input audio is back there i can hear it a little. What can i possibly to do to get it to work again ? Is it.. Fried ? :(

Did a reflashing of the banks too, not much else i can do
I’m not sure after reading your post, but did you try it on a different case power supply? When my -12V rail went my modules sounded wrong simply because there was no -12V anymore. Everything was fine once I tried them on a different PSU.

benamanou
Learning to Wiggle
Posts: 18
Joined: Tue Dec 08, 2020 6:45 am
Location: Belgique

Re: FX AID - multi audio effect module

Post by benamanou » Fri Apr 16, 2021 4:07 am

Kosmikos wrote:
Thu Apr 15, 2021 1:59 pm
benamanou wrote:
Thu Apr 15, 2021 9:43 am
Something went wrong in my case this afternoon, power related, the vast majority of my modules are okay but my FX AID doesn't outpout at the same level anymore.. It's like wayyyyy lower, when i crank my mixer to hear it i mostly hear gain noise but the L input audio is back there i can hear it a little. What can i possibly to do to get it to work again ? Is it.. Fried ? :(

Did a reflashing of the banks too, not much else i can do
I’m not sure after reading your post, but did you try it on a different case power supply? When my -12V rail went my modules sounded wrong simply because there was no -12V anymore. Everything was fine once I tried them on a different PSU.
Well you guessed it right aha I had in fact a problem with my -12v rail ! Another PSU is on the way

Post Reply

Return to “Eurorack Modules”