uO_c 8hp ornament and crime.

From circuitbending to homebrew stompboxes & synths, keep the DIY spirit alive!

Moderators: Kent, luketeaford, Joe.

Post Reply
User avatar
jpeterman
Common Wiggler
Posts: 64
Joined: Tue Aug 20, 2019 1:25 pm
Location: los angeles

Re: uO_c 8hp ornament and crime.

Post by jpeterman » Tue Feb 16, 2021 6:42 pm

First one I ordered was from HiLetGo. This is the one thats in there right now: https://www.amazon.com/gp/product/B07QJ ... UTF8&psc=1

User avatar
Altitude909
Super Deluxe Wiggler
Posts: 3612
Joined: Wed Aug 24, 2011 5:13 pm
Location: Meesheegan

Re: uO_c 8hp ornament and crime.

Post by Altitude909 » Tue Feb 16, 2021 7:31 pm

you have to be careful really, those pics in that listing show two different screens and the HitLetGo ones still have the pic of the old device which was fine but they send something else. I wouldnt put much faith in any of the Amazon ones right now, if one place has the garbage ones, chances are most of them have them too

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Only runs with USB?

Post by corrupt_reverend » Sun Feb 21, 2021 2:25 am

Hey y'all. Long time listener, first time caller. :P

So I finally finished building my uO_c tonight but there seems to be a problem.

I was able to load the latest stable firmware, but the module only seems to power on when the microUSB is plugged in. I get nothing on the screen when I have only the eurorack power attached.

I was able to go into calibration and that stuff seems to have issues too, but I figured I'd start with figuring out the power issue.

Any pointers and/or insight would be greatly appreciated! :)

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 5:11 am

Check the voltage rails, especially the 5V supply

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 3:13 pm

cnicht wrote:
Sun Feb 21, 2021 5:11 am
Check the voltage rails, especially the 5V supply
Did some poking around. I only have 0.2V at Vin on the Teensy when power is plugged in with the red stripe on the left (as viewed from rear), and barely 0.02V with the red stripe on the right.

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 4:01 pm

Is anything getting hot?

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 4:04 pm

Is anything getting hot?

Also do you have D7 soldered the correct way round?

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 4:25 pm

cnicht wrote:
Sun Feb 21, 2021 4:01 pm
Is anything getting hot?
Nothing that I can feel.
Also do you have D7 soldered the correct way round?
I believe so. With the notch illustrated on the PCB at the top, the bevel goes down the left hand side?

Also, just checked voltage at what I believe to be the voltage regulator (two decades since electronics classes combined with adhd makes things tricky. :/ ) and I'm only getting around .9V at most across the pins.

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 4:38 pm

What voltages are you getting on the pins of D7?

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 4:48 pm

cnicht wrote:
Sun Feb 21, 2021 4:38 pm
What voltages are you getting on the pins of D7?
P1-P2 = 21.2V

P1-P3 = -0.5V

P1-P4 = 21.8V

... That can't be right, can it?

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 5:05 pm

Measure wrt GND

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 5:12 pm

cnicht wrote:
Sun Feb 21, 2021 5:05 pm
Measure wrt GND
I'm sorry, I don't understand what that means.

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 5:22 pm

With respect to - connect common of DVM to GND and probe voltages with the other lead.

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 5:28 pm

cnicht wrote:
Sun Feb 21, 2021 5:22 pm
With respect to - connect common of DVM to GND and probe voltages with the other lead.
Oooh, gotcha. Thanks for the clarification.

That's what I did to get the voltages listed above. P2 = gnd as labeled on the package.

Edit: Er, wait.. in a circuit that uses negative voltages, "-" doesn't necessarily mean gnd, does it.. Argh, bit more out of my depth than I had anticipated. haha

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 5:40 pm

Use middle pins of JP1 as GND reference.

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 5:58 pm

cnicht wrote:
Sun Feb 21, 2021 5:40 pm
Use middle pins of JP1 as GND reference.
Okay, I've got:

P1=11.3V

P2=11.4V

P3=12.0V

P4=12.0V

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 6:00 pm

Looks good.

What are the voltages on IC6 wrt GND?

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 6:09 pm

cnicht wrote:
Sun Feb 21, 2021 6:00 pm
Looks good.

What are the voltages on IC6 wrt GND?
With the two pins on top, and the big pin on the bottom:

Top left = 0.9V

Top right = 0.0V

Bottom = 0.2V

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 6:20 pm

Is R60 ok?

Check it’s soldered correctly and is the correct value.

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Sun Feb 21, 2021 6:34 pm

cnicht wrote:
Sun Feb 21, 2021 6:20 pm
Is R60 ok?

Check it’s soldered correctly and is the correct value.
Well I feel silly..

Reading 47kohm and BOM calls for 4.7ohm. :doh:

Thanks a bajillion for helping me through this!!

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Sun Feb 21, 2021 7:01 pm

Excellent

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Mon Feb 22, 2021 8:54 am

Sorry to spam this thread, but a new issue has arisen:

Calibrating the "A" jack for -3V, I can only get it down to -2.22V. That's with the calibration brought all the way down to 0. Before adjustment, it started at -2.05V @ 4890, so very very little change of voltage per click.

I checked the solder connections on the DAC. Had a possible solder bridge so I wicked it up and now it looks pretty darn good, but the problem persists.

User avatar
cnicht
Ultra Wiggler
Posts: 802
Joined: Mon Sep 23, 2013 9:23 am

Re: uO_c 8hp ornament and crime.

Post by cnicht » Mon Feb 22, 2021 1:05 pm

Are the components around the op amp driving this output the correct value?

corrupt_reverend
Learning to Wiggle
Posts: 12
Joined: Wed Apr 04, 2018 8:04 pm
Location: California

Re: uO_c 8hp ornament and crime.

Post by corrupt_reverend » Mon Feb 22, 2021 1:16 pm

cnicht wrote:
Mon Feb 22, 2021 1:05 pm
Are the components around the op amp driving this output the correct value?
Good call considering my last problem. Haha

I'll check that first when I get home from work.

Update: Decided to triple check my solder joints and found that I completely missed a few pins on U3 and U4. Everything is all calibrated up and we're good to go! Thanks again for the help.

deliand
1-Post Wiggler
Posts: 1
Joined: Wed Feb 24, 2021 9:59 pm

Re: uO_c 8hp ornament and crime.

Post by deliand » Wed Feb 24, 2021 10:03 pm

Hi guys, I built this and when I plugged it in the screen lit up, but resistor R60 started smoking. I suspected a short between 3.3v and ground somewhere, but checking continuity several times at every possible place this could happen, I didn’t see any. I then decided to just turn it on for a few seconds to measure the output of regulator IC6. It is supposed to regulate 12V down to 5V but I saw the output oscillate from 10V to 5V and then rise again before I shut it off.

Is this a faulty part, or is there some other explanation for this behavior?

Post Reply

Return to “Music Tech DIY”