Teensy 3.2 in uO_C - Phyically damaged LED = Problems?

From circuitbending to homebrew stompboxes & synths, keep the DIY spirit alive!

Moderators: lisa, luketeaford, Kent, Joe.

Post Reply
User avatar
Overand
Common Wiggler
Posts: 190
Joined: Mon Jul 02, 2012 6:29 pm
Location: Maine, United States

Teensy 3.2 in uO_C - Phyically damaged LED = Problems?

Post by Overand » Tue Jun 30, 2020 9:51 am

EDIT- I'll order a replacement Teensy, for the whole ~$24 USD, too - just hoping to be up and running sooner! And, fixing things is nice.

Folks - I was doing some work on a uO_C (replacing the pin headers on the Teensy 3.2, as part of switching teensy modules between two uO_C modules - a whole different story).

So, there's an LED on the teensy, near the button. From what I can tell on the uO_C schematic and the Teensy 3.2 schematic, this LED is related to the clock on U2, a DAC on the uO_C.

Regardless, this O&C now boots "sometimes." Often it will hang/black screen. The LED is definitely not working, because it's cracked/broken. Does that likely have an effect other than cosmetic? There certainly could be other damage or issues, but, that's all I've seen so far.

Should I try to shoehorn a non-SMD diode there temporarily to test? Etc?

Thanks!
Sites: overand.com | SoundCloud | YouTube ModularGrid: MOTM | Euro
WTB: MOTM Case, Euro VCAs, Sequencers, Env Followers & Interfaces.
Building the modular since ~2003

User avatar
Altitude909
Super Deluxe Wiggler
Posts: 3396
Joined: Wed Aug 24, 2011 5:13 pm
Location: Meesheegan

Re: Teensy 3.2 in uO_C - Phyically damaged LED = Problems?

Post by Altitude909 » Tue Jun 30, 2020 12:49 pm

> Does that likely have an effect other than cosmetic?

none whatsoever, just a programmable indicator

User avatar
emmaker
Veteran Wiggler
Posts: 622
Joined: Sat Mar 10, 2012 5:07 pm
Location: PDX

Re: Teensy 3.2 in uO_C - Phyically damaged LED = Problems?

Post by emmaker » Tue Jun 30, 2020 1:33 pm

Have you changed power supply or added new modules to your synth?

According to the uO&C thread on Muffs some have issues with the power supply causing the Teensy not to run properly. A reset supervisor chip was added to handle this. Search for that thread and see if that maybe your problem.

User avatar
Phitar
Wiggling with Experience
Posts: 481
Joined: Sat Feb 21, 2015 7:54 am
Location: Northern Virginia, USA

Re: Teensy 3.2 in uO_C - Phyically damaged LED = Problems?

Post by Phitar » Wed Jul 01, 2020 8:47 pm

Altitude909 wrote:
Tue Jun 30, 2020 12:49 pm
> Does that likely have an effect other than cosmetic?

none whatsoever, just a programmable indicator
:tu: Agree. Question is.... Is that all you messed up? :despair:

When in doubt...Swap it out!

Hopefully it's in a socket. I just had to change one out last week that was soldered on. What a PITA THAT was! :bang:
At the Enrichment Center we promise never to value your safety above your unique ideas and creativity. - Portal

Waiting for the electrician... or someone like him. - Firesign

Post Reply

Return to “Music Tech DIY”