Kawai K3 won't boot, looking for firmware

From circuitbending to homebrew stompboxes & synths, keep the DIY spirit alive!

Moderators: Kent, luketeaford, Joe., lisa

Post Reply
synth80s
Learning to Wiggle
Posts: 3
Joined: Fri Aug 28, 2020 11:25 pm

Kawai K3 won't boot, looking for firmware

Post by synth80s » Fri Aug 28, 2020 11:32 pm

I just picked up a K3 that also doesn't boot. Here is my summary below:

Guy said it didn’t power and had a burnt cord. Cut open the cord and the burn damage was on the outside not inside so think that was from a space heater or something. Replaced the cord, all PSU voltages are dead on. I turn the switch on, no lights, nobody’s home.

CPU has a good clock, cpu address lines are pulsing, EEPROMs address lines are pulsing, gate array chip that drives the screen and buttons is pulsing, even probing one of the demuxes on the right side and hitting a key on the keyboard I can see it transmitting bits on my scope. Button and screen board has power on components, the logic lines running from the cpu board to the lcd board are pulsing. I noticed the wave forms aren’t pure square, a little bit of modulation on the leading edge But probably normal. The synthesizer board has waveforms all over it, filter chips have power. Forgot to mention all the logic chips on the cpu board have power too, couldn’t find any shorts.

I am not sure where to go from here. As I said it seems the code is executing, yet no lights and display, no sounds. I can only hear a faint pop in the right headphone when powering the synth up. There is voltage on the button board.

I just got the tl866ii and had the same problem as you, the k3m firmware differs drastically.Anyone have a copy of the k3 firmware?

Thanks,

BartBral
Common Wiggler
Posts: 188
Joined: Tue Nov 26, 2019 10:47 am
Location: IC1

Re: Kawai K3 won't boot, looking for firmware

Post by BartBral » Sat Aug 29, 2020 6:28 pm


synth80s
Learning to Wiggle
Posts: 3
Joined: Fri Aug 28, 2020 11:25 pm

Re: Kawai K3 won't boot, looking for firmware

Post by synth80s » Thu Sep 03, 2020 11:02 am

Thanks for the reply! Unfortunately that’s where I downloaded the firmware from but The guy who uploaded it said it was from a k3m (rack mount version) it differs drastically from the firmware I have. I disassembled it and the code is complete so I just believe the keyboard Version k3 has different firmware since it has to scan the keyboard matrix and such. I was hoping someone could upload theirs so I can compare.

User avatar
BadPixel
Common Wiggler
Posts: 63
Joined: Tue Nov 06, 2018 8:23 am
Location: Stockholm, Sweden

Re: Kawai K3 won't boot, looking for firmware

Post by BadPixel » Thu Sep 03, 2020 1:24 pm

I’ve only had (and updated) the K3m and the K4’s, but afaik the fw is different between the keyboard and rack versions. I might have the fw for the keyboard somewhere. I’ll have a look and get back to you.

<edit>
Apparently I was dreaming :confused: I did have a few links saved but not all of them are alive anymore :(

There's some info and dl's for the K3 over at VSE: http://forum.vintagesynth.com/viewtopic ... 1&t=102542. I also had an link to downloads on Kawai's European site. It's still there but seems defunct :( https://www.kawai.co.uk/downloads/
</edit>

synth80s
Learning to Wiggle
Posts: 3
Joined: Fri Aug 28, 2020 11:25 pm

Re: Kawai K3 won't boot, looking for firmware

Post by synth80s » Thu Sep 10, 2020 10:47 pm

Thanks for the links, I'll try the way back machine. I just realized this thing actually has 5 eproms!!

1 27256 on the CPU board for what I assume is firmware
2 27256 on the syn57 board which are for the wavetables
2 2764 on the syn57 board for what I assume is the synth boards firmware? Any ideas?

User avatar
chvad
Super Deluxe Wiggler
Posts: 3386
Joined: Mon Oct 03, 2011 9:23 am
Location: Brooklyn, NY
Contact:

Re: Kawai K3 won't boot, looking for firmware

Post by chvad » Thu Sep 10, 2020 11:15 pm

I know it seems silly but I've reached out to Kawai in the past for chips and such for their older units and somehow they've always managed to respond AND have something useful for me. They've been a remarkably cool company support wise considering they haven't released a synth in ages.

IndyNate
1-Post Wiggler
Posts: 1
Joined: Wed Jan 13, 2021 11:27 am

Re: Kawai K3 won't boot, looking for firmware

Post by IndyNate » Wed Jan 13, 2021 11:44 am

Synth80s, et alii, lemme jump in here and join this thread. I bought a really excellent condition, fully working K3 a decade ago, but only recently started playing it. That said, decided I'd do what I normally do, which is to open the case, inspect, service and replace battery. I've done this to over a dozen 80s boards with no issues, but, when I replaced the batt in my K3, the display ceased to function. I went through all the normal troubleshooting including contact cleaning and reinserting all cables as well as visual inspections. Oddly, the sound engine appears to be functioning perfectly and responds to the dial wheel and membrane switches. For clarification, upon power on a figure 8 appears in the far right LED, then disappears. All this said, I haven't put my scope on the ICs, but I"ll assume they're working, as I have sound and control, just no display. So, my first thought is did I nuke something with electrostatic discharge? Would a failed EEPROM behave like this? Before I tear it apart again and possibly cause more unintended damage, I wanted to revive this thread. I too am looking for the software but still haven't found it. Thanks!

Post Reply

Return to “Music Tech DIY”