Debugging Shruthi XT- digital noise on output

From circuitbending to homebrew stompboxes & synths, keep the DIY spirit alive!

Moderators: Kent, luketeaford, lisa, Joe.

Post Reply
djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Debugging Shruthi XT- digital noise on output

Post by djs » Fri Sep 11, 2020 7:58 am

My Shruthi XT is getting a lot of digital noise on the output. I don't think it's the display as it's very loud- much louder than the normal sound itself (which also sounds distorted). It seems to come on after 2-3 seconds of being on, and is fairly continuous ie. not affected by the envelope. Changing screens or settings seems to trigger it, but it's really hard to say. Also, the filters don't filter the noise in any way, so maybe it's on the ground line? IDK.

To be honest, I'm not a digital guy- any suggestions on where to start? FYI- I'm using the CS80 filter board on it.

Your help is appreciated!
"Noise is what the Earth is made of" - David Bowie

User avatar
cnicht
Veteran Wiggler
Posts: 746
Joined: Mon Sep 23, 2013 9:23 am

Re: Debugging Shruthi XT- digital noise on output

Post by cnicht » Fri Sep 11, 2020 2:22 pm

What sort of power supply are you using?

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Fri Sep 11, 2020 3:07 pm

wall wart- 9v 1amp supply.. so I don't think it's under powered?
"Noise is what the Earth is made of" - David Bowie

User avatar
Bjarne
Common Wiggler
Posts: 109
Joined: Sat Jul 20, 2013 10:31 am
Location: Stockholm

Re: Debugging Shruthi XT- digital noise on output

Post by Bjarne » Fri Sep 11, 2020 4:01 pm

Just checking: have you selected ‘svf’ in the filter settings?

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Fri Sep 11, 2020 5:20 pm

Yes - filter setting is correct :).
"Noise is what the Earth is made of" - David Bowie

snowtires
Common Wiggler
Posts: 85
Joined: Fri Jun 03, 2016 12:58 pm

Re: Debugging Shruthi XT- digital noise on output

Post by snowtires » Fri Sep 11, 2020 7:08 pm

Man, I had lots of problems with Shruthis and 9v supplies, I always used a 12v

User avatar
cnicht
Veteran Wiggler
Posts: 746
Joined: Mon Sep 23, 2013 9:23 am

Re: Debugging Shruthi XT- digital noise on output

Post by cnicht » Sat Sep 12, 2020 2:08 am

djs wrote:
Fri Sep 11, 2020 3:07 pm
wall wart- 9v 1amp supply.. so I don't think it's under powered?
Have you looked at its output without it being connected to the Shruthi?

User avatar
Altitude909
Super Deluxe Wiggler
Posts: 3491
Joined: Wed Aug 24, 2011 5:13 pm
Location: Meesheegan

Re: Debugging Shruthi XT- digital noise on output

Post by Altitude909 » Sat Sep 12, 2020 8:15 am

what type of display are you using

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Sat Sep 12, 2020 9:39 am

Ok- so I switched out to a 1amp, 12V supply and it had the same problem. I notice that once the digital sounding garbage starts (about 5-10 seconds after turning on) the sound other than the digital noise sounds like it has a LPF on it, no matter what the actual setting is. It works before the 5-10 seconds, so I know I have the settings right. I have a theory that maybe something is funky with the CD4053s on the filter board? Thoughts?

Not sure what the display is... or at least I can’t remember what I put in there.
"Noise is what the Earth is made of" - David Bowie

User avatar
cnicht
Veteran Wiggler
Posts: 746
Joined: Mon Sep 23, 2013 9:23 am

Re: Debugging Shruthi XT- digital noise on output

Post by cnicht » Sat Sep 12, 2020 10:35 am

It sounds like something is heating up and generating random oscillations

User avatar
Altitude909
Super Deluxe Wiggler
Posts: 3491
Joined: Wed Aug 24, 2011 5:13 pm
Location: Meesheegan

Re: Debugging Shruthi XT- digital noise on output

Post by Altitude909 » Sat Sep 12, 2020 10:40 am

djs wrote:
Sat Sep 12, 2020 9:39 am
..
Not sure what the display is... or at least I can’t remember what I put in there.
Was it an OLED or a LCD with LED backlight

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Sat Sep 12, 2020 5:48 pm

Looks like an LCD with backlight
"Noise is what the Earth is made of" - David Bowie

User avatar
AlanP
Ultra Wiggler
Posts: 969
Joined: Fri Mar 14, 2014 8:37 pm
Location: New Zealand

Re: Debugging Shruthi XT- digital noise on output

Post by AlanP » Sun Sep 13, 2020 2:15 am

Are you running wires for the volume pot, or using the built-in volume thing?

User avatar
Altitude909
Super Deluxe Wiggler
Posts: 3491
Joined: Wed Aug 24, 2011 5:13 pm
Location: Meesheegan

Re: Debugging Shruthi XT- digital noise on output

Post by Altitude909 » Sun Sep 13, 2020 6:30 am

Sounds like digital bus noise. Does it get worse when you turn one of the pots? Has anyone actually tested the CS80 filter on the XT?

User avatar
Flounderguts
Ultra Wiggler
Posts: 753
Joined: Thu Dec 07, 2017 5:56 pm
Location: SLC
Contact:

Re: Debugging Shruthi XT- digital noise on output

Post by Flounderguts » Sun Sep 13, 2020 7:51 am

Me. I have an XT with CS80 filter. No issues.
----------------------

Flounderguts

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Sun Sep 13, 2020 8:15 am

Altitude909 wrote:
Sun Sep 13, 2020 6:30 am
Sounds like digital bus noise. Does it get worse when you turn one of the pots? Has anyone actually tested the CS80 filter on the XT?
Yes it does... or when menus are changing.

Also I’m using the built in volume knob... no wires
"Noise is what the Earth is made of" - David Bowie

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Sun Sep 13, 2020 4:30 pm

I posted a sample of it on IG here:



It worked fine for about 2.5 min and then did this. Maybe it’s overheating? Something more digital based? A cap that’s charging up slowly and then getting angry?

Next step is to take it apart and see how hot everything gets when it starts glitching?
"Noise is what the Earth is made of" - David Bowie

User avatar
Flounderguts
Ultra Wiggler
Posts: 753
Joined: Thu Dec 07, 2017 5:56 pm
Location: SLC
Contact:

Re: Debugging Shruthi XT- digital noise on output

Post by Flounderguts » Tue Sep 15, 2020 7:46 am

Are you using RAM different from what was specified? Someone posted about digital noise from RAM in MI DIY thread.
----------------------

Flounderguts

djs
Super Deluxe Wiggler
Posts: 1176
Joined: Wed Sep 01, 2010 8:36 am
Location: South Beloit, IL

Re: Debugging Shruthi XT- digital noise on output

Post by djs » Tue Sep 15, 2020 9:08 am

Interesting- I don't think so, but I'll check!
"Noise is what the Earth is made of" - David Bowie

snowtires
Common Wiggler
Posts: 85
Joined: Fri Jun 03, 2016 12:58 pm

Re: Debugging Shruthi XT- digital noise on output

Post by snowtires » Tue Sep 15, 2020 9:18 am

Check the soldering around the Atmega and the CD4051, maybe replace the 4051 if you have an extra since they're cheap. They're the two chips that deal with the digital aspects of the Shruthi and how it reads the pots

User avatar
Altitude909
Super Deluxe Wiggler
Posts: 3491
Joined: Wed Aug 24, 2011 5:13 pm
Location: Meesheegan

Re: Debugging Shruthi XT- digital noise on output

Post by Altitude909 » Tue Sep 15, 2020 9:25 am

Flounderguts wrote:
Tue Sep 15, 2020 7:46 am
Are you using RAM different from what was specified? Someone posted about digital noise from RAM in MI DIY thread.
no ram in the shurthi, its ATmega644 based, not ARM like the one in the DIY thread

User avatar
cnicht
Veteran Wiggler
Posts: 746
Joined: Mon Sep 23, 2013 9:23 am

Re: Debugging Shruthi XT- digital noise on output

Post by cnicht » Tue Sep 15, 2020 2:28 pm

Have you measured the power rails when the fault occurs?

snowtires
Common Wiggler
Posts: 85
Joined: Fri Jun 03, 2016 12:58 pm

Re: Debugging Shruthi XT- digital noise on output

Post by snowtires » Tue Sep 15, 2020 3:15 pm

Speaking of making sure the filter is on the right setting, I vaguely remember there being either a specific power on combo or a menu setting to signify that it's a Shruthi XT. It's been a few years since I built one, I forget what the deal was, but seeing the display going crazy like that in the video reminded me of it.

snowtires
Common Wiggler
Posts: 85
Joined: Fri Jun 03, 2016 12:58 pm

Re: Debugging Shruthi XT- digital noise on output

Post by snowtires » Tue Sep 15, 2020 3:19 pm

From Emilie: Try booting the synth with the encoder pressed until the screen shows:

shruthi xt
(full control)

From this thread:https://www.google.com/url?sa=t&source= ... Ehk0c9tf3k

The OP in that thread's issue was caused by two swapped chips, check that out on yours

Post Reply

Return to “Music Tech DIY”