Why? Overdrive pedals having jumpy Gain controls on my Send

A place for the string slingers, pedal freaks and amp snobs in our midst.

Moderators: Joe., lisa, luketeaford, Kent

Post Reply
Technologear?
Wiggling with Experience
Posts: 306
Joined: Fri Aug 11, 2017 7:08 am
Location: Straya

Why? Overdrive pedals having jumpy Gain controls on my Send

Post by Technologear? » Mon Oct 28, 2019 2:01 am

I've tried a number of overdrive pedals on my mixer sends, and they all seem to do the same thing: their controls become really sensitive, going from 'not much' to 'heaps' from barely a twist of the knob.
I haven't tried boutique pedals just what I have available, stuff from danelectro, behri, mooer, ehx.
Could this be a line level impedance issue, or just something associated with cheaper pedals? My tube amp and mixer channel gains don't behave like this.

User avatar
BailyDread
Wiggling with Experience
Posts: 265
Joined: Tue Oct 23, 2018 12:55 pm

Post by BailyDread » Tue Oct 29, 2019 11:08 am

The pedals are expecting instrument level signal and you're feeding it a line level signal. That coupled with the fact that your sends are almost certainly balanced connections while the pedal is expecting unbalanced is where this is coming from.

A re-amping device from Radial would help you, or you could use a DI box in reverse. There's lots of information online about how to do both of those things :tu:

Technologear?
Wiggling with Experience
Posts: 306
Joined: Fri Aug 11, 2017 7:08 am
Location: Straya

Post by Technologear? » Wed Oct 30, 2019 3:43 am

I have plenty of DIs floating around, I'll utilise them, thanks (again) BD!

Post Reply

Return to “Guitars, Basses, Amps & FX”