fender silver face bronco trem/vib malfuntion?repair help?

A place for the string slingers, pedal freaks and amp snobs in our midst.

Moderators: Joe., lisa, luketeaford, Kent

Post Reply
User avatar
Severed head
Veteran Wiggler
Posts: 510
Joined: Tue Sep 24, 2019 9:24 am

fender silver face bronco trem/vib malfuntion?repair help?

Post by Severed head » Wed Jan 29, 2020 3:35 pm

hello friends,
I have a fender Silverface (1974) bronco amp, im not sure if its and AA764 or AB764, oddly the serial number doesnt have a letter and I could only find info on serials with and "A" before the number.

but the trem/vib kinda works... I guess, it works some times and others not. I have a few latching switches, all passive ,basically a switch in a box a few even the same brand of switch, and periodically one won't work but the other will, or none will, and periodically if none of the latching will fire off the trem/vib a momentary switch will(while held down)

ive obviously checked my chord well as I only have the one chord that has the RCA head on it and each time it flops I check my chord if just changing the latching switch doesnt work.


anyone know anything about testing the term/vib circuit in a siverface amp? or the bulb, to confirm if thats the issue or if its another part of the circuit?
im probably presumptuously assuming that fender silver face amps have the same term circuit.
WTB: modules, MA35 filter.
:help:

User avatar
sduck
experimental use of gravity
Posts: 13602
Joined: Wed Feb 18, 2009 6:03 pm
Location: Vortepexaion, TN, USA

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by sduck » Wed Jan 29, 2020 10:50 pm

I'm not sure what you're saying about the switch - do you mean a footswitch, or some kind of replacement thing?

I don't have any vintage fender amps currently, although I've had more than my fair share of blackface and silverface twins and such over the years. If the bronco works anything like those, it'll work without the footswitch by dialing in or out the intensity knob, if I recall correctly. I never used the footswitches with these amps - if I even had them - whenever I'd play gigs with them, they'd be stolen almost immediately. But i don't know enough about the bronco amp to go on much further - do you have a schematic for it you could post?
flickr cloud of sound touyube NOT A MODERATOR ANYMORE

User avatar
Severed head
Veteran Wiggler
Posts: 510
Joined: Tue Sep 24, 2019 9:24 am

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Severed head » Thu Jan 30, 2020 12:40 pm

bronco_ab764_schem.gif
hey S,
thanks for the reply.
sorry yeah referring to the foot switch.
Ive 99% confirmed its a bronco AB764, by the year, according to a few shops, but also been told the circuits of the AA & AB are so close to identical theres no need to search to hard for one or the other.

I have these 2 images, i really just wasn't sure how I could do much testing of what may be actually causing the malfunction. was wondering is it possible the lightbulb component starting to fail possibly and that being why its intermittent. or if possibly the internal jack wiring or a component is just old, shorted or loose.

- the bronco is probably the same tremolo as all the silver faces the only difference is probably the foot switch connection jack & cable
on the Bronco (& I think vibro champ) the foot switch (like the other fender Amps) has an attached cable, but the male end of the cable is a RCA plug and of course a female RCA jack on the amp.
im not sure is there possibly something im not catching or knowledgeable about the RCA plug/jack?
ive had a twin (silverface) the one I had the Tremolo would work with out the foot switch, but only if the trem was activated when the foot switch was unplugged, so with out it you could dial in the trem but if it was bypassed when the foot switch was unplugged the intensity know wouldn't do anything.
this may be a one off though as that twin was molested by various dingdongs before I got it for 100$!!!

- just looking over a few documents, is there a tube in the trem circuit ? 12ax7a maybe thats on its way out..
idk. I really shouldn't be fucking around with this thing, im probably gonna break it more. LOL, but it was free excluding shippingnso I figured its a good learners project.
bronco_ab764_layout copy.gif
s
You do not have the required permissions to view the files attached to this post.
WTB: modules, MA35 filter.
:help:

User avatar
Just me
Has enough VCA's
Posts: 4488
Joined: Sat Apr 10, 2010 11:45 am
Location: Downtown

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Just me » Thu Jan 30, 2020 8:45 pm

A learners project. Good or bad is subjective.
Just be damned well aware that random poking around in a tube amp can expose you to lethal voltages. Get some local experienced help to guide you around.
If I have water in my ear, is it safe for me to listen to electronic music?

User avatar
Severed head
Veteran Wiggler
Posts: 510
Joined: Tue Sep 24, 2019 9:24 am

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Severed head » Thu Jan 30, 2020 9:03 pm

Just me wrote:
Thu Jan 30, 2020 8:45 pm
A learners project. Good or bad is subjective.
Just be damned well aware that random poking around in a tube amp can expose you to lethal voltages. Get some local experienced help to guide you around.
yeah, I planned on discharging everything before I got to wild...
unfortunately my location is prohibitive to getting anyone to look over it without shipping.
and ive been to the local shops all of which are over 1.5hrs drive...

the guys response to some basic questions about electronics were pretty discouraging.
so im opting for figuring it out myself
fortunately the amp works fine excluding the tremolo issue.
WTB: modules, MA35 filter.
:help:

User avatar
sduck
experimental use of gravity
Posts: 13602
Joined: Wed Feb 18, 2009 6:03 pm
Location: Vortepexaion, TN, USA

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by sduck » Thu Jan 30, 2020 11:21 pm

Severed head wrote:
Thu Jan 30, 2020 12:40 pm

- just looking over a few documents, is there a tube in the trem circuit ? 12ax7a maybe thats on its way out..
Well yeah. V2 is just for the tremelo. First thing to do is check it, replace if needed. Dollars to donuts that's the problem, there's not a lot else involved in the circuit that would go bad.

Do you know offhand if this thing has ever been recapped? There's a bunch of 45 year old electrolytic caps in this thing if not, and they'll want to be replaced to get this thing working properly and/or keep it working.
flickr cloud of sound touyube NOT A MODERATOR ANYMORE

User avatar
Revok
Veteran Wiggler
Posts: 734
Joined: Sun Jan 15, 2012 12:11 pm
Location: Phoenix

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Revok » Fri Jan 31, 2020 12:14 am

The tremolo should work without a footswitch. If it's intermittently working without the footswitch plugged in, then it could be a cracked solder joint or loose/dirty tube socket. Try cleaning and retensioning the sockets and inspect the solder joints while you have it open.

User avatar
Just me
Has enough VCA's
Posts: 4488
Joined: Sat Apr 10, 2010 11:45 am
Location: Downtown

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Just me » Fri Jan 31, 2020 6:32 am

Spend a bit of time on the "D-lab electronics" and "uncle Doug" YouTube channels. They have some great tutorials on theory and practical tube amp service.
If I have water in my ear, is it safe for me to listen to electronic music?

User avatar
Severed head
Veteran Wiggler
Posts: 510
Joined: Tue Sep 24, 2019 9:24 am

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Severed head » Fri Jan 31, 2020 10:07 am

Just me wrote:
Fri Jan 31, 2020 6:32 am
Spend a bit of time on the "D-lab electronics" and "uncle Doug" YouTube channels. They have some great tutorials on theory and practical tube amp service.
D-Lab is actually on of the YT channels I been checking out, will check out the other as well
thanks for the tip.
Revok wrote:
Fri Jan 31, 2020 12:14 am
The tremolo should work without a footswitch. If it's intermittently working without the footswitch plugged in, then it could be a cracked solder joint or loose/dirty tube socket. Try cleaning and retensioning the sockets and inspect the solder joints while you have it open.
with out a FS plugged in I get nothing when cranking up the intensity,
some times I can here a bit of a hum or buzz if I crank it up but thats also an intermittent thing
once when the tremolo was working (w/ the FS) I tried unplugging the FS to see if the trem would stay activated but it shut off when I unplugged it.
with a FS I only get the tremolo about 5% of the time the other times its the buzz/hum or just a little click sound then no change.
sduck wrote:
Thu Jan 30, 2020 11:21 pm
Do you know offhand if this thing has ever been recapped? There's a bunch of 45 year old electrolytic caps in this thing if not, and they'll want to be replaced to get this thing working properly and/or keep it working.
im not sure yet, Its been a while since I pulled it open.
the only thing I know for sure has been replaced is the speaker and the knobs, (not the pots tho) as I put new ones off another fender amp.
other than the trem it works and sounds good,
I dont here the usually humming or static crumbling sound that I have been told (when I heard it) is the caps working towards dead.

thanks for all the tips guys!!!
im gonna pull it open this weekend and see what I can figure out.
just thought id search for tips before I got this sucker splattered across my table and cats sleeping on my tools...
WTB: modules, MA35 filter.
:help:

User avatar
sduck
experimental use of gravity
Posts: 13602
Joined: Wed Feb 18, 2009 6:03 pm
Location: Vortepexaion, TN, USA

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by sduck » Fri Jan 31, 2020 1:09 pm

Replace V2 before pulling it all apart.
flickr cloud of sound touyube NOT A MODERATOR ANYMORE

User avatar
Revok
Veteran Wiggler
Posts: 734
Joined: Sun Jan 15, 2012 12:11 pm
Location: Phoenix

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Revok » Fri Jan 31, 2020 7:15 pm

Weird. Post some photos when you get it open.

User avatar
Severed head
Veteran Wiggler
Posts: 510
Joined: Tue Sep 24, 2019 9:24 am

Re: fender silver face bronco trem/vib malfuntion?repair help?

Post by Severed head » Sat Feb 01, 2020 7:39 am

will do im gonna plug it up today, as ive been busy with some recordings, and just wrapped them up, so ill have the afternoon to fiddle around with it.

ill try to see if tube V2 is glowing. and if it is or isn't, glowing I think a store around hear has a tube tester and ill have them through it on there.
the guy at the local shop (as local as it can be in Appalachia (1.5hrs)) is an old timer who likes synths he said he "used them plug in kind" back in the 70's he's like 90 yrs old (literally) but never heard of or seen euro so im been looking for an excuse to drive over an chat with him and let him jam on my case for a bit.
WTB: modules, MA35 filter.
:help:

Post Reply

Return to “Guitars, Basses, Amps & FX”