TR 909 Eprom problems ?

Any music gear discussions that don't fit into one of the other forums.

Moderators: Kent, luketeaford, Joe.

Post Reply
mckenzie
Learning to Wiggle
Posts: 18
Joined: Mon Mar 20, 2017 8:09 am
Location: UK

TR 909 Eprom problems ?

Post by mckenzie » Wed Apr 07, 2021 1:11 pm

Hi there, a friend has given me his 909 to look at. He says the problems started roughly after he had the the eprom V4 fitted about 10 years ago so I would suspect something problematic there but not sure, it was fitted professionally so he says.

Before I go poking around I was wondering if anyone recognises any of these problems?
Some of the low velocity settings don't trigger on a few of the parts (kick, tom etc). Mid tom will only trigger its pattern randomly. Crash only triggers when the ride is triggered in the same sequencer position. Some occasional what seems like random triggering of parts is happening.
Also he says sometimes the unit will freeze up completely & you have to cycle the power to reset.

Thanks for any insight

maxwellravitz
Common Wiggler
Posts: 178
Joined: Fri Dec 30, 2011 1:06 pm
Location: Asheville, NC

Re: TR 909 Eprom problems ?

Post by maxwellravitz » Thu Apr 08, 2021 12:15 am

Sounds to me like some trigger logic gate issues, which certainly could be CPU related. I would probe the traces around the CPU. Those old Roland PCBs might as well be cardboard, so it's very easy to lift traces when desoldering unsocketed IC's. Having done that particular IC swap before, it's in a tricky spot to work on.

Post Reply

Return to “General Gear”