ISLA Instruments SP-2400

Any music gear discussions that don't fit into one of the other forums.

Moderators: Kent, luketeaford, Joe., lisa

Post Reply
david_r
Wiggling with Experience
Posts: 497
Joined: Fri Dec 12, 2014 12:23 am
Location: SF Bay Area

Re: ISLA Instruments SP-2400

Post by david_r » Tue Dec 29, 2020 1:03 am

tigerhill wrote:
Mon Dec 28, 2020 2:50 pm
syzygywell wrote:
Sun Dec 27, 2020 3:36 pm
As some have noted I had the audio board sync fail message 3 times or so. Others have a Comm fail message. So if you can do surface mount soldering and want to put a dollop on there yourself you can. I didn't have anything but a lousy old radio shack soldering iron and didn't want to chance it so mine went back for the repair.
I am in the range but haven’t had it yet - I don’t want to run into problems down the road so thinking about sending it in.

What could I do to bring out the issue if my unit is affected?
I’ve only experienced the issue when powering via power bank so you can try that. The issue is a floating pin on one of the CPUs so it’s not easy to replicate. I’m guessing testing different power sources might bring it out? Or power it with a variable power supply and sweep the voltage around slightly.

david_r
Wiggling with Experience
Posts: 497
Joined: Fri Dec 12, 2014 12:23 am
Location: SF Bay Area

Re: ISLA Instruments SP-2400

Post by david_r » Wed Dec 30, 2020 4:21 pm

I faced the issue multiple times back to back the other night after switching SD cards. Just finished doing the fix myself and everything looks like it went well. It just involves shorting 2 adjacent pins on the CPU.

tigerhill
Common Wiggler
Posts: 85
Joined: Sat Aug 01, 2020 9:36 am

Re: ISLA Instruments SP-2400

Post by tigerhill » Wed Dec 30, 2020 4:33 pm

I have very little solder experience... don’t feel I can do myself but seems like it’s an easy fix

User avatar
syzygywell
aligned wiggler
Posts: 1622
Joined: Wed Jul 08, 2009 1:26 pm
Location: Sasquatch territory

Re: ISLA Instruments SP-2400

Post by syzygywell » Tue Jan 12, 2021 7:52 pm

tigerhill wrote:
Mon Dec 28, 2020 2:50 pm
syzygywell wrote:
Sun Dec 27, 2020 3:36 pm
As some have noted I had the audio board sync fail message 3 times or so. Others have a Comm fail message. So if you can do surface mount soldering and want to put a dollop on there yourself you can. I didn't have anything but a lousy old radio shack soldering iron and didn't want to chance it so mine went back for the repair.
I am in the range but haven’t had it yet - I don’t want to run into problems down the road so thinking about sending it in.

What could I do to bring out the issue if my unit is affected?
Not all units have the issue mine did. The turn around is a day. I sent it back over the holidays so it took twice as long to reach ISLA Instruments as it did to ship to me the first time. But it's really on average about a 2 week turn around which isn't bad.
It's been a long time since someone wrote a really good book in jail.

https://www.instagram.com/instrumentsofflight/

tigerhill
Common Wiggler
Posts: 85
Joined: Sat Aug 01, 2020 9:36 am

Re: ISLA Instruments SP-2400

Post by tigerhill » Tue Jan 12, 2021 10:40 pm

I ended up having the issue after putting the gear to work for about a week. I sent it in to Isla and they fixed it the same day they got it (amazing!) and shipped it back the next morning first thing. There and back it took 7 days total. I would say overall great service for a small company.

Love this thing so far.

Leighzi88
Learning to Wiggle
Posts: 21
Joined: Sat Jul 25, 2020 3:36 am

Re: ISLA Instruments SP-2400

Post by Leighzi88 » Thu Jan 14, 2021 7:50 am

Anyone else hearing a click / pop noise at the end of their one shot samples? I’ve tried to minimise the noise with the envelope and zero crossing but still hearing it. My samples are 48khz and 16 bit which is the recommended format.

User avatar
h4ndcrafted
Super Deluxe Wiggler
Posts: 4055
Joined: Wed Jan 18, 2012 2:27 pm

Re: ISLA Instruments SP-2400

Post by h4ndcrafted » Thu Jan 14, 2021 8:05 am

I’ve been sitting on my hands with this one for so long now , partly because I don’t have the budget right now. It is gonna be interesting to see how it develops for sure.

Never used an SP but the interface is so fantastic.
We don't want to conquer space at all. We want to expand Earth endlessly. We don't want other worlds; we want a mirror.

tigerhill
Common Wiggler
Posts: 85
Joined: Sat Aug 01, 2020 9:36 am

Re: ISLA Instruments SP-2400

Post by tigerhill » Thu Jan 14, 2021 9:20 am

h4ndcrafted wrote:
Thu Jan 14, 2021 8:05 am
I’ve been sitting on my hands with this one for so long now , partly because I don’t have the budget right now. It is gonna be interesting to see how it develops for sure.

Never used an SP but the interface is so fantastic.
It definitely has some firmware issues so far but the forums are active and I know they are working on the updates. They are taking a lot of user input which is cool. Still have to see the speed they put the updates now but it is usable already but some bugs are more annoying than others.

Overall the interface is really satisfying - I bought it because of my love for roule era house music and Alan braxes music. I wasn’t sure how I would jive with it because I’ve never used hardware samplers. The interface with faders is oddly really good and quick and also the fact that it is not laid out as a keyboard I think also makes you think differently about sampling which is a cool limitation.

User avatar
syzygywell
aligned wiggler
Posts: 1622
Joined: Wed Jul 08, 2009 1:26 pm
Location: Sasquatch territory

Re: ISLA Instruments SP-2400

Post by syzygywell » Thu Jan 14, 2021 6:27 pm

Leighzi88 wrote:
Thu Jan 14, 2021 7:50 am
Anyone else hearing a click / pop noise at the end of their one shot samples? I’ve tried to minimise the noise with the envelope and zero crossing but still hearing it. My samples are 48khz and 16 bit which is the recommended format.

Yes if you check the forum for ISLA instruments there are definitely a list of reported bugs. There are some issues with pops, noise, and loss of samples when saving projects. There is a firmware update coming soon from what I understand that will be addressed soon I hope. They've got 2 devs and that's it but Mickey is pretty involved in the forum. I see far less from Vladamir.
It's been a long time since someone wrote a really good book in jail.

https://www.instagram.com/instrumentsofflight/

User avatar
h4ndcrafted
Super Deluxe Wiggler
Posts: 4055
Joined: Wed Jan 18, 2012 2:27 pm

Re: ISLA Instruments SP-2400

Post by h4ndcrafted » Fri Jan 15, 2021 4:27 am

tigerhill wrote:
Thu Jan 14, 2021 9:20 am
h4ndcrafted wrote:
Thu Jan 14, 2021 8:05 am
I’ve been sitting on my hands with this one for so long now , partly because I don’t have the budget right now. It is gonna be interesting to see how it develops for sure.

Never used an SP but the interface is so fantastic.
It definitely has some firmware issues so far but the forums are active and I know they are working on the updates. They are taking a lot of user input which is cool. Still have to see the speed they put the updates now but it is usable already but some bugs are more annoying than others.

Overall the interface is really satisfying - I bought it because of my love for roule era house music and Alan braxes music. I wasn’t sure how I would jive with it because I’ve never used hardware samplers. The interface with faders is oddly really good and quick and also the fact that it is not laid out as a keyboard I think also makes you think differently about sampling which is a cool limitation.

I once described my perfect sampler company’s should put out now, and realised it was the SP.
Even before I started buying gear I fell in love with the look of it, before I even understood what it did, from this record cover.

Image
We don't want to conquer space at all. We want to expand Earth endlessly. We don't want other worlds; we want a mirror.

Post Reply

Return to “General Gear”