disting mk4 sd card help - clocked delay

Discussion and support for Expert Sleepers' Silent Way software and hardware.

Moderators: Kent, os

Post Reply
tuj
Super Deluxe Wiggler
Posts: 3136
Joined: Mon May 17, 2010 9:28 pm
Location: Connecticut
Contact:

disting mk4 sd card help - clocked delay

Post by tuj » Fri Jun 26, 2020 4:03 pm

Hi all:

I have tried using SD cards from SanDisk that are both class-10, one was rated for 80MB/s and the other was 98MB/s. Both are giving me glitches when I'm using the clocked SD card delay algorithm. The glitches are not constant, but frequent enough to cause problems. I tried altering the wave sample rate in the settings but that didn't seem to have any effect.

What speed card do I need?

User avatar
sagetone
Wiggling with Experience
Posts: 257
Joined: Thu Aug 29, 2013 7:52 pm
Location: Houston, TX
Contact:

Re: disting mk4 sd card help - clocked delay

Post by sagetone » Fri Jun 26, 2020 5:05 pm

Hi tuj, I have the same issue. Two Mk4's, trying to use SD cards for Stereo Delays. (Currently on 4.14.2, haven't done the bootloader update yet). I had the same issue as you have described with 16G and 32G Class-10 Samsung Evo cards, and also with 64G U3 Evo cards. I'm going to try to format again and see if that fixes it. Hope that Os can weigh in on this.

Also, I've been reading another post, titled "disting mk4 SD card problem", and Os mentions that 32G are needed. Should I format my 64G U3 cards and partition to 32G?

EDIT: I formatted to FAT32 and partitioned to 32GB (in Disk Management in Win 10) and it now seems to work well. Next step will be to update to latest FW, incl bootloader.

EDIT2: I ran all of the SD Delay algos and it is working well. Conclusion: Mk4 seems to like U3 32G card (at least mine does). Only issue is that every few minutes or so, I'll hear ~ a second of what sounds like audio buffer issues and then it catches back up. Didn't seem to do this on all of the SD Delay algos either.
Last edited by sagetone on Fri Jun 26, 2020 9:59 pm, edited 2 times in total.

tuj
Super Deluxe Wiggler
Posts: 3136
Joined: Mon May 17, 2010 9:28 pm
Location: Connecticut
Contact:

Re: disting mk4 sd card help - clocked delay

Post by tuj » Fri Jun 26, 2020 8:15 pm

I have a 32GB card myself. That doesn't seem to be the issue.

User avatar
sagetone
Wiggling with Experience
Posts: 257
Joined: Thu Aug 29, 2013 7:52 pm
Location: Houston, TX
Contact:

Re: disting mk4 sd card help - clocked delay

Post by sagetone » Fri Jun 26, 2020 9:49 pm

tuj, did you say yours is Class-10 (U1)? I had U1's and it didn't work as well as the U3's now do.

tuj
Super Deluxe Wiggler
Posts: 3136
Joined: Mon May 17, 2010 9:28 pm
Location: Connecticut
Contact:

Re: disting mk4 sd card help - clocked delay

Post by tuj » Sat Jun 27, 2020 7:33 am

sagetone wrote:
Fri Jun 26, 2020 9:49 pm
tuj, did you say yours is Class-10 (U1)? I had U1's and it didn't work as well as the U3's now do.
Yes, honestly I'm a little confused because I had one SanDisk 32GB that said 80MB/s and another of the same size that said 93MB/s and they were both listed as Class-10. I'm a little surprised because I use these same SD cards with: 4MS Wave Recorder, 1010 Bitboxes, TTA ONE, 2HP Play. All of those modules play samples off the card or at least read the cards and the wave recorder writes also as do the bit boxes. The SanDisk cards (the red and gray ones) work fine in those. I've also used the SanDisk 64GB (the yellow and gray one) to good effect.

I just ordered a card that says it's 300MB/s UHS-II. Hopefully that works but honestly this is really disappointing because I've got a performance tonight and I was really hoping to be able to use the SD card delay in the Disting.

tuj
Super Deluxe Wiggler
Posts: 3136
Joined: Mon May 17, 2010 9:28 pm
Location: Connecticut
Contact:

Re: disting mk4 sd card help - clocked delay

Post by tuj » Sat Jun 27, 2020 10:13 pm

Well I swapped the SD delay for a D2 tape delay which isn't the same at all but at least added a little bit. I would really like to know what my issue is with the SD card delay and why it glitches out. What is the "approved" card to use? I couldn't find it.

User avatar
sagetone
Wiggling with Experience
Posts: 257
Joined: Thu Aug 29, 2013 7:52 pm
Location: Houston, TX
Contact:

Re: disting mk4 sd card help - clocked delay

Post by sagetone » Mon Jun 29, 2020 2:16 pm

Hi tuj, hope your gig went well even though you weren't able to use the Disting SD delay. I've been playing all of the SD delays in one of my Mk4s for many hours, and it is finally working well, with one exception. This is the card that finally works for me and the settings on the Disting:

Samsung Evo Select, 64GB, Class 10, U3. (I'm pretty sure the U3 is the most important spec, use it instead of a U1). I formatted in Win 10 using Disk Management because I planned on partitioning into two 32GB volumes. Oddly enough, it showed up as a 32GB card even though it's clearly marked 64GB on the card itself and with the packaging. Oh well. Formatted 32GB FAT. And then set Disting from 75Mhz to 48Mhz. I also set the max SD delay time to 10 minutes. (I doubt that changes performance though).

Here's the one exception, the one issue that I am still having. There is an audibly noticeable audio buffer issue that lasts for about 1 second, and then the Disting uprights itself and keeps going. This happens intermittently, and seems to occur every 5ish minutes or so. In other words, very sporadic, not frequent, but when it happens it's a little irritating.

Os, can you comment on the issue I just wrote about?

tuj
Super Deluxe Wiggler
Posts: 3136
Joined: Mon May 17, 2010 9:28 pm
Location: Connecticut
Contact:

Re: disting mk4 sd card help - clocked delay

Post by tuj » Mon Jun 29, 2020 2:37 pm

So just to confirm, class 10, U3 and you are still getting the occasional glitch? Mine was happening about once a minute roughly so I'm guessing the write or read access of the card is the issue. I have a 32GB UHS-II on the way that claims to do 300Mb/s which is 3x my current SanDisk card. I understand that the Disting MK4 probably(?) has a UHS-I slot so the speed should be limited by the Disting hardware at that point and not the card, at least in theory.

User avatar
sagetone
Wiggling with Experience
Posts: 257
Joined: Thu Aug 29, 2013 7:52 pm
Location: Houston, TX
Contact:

Re: disting mk4 sd card help - clocked delay

Post by sagetone » Mon Jun 29, 2020 8:57 pm

Yes, I'm getting the occasional glitch, but it's less frequent than once a minute, more like once every 5 minutes or so.

User avatar
pretendingtosee
Learning to Wiggle
Posts: 34
Joined: Sat Nov 24, 2012 7:59 pm
Location: Madrid

Re: disting mk4 sd card help - clocked delay

Post by pretendingtosee » Tue Jun 30, 2020 2:10 pm

I’m having a similar problem with my disting mk4 using K7 - stereo clocked delay- it will glitch , sometimes like crazy sometimes every minute or so. I’m using a Sandisc 32 gb uhs card (recommend by expert sleepers in the manual) is this just a limitation of the disting or has anyone found a solution to this? :despair:

User avatar
sagetone
Wiggling with Experience
Posts: 257
Joined: Thu Aug 29, 2013 7:52 pm
Location: Houston, TX
Contact:

Re: disting mk4 sd card help - clocked delay

Post by sagetone » Tue Jun 30, 2020 7:45 pm

Hi os,

Can you provide insight on this? A few of us here are using cards for the SD delays on the Mk4s, and running into occasional glitches caused by buffer overflow/underrun (I think that's what's causing these).

Thank you,

Todd Silva

Post Reply

Return to “Expert Sleepers”