Ableton CV tools and ES expander modules

Discussion and support for Expert Sleepers' Silent Way software and hardware.

Moderators: Kent, os

bhenry1790
Common Wiggler
Posts: 152
Joined: Wed Oct 05, 2011 9:26 am

Re: Ableton CV tools and ES expander modules

Post by bhenry1790 » Wed Aug 19, 2020 10:46 am

Virgil wrote:
Wed Aug 19, 2020 8:19 am
Thank you for the work you put into modifying the max4live devices and even creating new ones, bhenry! I discovered them earlier this week, but sadly I haven't been able to get any of them to work.

So I've got an ES-5 connected to an ES-8 which extends my interface via ADAT. Two ESX-8CV and one ESX-8GT are hooked up with the ES-5 headers 4 & 5, and 6 respectively. I run Ableton Suite 10.1.15 on Windows 10 Pro. Sending CV over ADAT to the ES-8 using Silentway lights up the jacks of the respective expander modules in the way that is to be expected. The hardware should be good.

First, I put the stock CV Clock output device in an audio track and routed it to channel 7 of the ES-8. The ES-5 outputs the clock, obviously not the way we want it due to the stock device not using the es5encoder~. When trying the same thing with your modified Clock Out device (latest version) nothing is being sent to the external devices at all. Upon inspecting the patch there seem to be a few bugs:
routing_manager_ES5.maxpat: patchcord inlet[/outlet] out of range: deleting patchcord [4x]

Second, the ESX8CV Track Helper: Added eight audio tracks, grouped them, put the track helper on the bus. One of the audio tracks sports an LFO that generates a signal which is even being picked up by the Track Helper. Unfortunately it stops here: no output.

I've tried several other devices for the ESX8CV and the ESX8GT. Of course the es*encoder~ externals are installed (to the same directory). While I haven't noticed any further errors in the patches, the ES-8 and all expanders keep dead silent :(

I assume I have got some fundamental misconceptions of how to work with these devices. Please help.
Hi Virgil, I think we have a couple of issues. Let's solve the easiest one first (the clock). I mustn't have 'frozen' my latest patch before uploading. Try it again. The "routing_manager_ES5.maxpat" should now be included in the package. https://maxforlive.com/library/device/6 ... -clock-out

FYI: I'm on Live 10 and using Max 8 on a Mac with ES9+ES5 on chan 7/8

Let's get the simple devices like ESX8GT Clock Out & ESX8CV Helper working first, then we'll move on to the Track Helpers. Track Helper setup is more complex because it requires routing CV Tools to Live Audio Tracks, then using the helper devices to choose the Audio Tracks.

Now some things to check:
Do your expanders work as expected with Silent Way?

All of the devices have an output selector (this is the routing_manager_ES5.maxpat) that appears on the right of the device. This is where you pick the stereo pair dedicated to the ES5. In my case it is 7/8.
ClockOut.jpg
ClockOut.jpg (69.51 KiB) Viewed 104 times
Last edited by bhenry1790 on Wed Aug 19, 2020 12:43 pm, edited 1 time in total.

Virgil
Common Wiggler
Posts: 172
Joined: Fri Apr 08, 2016 4:36 pm
Location: Europe

Re: Ableton CV tools and ES expander modules

Post by Virgil » Wed Aug 19, 2020 11:26 am

I appreciate you getting back so quickly :)
Yes, as I mentioned earlier I have no trouble outputting to specific channels of the ES-5 (on channel 7/8) and ESX-8GT using the ES-5 controller. Also the ES-8 Combiner works to send CV to both expanders. I just verified again before installing your updated device. It's still not working, well, not really, although we are getting closer. When I open the patch in Max, the log now states: "gen.patcher: could not find gen patcher Signitalizer v0.01" and "... rmax_01" [in green]. However, that's the curious thing about it, the clock is now sent to the channel I select for the ES8GT! Nice. But when I close the Max window again it stops although I haven't touched anything else.

EDIT: ES8CV Helper and the octLFO also work - but only while being open in MAX! The moment I close it, it stops working. :despair:

bhenry1790
Common Wiggler
Posts: 152
Joined: Wed Oct 05, 2011 9:26 am

Re: Ableton CV tools and ES expander modules

Post by bhenry1790 » Wed Aug 19, 2020 12:59 pm

Virgil wrote:
Wed Aug 19, 2020 11:26 am
I appreciate you getting back so quickly :)
Yes, as I mentioned earlier I have no trouble outputting to specific channels of the ES-5 (on channel 7/8) and ESX-8GT using the ES-5 controller. Also the ES-8 Combiner works to send CV to both expanders. I just verified again before installing your updated device. It's still not working, well, not really, although we are getting closer. When I open the patch in Max, the log now states: "gen.patcher: could not find gen patcher Signitalizer v0.01" and "... rmax_01" [in green]. However, that's the curious thing about it, the clock is now sent to the channel I select for the ES8GT! Nice. But when I close the Max window again it stops although I haven't touched anything else.

EDIT: ES8CV Helper and the octLFO also work - but only while being open in MAX! The moment I close it, it stops working. :despair:
Wow, Odd that it works wile Max is open, but not in Live. It seems silly but have you tried full reboot? After that, could there be a security setting blocking Live from running the externals? I don't know if Windows is the same, but recent Mac OS security updates break things.

On the clock. All of the gen.patcher stuff in the clock would have come from the original CV Tools device so I'll double check that.
Edit: Redid the whole ES conversion for the Clock Out. Tested with Pam's and getting solid timing.
https://maxforlive.com/library/device/6 ... -clock-out

Thanks for the feedback! I put these things out, they all work for me so I have to assume they are working for everyone that has downloaded.
Last edited by bhenry1790 on Wed Aug 19, 2020 2:03 pm, edited 1 time in total.

Virgil
Common Wiggler
Posts: 172
Joined: Fri Apr 08, 2016 4:36 pm
Location: Europe

Re: Ableton CV tools and ES expander modules

Post by Virgil » Wed Aug 19, 2020 1:42 pm

bhenry1790 wrote:
Wed Aug 19, 2020 12:59 pm

Wow, Odd that it works wile Max is open, but not in Live. It seems silly but have you tried full reboot? After that, could there be a security setting blocking Live from running the externals? I don't know if Windows is the same, but recent Mac OS security updates break things.

On the clock. All of the gen.patcher stuff in the clock would have come from the original CV Tools device so I'll double check that.

Thanks for the feedback! I put these things out, they all work for me so I have to assume they are working for everyone that has downloaded.
I'm happy to help as I really would like to get these devices going :hyper: I have close to zilch knowledge of Max though.
When Max is opened and the gen patcher error/warning messages appear, the console tells me that "gen is working in runtime mode".
Could it be that it exits runtime mode when I close the Max window and thus it stops, well, running?

bhenry1790
Common Wiggler
Posts: 152
Joined: Wed Oct 05, 2011 9:26 am

Re: Ableton CV tools and ES expander modules

Post by bhenry1790 » Wed Aug 19, 2020 2:11 pm

Virgil wrote:
Wed Aug 19, 2020 1:42 pm
I'm happy to help as I really would like to get these devices going :hyper: I have close to zilch knowledge of Max though.
When Max is opened and the gen patcher error/warning messages appear, the console tells me that "gen is working in runtime mode".
Could it be that it exits runtime mode when I close the Max window and thus it stops, well, running?
Oh, that could be helpful. And yeah, I had NO knowledge of Max when I started hacking these things together. Gen is still out of my depth.

ESX8GT Clock Out has been completely redone with the ES expander conversion:
https://maxforlive.com/library/device/6 ... -clock-out

The most basic sequencer I built from scratch linked below. Does this one work for you (no Gen or anything fancy in here):
https://maxforlive.com/library/device/6 ... -sequencer

Virgil
Common Wiggler
Posts: 172
Joined: Fri Apr 08, 2016 4:36 pm
Location: Europe

Re: Ableton CV tools and ES expander modules

Post by Virgil » Wed Aug 19, 2020 2:50 pm

Now that's interesting. I changed the settings in Live to use my full copy of Max (v8.1.5) which I also have a license of. I tried the new patch I had snatched from your edited post. No error messages of course, but still the same behavior. So then I've updated Live to 10.1.18 and switched back to using the build-in Max version. Reboot. ESX8GT Clock Out works now right away without the need to open the patch! :party: (Gen is still working in runtime mode so this probably wasn't the culprit). So far I've tried the basic sequencer, the euclidean one, the LFOs, and even the track helper! :sb:

I have got a pretty clean production machine, so I can only suppose there was a quirky issue with Live 10.1.15 and its audio routing. Very odd. Glad I could at least point you to the Clock Out issue. I'm very happy now, excellent work! Again, thank you for making these devices.

bhenry1790
Common Wiggler
Posts: 152
Joined: Wed Oct 05, 2011 9:26 am

Re: Ableton CV tools and ES expander modules

Post by bhenry1790 » Wed Aug 19, 2020 3:49 pm

Virgil wrote:
Wed Aug 19, 2020 2:50 pm
Now that's interesting. I changed the settings in Live to use my full copy of Max (v8.1.5) which I also have a license of. I tried the new patch I had snatched from your edited post. No error messages of course, but still the same behavior. So then I've updated Live to 10.1.18 and switched back to using the build-in Max version. Reboot. ESX8GT Clock Out works now right away without the need to open the patch! :party: (Gen is still working in runtime mode so this probably wasn't the culprit). So far I've tried the basic sequencer, the euclidean one, the LFOs, and even the track helper! :sb:

I have got a pretty clean production machine, so I can only suppose there was a quirky issue with Live 10.1.15 and its audio routing. Very odd. Glad I could at least point you to the Clock Out issue. I'm very happy now, excellent work! Again, thank you for making these devices.
Nice! Glad to learn everything is working now! Every machine is different to it's a guessing game sometimes.

User avatar
Placid Mouse
Wiggling with Experience
Posts: 279
Joined: Tue Aug 25, 2015 9:47 pm
Location: BC

Re: Ableton CV tools and ES expander modules

Post by Placid Mouse » Tue Sep 15, 2020 2:25 am

Wow, I'm reading through this post and I've discovered that your devices bhenry, are what I've been trying to make, but way better! I created a post on this sub-forum with an 8x CV clock tool for the ES-5 but it looks like yours is much better, nice work.

bhenry1790
Common Wiggler
Posts: 152
Joined: Wed Oct 05, 2011 9:26 am

Re: Ableton CV tools and ES expander modules

Post by bhenry1790 » Tue Sep 15, 2020 5:25 am

Placid Mouse wrote:
Tue Sep 15, 2020 2:25 am
Wow, I'm reading through this post and I've discovered that your devices bhenry, are what I've been trying to make, but way better! I created a post on this sub-forum with an 8x CV clock tool for the ES-5 but it looks like yours is much better, nice work.
Awesome! Glad they are useful. I'm working on a couple more that I'm excited to share soon!

User avatar
djgravitymike
1-Post Wiggler
Posts: 1
Joined: Wed Sep 16, 2020 3:38 pm
Location: Wigan
Contact:

Re: Ableton CV tools and ES expander modules

Post by djgravitymike » Wed Sep 16, 2020 3:54 pm

Image

ive just bought an ES-8 , ES-5 AND ESX-8CV , I Have silent way its proved nit very useful to me in ableton

Anyway,

there all connected up, id like to know, how are the max external encoders added to the m4l tools and where in max, as there missing
--- and which of the 16 outs 1/2 to 15/16 are used for the ES-5 from the ES-8 8-)

Post Reply

Return to “Expert Sleepers”