Fh-2 various issues

Discussion and support for Expert Sleepers' Silent Way software and hardware.

Moderators: Kent, os

Post Reply
c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Fh-2 various issues

Post by c0ntr4d1ct10n » Sat Dec 14, 2019 4:44 am

Hi os, I have just got the FH-2 which came with the latest firmware 1.7.2 but have already encountered a few issues (note I am using a Roli Seaboard block):

Issue 1: when I upload the configuration using the web configurator, it works but doesnt seem to save the config - it resets when I power cycle it. Even when I save preset and power cycle, then reload the preset on the device, it doesnt seem to recognise the config until I reupload the config from the web configurator. This means that I always have to hook the FH-2 up to a pc to get it to work.

Issue 2: I am using MPE mode and with 2 voices, output 5 (pitch 2) seems to always be on and doesnt respond to pitch. Likewise when I use more voices with an expander, the additional pitch outputs dont respond to pitch.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Sat Dec 14, 2019 5:53 am

Okay, so it turns out I answered my own questions:
1. I just had to save the preset and config on the module itself and had to change the setting where it loads the desired preset and config on bootup.

2. For some reason the expander (FHX-8CV) came shipped with a second jumper that was placed incorrectly connecting pins 1 and 2, which may have been causing problems with the outputs.

Now it all works. I even managed to connect it to my FH-1 and use that as an extra expander.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Sat Dec 14, 2019 6:13 am

Now I have a problem where I can't seem to get the Expressive E Touche SE working with the FH-2. I set the config to recognise Channel 1 CCs 16-19 for outputs 1-4 but the FH-2 does not recognise the Touche.

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Mon Dec 16, 2019 4:46 am

Are you saying that it doesn't recognise it at all (i.e. the 'A' indicator doesn't show in the display) or that it's not responding to the MIDI?

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Mon Dec 16, 2019 8:24 am

os wrote:Are you saying that it doesn't recognise it at all (i.e. the 'A' indicator doesn't show in the display) or that it's not responding to the MIDI?
There's no A indicator. Note that this is a Touche SE. The lights on the Touche SE turn on when I plug it into the FH-2. I've even tried power cycling the module with the Touche plugged in but no luck.

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Mon Dec 16, 2019 8:42 am

Odd. It's noted that firmware v1.5.2 specifically made the Touché (not SE) work: https://www.muffwiggler.com/forum/viewt ... 08#3012408

Could you perhaps try 1.5.2, just in case something that used to work as broken again?

If that doesn't work, could you please grab the SE's USB descriptor? See https://www.muffwiggler.com/forum/viewt ... 75#2979375

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Mon Dec 16, 2019 9:30 am

os wrote:Odd. It's noted that firmware v1.5.2 specifically made the Touché (not SE) work: https://www.muffwiggler.com/forum/viewt ... 08#3012408

Could you perhaps try 1.5.2, just in case something that used to work as broken again?

If that doesn't work, could you please grab the SE's USB descriptor? See https://www.muffwiggler.com/forum/viewt ... 75#2979375
Hi os,

I just tried 1.5.2, still the same - not detecting anything.
I don't have a mac so only use Windows 10 on my Surface Pro and Windows 8.1 on my desktop. Can you tell me how to get the USB descriptor on Windows?

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Mon Dec 16, 2019 9:36 am

I have no idea, sorry. I'd be googling it, so you've as much chance of figuring it out as I have.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Mon Dec 16, 2019 5:47 pm

os wrote:I have no idea, sorry. I'd be googling it, so you've as much chance of figuring it out as I have.
I managed to find a windows app - tdd.exe from Thesycon.de. Please see attached.
You do not have the required permissions to view the files attached to this post.

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Dec 17, 2019 3:29 am

Thanks. That looks well nigh identical to the Touché one, so I'm at a loss. I'll have to try & get hold of an SE for testing.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Tue Dec 17, 2019 5:11 am

Not sure if this will help, but my Touche SE works through the iconnectivity midi4+. I tested it this morning and got it to run on the FH-2 via the midi4+.

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Re: Fh-2 various issues

Post by os » Mon Dec 23, 2019 10:43 am

I have the Touché SE here now, and have it working with a small firmware tweak. I'll aim to release that soon, though soon might mean after the holidays.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Re: Fh-2 various issues

Post by c0ntr4d1ct10n » Thu Jan 02, 2020 7:00 am

Thanks os. Look forward to it.

Another issue I seem to be having with the FH-2 and the Roli Seaboard Block is there is always a single note that doesnt respond. This issue isnt a specific note, its always a different note every time I turn on the FH-2 and after a while of playing, it works but then another note stops responding. It is always only a single note.
This is on mpe mode with 6 voices, using a FH-1 as the first expander and FHX-8CV as the second expander.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Re: Fh-2 various issues

Post by c0ntr4d1ct10n » Sat Jan 04, 2020 5:11 am

I've also been getting the message "MIDI device send queue overflow" when the FH-2 freezes up occasionally after about 5min of play.

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Re: Fh-2 various issues

Post by os » Tue Jan 07, 2020 10:06 am

Please could you try this beta?

You'll find a new setting called 'USB reset time'. Set this to about 40 for the Touché.
You do not have the required permissions to view the files attached to this post.

c0ntr4d1ct10n
Common Wiggler
Posts: 214
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Re: Fh-2 various issues

Post by c0ntr4d1ct10n » Tue Jan 07, 2020 9:51 pm

Thanks os, this version works now!

User avatar
os
Super Deluxe Wiggler
Posts: 12419
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Re: Fh-2 various issues

Post by os » Wed Jan 08, 2020 4:43 am

Thanks for confirming. Will release soon.

Post Reply

Return to “Expert Sleepers”