The Pickit Thread: Updating Firmware & Burning ROMs

Digital Audio Electronics - discussion & support.

Moderators: Kent, solidox, governor blacksnake

User avatar
thetwlo
Super Deluxe Wiggler
Posts: 4898
Joined: Wed Apr 16, 2008 4:05 pm
Location: East Bay, CA US

Post by thetwlo » Sat Dec 23, 2017 10:34 pm

mt3 wrote:And here's the firmware part you were looking for:
http://www.theharvestman.org/programmer.php
DEAD link.

User avatar
debolish
Common Wiggler
Posts: 236
Joined: Wed Jul 29, 2015 9:15 am
Location: Boston, MA

Post by debolish » Sat Dec 23, 2017 11:09 pm

thetwlo wrote:
mt3 wrote:And here's the firmware part you were looking for:
http://www.theharvestman.org/programmer.php
DEAD link.
http://www.microchip.com/development-to ... ds-archive

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sat Dec 23, 2017 11:09 pm

thetwlo wrote:
mt3 wrote:And here's the firmware part you were looking for:
http://www.theharvestman.org/programmer.php
DEAD link.
Contents were cut and pasted in the body of the post. Nothing is missing.

https://web.archive.org/web/20170402191 ... rammer.php

User avatar
thetwlo
Super Deluxe Wiggler
Posts: 4898
Joined: Wed Apr 16, 2008 4:05 pm
Location: East Bay, CA US

Post by thetwlo » Thu Jan 04, 2018 8:56 pm

thanks mt3 and debolish!

(finally getting back to doing this)

guestt

Post by guestt » Fri Mar 16, 2018 2:25 pm

Programmer and roms available for sale in BST:

viewtopic.php?t=192781

Someone going to be lucky today!

:cloud:

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sun Apr 08, 2018 6:29 am

Updated post with following vid:
[video][/video]

guestt

Post by guestt » Sun Apr 08, 2018 7:39 am

Cool - nice overview - thanks mt3 :)

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sun Apr 08, 2018 11:16 am

Baddcr wrote:Cool - nice overview - thanks mt3 :)
Not mine!
:party:

User avatar
MickeyClouds
Learning to Wiggle
Posts: 4
Joined: Wed Jan 18, 2017 1:42 pm
Location: Altadena

Post by MickeyClouds » Wed May 30, 2018 1:56 pm

Thank you all for the wonderful info! :nana:

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Wed Aug 29, 2018 6:53 pm

FYI: For those using MLAB IPE v5 software, can be painful when it doesn't seem to connect/see the module for no reason. Restarting the software and reconnecting the programmer to the module a few times seems to "work".

User avatar
0BSRVR
Common Wiggler
Posts: 135
Joined: Fri Oct 23, 2015 12:19 pm
Location: Phoenix, AZ

Post by 0BSRVR » Tue Sep 11, 2018 1:52 pm

Thank you for all the excellent info in this thread. Unfortunately I'm still having problems updating from 1.666. I'm on MAC OS 10.12.6 and I'm using MPLAB X IPE V.5.05

I've got the device ID set as DSPIC33FJ128GP310A as per the IME readme file.

The hammer is powered up and connected to the Pickit3 as shown in the above video. I get the green light next to the apply button in the IPE software, but when I click connect I always get this error message.

Initialization failed: Unable to create ControlPointMediator



Do I need to install java on my MAC to get this too work? If so, which version of java?


Thank you to anyone that can help.

User avatar
0BSRVR
Common Wiggler
Posts: 135
Joined: Fri Oct 23, 2015 12:19 pm
Location: Phoenix, AZ

Post by 0BSRVR » Tue Sep 11, 2018 2:24 pm

Update:

I'm sorted!!!!


So, screw MLAB IPE V5.05!!! I uninstalled it then downloaded MPLABX IPE V 4.05 and it updated the Pickit3 firmware automatically. Then then hammer update worked on the first attempt.


Thanks to Robotopsy, MT3, and debolish for their videos and info.


Get Version 4.05 for Mac OS here.
http://www.microchip.com/development-to ... ds-archive


:nana:

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Tue Sep 11, 2018 3:08 pm

0BSRVR wrote:Update:

I'm sorted!!!!


So, screw MLAB IPE V5.05!!! I uninstalled it then downloaded MPLABX IPE V 4.05 and it updated the Pickit3 firmware automatically. Then then hammer update worked on the first attempt.


Thanks to Robotopsy, MT3, and debolish for their videos and info.


Get Version 4.05 for Mac OS here.
http://www.microchip.com/development-to ... ds-archive


:nana:
Yes, that's the "solution" conclusion I came to myself.
:tu:

User avatar
tau_seti
Veteran Wiggler
Posts: 702
Joined: Sun May 04, 2014 12:21 pm

Post by tau_seti » Mon Nov 26, 2018 3:33 pm

I think I was successful. On startup, the firmware indicator goes by MUCH faster than it used to (2.26 vs 1.666). I literally had to use the slow motion video on my iPhone to see it. Is that normal?.

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Tue Nov 27, 2018 4:17 am

tau_seti wrote:I think I was successful. On startup, the firmware indicator goes by MUCH faster than it used to (2.26 vs 1.666). I literally had to use the slow motion video on my iPhone to see it. Is that normal?.
Wow. Amazing eyes!
:nana:

Since ver 2.0, the firmware version can be displayed by pressing INIT + CLOCK.

User avatar
maltemark
Veteran Wiggler
Posts: 744
Joined: Tue Dec 16, 2014 11:39 am
Location: Gothenburg

Post by maltemark » Thu Mar 14, 2019 12:27 pm

Has anyone else experienced corruption of EEPROM data for the PH mk1 expander? I think I might have fallen victim of this somehow...

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Wed Mar 27, 2019 6:33 pm

maltemark wrote:Has anyone else experienced corruption of EEPROM data for the PH mk1 expander? I think I might have fallen victim of this somehow...
Can you elaborate?

User avatar
spilthyfred
Common Wiggler
Posts: 172
Joined: Fri Dec 14, 2018 12:58 am

Post by spilthyfred » Sat Dec 07, 2019 6:21 am

mt3 wrote:
0BSRVR wrote:Update:

I'm sorted!!!!


So, screw MLAB IPE V5.05!!! I uninstalled it then downloaded MPLABX IPE V 4.05 and it updated the Pickit3 firmware automatically. Then then hammer update worked on the first attempt.


Thanks to Robotopsy, MT3, and debolish for their videos and info.


Get Version 4.05 for Mac OS here.
http://www.microchip.com/development-to ... ds-archive


:nana:
Yes, that's the "solution" conclusion I came to myself.
:tu:
For anyone stuck in a similar pickle, I just ran into the same problem with my Argos Bleak and this was also the solution on Windows 10. ^

Thanks OBSRVR :yay:

User avatar
synonymist
Veteran Wiggler
Posts: 661
Joined: Thu Sep 27, 2018 3:11 pm
Contact:

Re:

Post by synonymist » Sat Jan 04, 2020 2:56 pm

.
Last edited by synonymist on Sat May 23, 2020 11:56 am, edited 1 time in total.

User avatar
paranormind
Common Wiggler
Posts: 125
Joined: Fri Nov 09, 2018 6:59 pm
Location: Tokyo

Re: The Pickit Thread: Updating Firmware & Burning ROMs

Post by paranormind » Sat May 09, 2020 6:57 am

Thank you all!! When updating my PHmk3 to the new 1.7, I got stuck in a "connection failed" loop with MPLAB 5+

I downgraded to 4.05 and worked like a charm after a couple of iterations. If you're looking for all the versions for the different OS, here you are: https://kennyshin.tistory.com/60

Plus, it's muuuuch faster than the last versions, so I'd recommend it to everyone :despair:

User avatar
Leverkusen
Super Deluxe Wiggler
Posts: 2255
Joined: Mon Jul 29, 2013 2:26 am
Location: Suhlendorf

Re: The Pickit Thread: Updating Firmware & Burning ROMs

Post by Leverkusen » Sat May 16, 2020 11:35 am

Has anyone successfully updated a Double Andore MKI? I have the firmware file and according to IME the processor type is dsPIC30F3014. I tried MPLAB X 5 and 4 on El Capitan and Win 10 with a PICkit 3 but can not detect a target.

It worked great and seamless with all MKIII modules though.

:despair: :waah:
Last edited by Leverkusen on Sun May 17, 2020 4:01 am, edited 1 time in total.

User avatar
robotopsy
Veteran Wiggler
Posts: 728
Joined: Thu Dec 20, 2012 1:55 am
Location: Canada

Re: The Pickit Thread: Updating Firmware & Burning ROMs

Post by robotopsy » Sun May 17, 2020 12:13 am

Never heard about a firmware for the DAv1 but you can program some bank on the microchip. there is one chip that was available at the time. The Orange meet pink I think you can make copies of those chips :roll:

http://www.analoguehaven.com/theharvestman/model-2017/


Leverkusen wrote:
Sat May 16, 2020 11:35 am
Has anyone successfully updated a Double Andore MKI? I have the firmware file and according to IME the processor type is dsPIC30F3014. I tried MPLAB 5 and 4 on El Capitan and Win 10 with a PICkit 3 but can not detect a target.

It worked great and seamless with all MKIII modules though.

:despair: :waah:

User avatar
Leverkusen
Super Deluxe Wiggler
Posts: 2255
Joined: Mon Jul 29, 2013 2:26 am
Location: Suhlendorf

Re: The Pickit Thread: Updating Firmware & Burning ROMs

Post by Leverkusen » Sun May 17, 2020 4:20 am

Might be a misunderstanding - my request was not about programming the wavetable chip. I know about the orange pinkies but they were sold out when I purchased my DA from AH. I have not found a file of them to copy by now.

I have a firmware (.hex) file for the DAv1 that is believed to fix the freezing issue early units had. I just can't get it onto the chip via the usually otherwise working methods and hoped someone might have done it before and could give some helpful advice.

Throwgnilli
Learning to Wiggle
Posts: 27
Joined: Mon Jan 09, 2017 5:45 pm
Location: England

Re: The Pickit Thread: Updating Firmware & Burning ROMs

Post by Throwgnilli » Mon May 25, 2020 11:06 am

Hi guys,

Just purchased a piston Honda mk3, I would like to update it but I’m a bit clueless. As there are no longer any pickit 3 in uk, could I do the update on a pickit 4?

Cheers
Ben

User avatar
paranormind
Common Wiggler
Posts: 125
Joined: Fri Nov 09, 2018 6:59 pm
Location: Tokyo

Re: The Pickit Thread: Updating Firmware & Burning ROMs

Post by paranormind » Mon May 25, 2020 9:13 pm

Throwgnilli wrote:
Mon May 25, 2020 11:06 am
Just purchased a piston Honda mk3, I would like to update it but I’m a bit clueless. As there are no longer any pickit 3 in uk, could I do the update on a pickit 4?
I can't provide a firm answer but I don't see why it wouldn't work. Just double-check this will be recognized by MPLAB, and preferably MPLAB 4, given that MPLAB 5+ doesn't really work well with the PH3 for some reasons.

Post Reply

Return to “The Harvestman”