Noisy AM8012

Discussion and support for the AMSynths range of analog synthesizer modules.

Moderators: Kent, emuarc

Post Reply
tufraniuh@yahoo.com
Learning to Wiggle
Posts: 12
Joined: Tue May 14, 2019 5:20 am

Noisy AM8012

Post by tufraniuh@yahoo.com » Wed May 29, 2019 12:41 pm

I bought a used AM8012 and it makes a lot of noise even with the filter closed. The seller claims that I broke it, but of course I connected correctly, this is not my first filter. What could be the cause of wild (white noise, hiss) noise with all the knobs turned off? I can try to replace the THAT300 and THAT340, will it help?

User avatar
SmartBits
Veteran Wiggler
Posts: 585
Joined: Tue Jul 16, 2013 3:46 am
Location: Nijmegen, The Netherlands

Post by SmartBits » Mon Jun 03, 2019 8:27 am

I think you'd better ask Rob directly via mail. His customer service is excellent!

User avatar
ndkent
Super Deluxe Wiggler
Posts: 3588
Joined: Tue Dec 23, 2008 5:59 am

Post by ndkent » Tue Aug 06, 2019 9:42 am

I bought mine direct and recall pretty much that. Turned out the D.C. offset hadn't been calibrated and Rob helped me by email. Had a similar problem with an uncalibrated filter D.C. offset on another brand too.

tufraniuh@yahoo.com
Learning to Wiggle
Posts: 12
Joined: Tue May 14, 2019 5:20 am

Post by tufraniuh@yahoo.com » Tue Aug 06, 2019 2:58 pm

ndkent wrote:I bought mine direct and recall pretty much that. Turned out the D.C. offset hadn't been calibrated and Rob helped me by email. Had a similar problem with an uncalibrated filter D.C. offset on another brand too.
How to calibrate D.C. offset?

Post Reply

Return to “AMSynths”