Page 1 of 1

ModyPoly (w HiRes) Install Troubleshooting Help

Posted: Fri Jul 05, 2019 2:57 pm
by zonki
I recently received a new ModyPoly with the HiRes board pre-installed. This is following an unfortunate incident where my original ModyPoly was damaged (after initially working for several weeks) while troubleshooting another issue. As of now my Polysix has a working installation of the PolySex mod and everything is working with the original voice selector chip installed. When I install the new ModyPoly none of the keys activate a note and there is only some quiet noise coming from the output when keys are pressed. This also seemed to cause blown fuses in the power supply. If I unplug the CV connector (on the HiRes board) I can play notes on the Polysix though only on 5 of the oscillators (in poly mode every 6th note is absent). The ModyPoly Voice modes and menu option navigations seem to work properly though. The wiring from the board to the CV connector appears to be correct too - it is the same wiring that worked previously on my ModyPoly. Does anyone have suggestions as to how to proceed with troubleshooting? Is it possible that chips on my voice board are damaged though no problems are evident when the original voice chip is installed?

Posted: Sun Jul 07, 2019 4:27 pm
by zonki
Nevermind. Problem solved! It just needed a firmware update. I thought the pre-installed hi-res modypoly would come with the new firmware, but maybe this was an exception. Hooray for a working, fully-tubbutec-modded Polysix!

Posted: Mon Jul 08, 2019 6:36 am
by tubbutec
Thanks for reporting your fix! And apologies for your troubles