Korg Poly 61 ModyPoly fail

Support and discussion of Tubbutec products.

Moderators: Kent, tubbutec

Post Reply
Twistslime
Learning to Wiggle
Posts: 2
Joined: Sun Jul 26, 2020 7:22 am

Korg Poly 61 ModyPoly fail

Post by Twistslime » Sun Aug 02, 2020 11:46 am

Hi! I've been trying to install the modypoly upgrade in my poly 61. However after putting the modypoly chip in and turning the synth on to see if it worked, i noticed something was off.

The display is stuck on P5 61 and the keys don't produce any sound. The Joystick and arpeggiator seem fine though.

The previous owner replaced the bad battery so i don't think the problem is due to corrosion but i'm not sure. I also slighty bent one of the pins on the mody poly chip when i was trying to install it but it looks okay now according to me,so i hope the problem is due to something else

Here are some pictures:
IMG-5913.JPG
IMG-5910.JPG
IMG-5915.JPG


Do you have any ideas on what might have caused this?

This is the first synth mod i'm attempting, it would have been smarter to take it to a tech but i thought i would take a risk and try to fix it on my own

Ps i haven't drilled the holes yet

User avatar
tubbutec
Veteran Wiggler
Posts: 643
Joined: Sat Dec 27, 2014 4:29 am
Location: Berlin
Contact:

Re: Korg Poly 61 ModyPoly fail

Post by tubbutec » Tue Aug 04, 2020 3:04 am

Please get in touch: support @ tubbutec.de

Twistslime
Learning to Wiggle
Posts: 2
Joined: Sun Jul 26, 2020 7:22 am

Re: Korg Poly 61 ModyPoly fail

Post by Twistslime » Tue Aug 04, 2020 8:10 am

tubbutec wrote:
Tue Aug 04, 2020 3:04 am
Please get in touch: support @ tubbutec.de
Hi thanks for the reply, i sent an email now:)

Post Reply

Return to “Tubbutec”