ModyPoly key priority setting not working

Support and discussion of Tubbutec products.

Moderators: Kent, tubbutec

Post Reply
User avatar
KurtisLugo
Learning to Wiggle
Posts: 14
Joined: Sun Nov 29, 2015 12:07 pm

ModyPoly key priority setting not working

Post by KurtisLugo » Fri Oct 02, 2020 4:11 pm

This is not a big issue for me personally, as I never need the different note priority settings - just thought I would report this, in case it is a bug.

I am using a Polysix w/ ModyPoly (firmware version 2.0) and when in unison mode, the upper/lower/last note priority settings don't affect anything - for example when selecting "down" (lower) it is always still last note priority, as in the original Polysix. The switch itself works normally with arp etc.

Everything else in the mod works perfectly, the synth itself has a new Synthronics motherboard installed. I never paid attention to this before, so I don't know if it's something that has to do with fw 2.0 - or if it was always there.

User avatar
KurtisLugo
Learning to Wiggle
Posts: 14
Joined: Sun Nov 29, 2015 12:07 pm

Re: ModyPoly key priority setting not working

Post by KurtisLugo » Sat Oct 03, 2020 3:29 am

(Updated to firmware version 2.2 just to test - no effect. Note priority is still always last, the switch position makes no difference. All other ModyPoly functions are working perfectly, just as they should)

User avatar
tubbutec
Veteran Wiggler
Posts: 663
Joined: Sat Dec 27, 2014 4:29 am
Location: Berlin
Contact:

Re: ModyPoly key priority setting not working

Post by tubbutec » Tue Oct 06, 2020 2:05 am

Hi.
Just as a test: can you please downgrade to version 1.6 and see if that helps?
Cheers

User avatar
KurtisLugo
Learning to Wiggle
Posts: 14
Joined: Sun Nov 29, 2015 12:07 pm

Re: ModyPoly key priority setting not working

Post by KurtisLugo » Mon Nov 02, 2020 2:58 am

Ok, tested - and spotted another, likely related, bug.

In addition to the key priority issue - when using the regular, polyphonic mode w/ sustain pedal, last note priority is not working; after all six notes are playing and the seventh, eight etc. is pressed, the "oldest" note is kept, while the "newest" note is cut off. It should be the other way around -and is- when simply using the full+ polyphony -without- the sustain pedal (=oldest note is then sacrificed, just as it should).

Also, this issue only occurs when 'tapping' in the notes (while using sustain pedal) - but if the notes are 'held' / kept pressed down (while still using sustain pedal) the newest notes are kept, as they should.

---> so I downgraded to FW 1.6 and both of the above mentioned issues (unison/monophonic key priority and polyphonic note priority w/ sustain pedal) are now working just as they should ---> there seems to be a bug in FW 2.0 and FW 2.2.

User avatar
tubbutec
Veteran Wiggler
Posts: 663
Joined: Sat Dec 27, 2014 4:29 am
Location: Berlin
Contact:

Re: ModyPoly key priority setting not working

Post by tubbutec » Mon Nov 02, 2020 11:13 am

Hi there,

1) From firmware version 2.xx the priority setting is fixed to last. The switch is now used for portamento/glissando control.
"Last priority" includes both "upper" and "lower" priority modes, so this should be fine for all players. The priority setting has always only applied to the unison mode.

2) Thanks for reporting the sustain bug.

User avatar
KurtisLugo
Learning to Wiggle
Posts: 14
Joined: Sun Nov 29, 2015 12:07 pm

Re: ModyPoly key priority setting not working

Post by KurtisLugo » Fri Nov 06, 2020 4:05 am

tubbutec wrote:
Mon Nov 02, 2020 11:13 am
Hi there,

1) From firmware version 2.xx the priority setting is fixed to last. The switch is now used for portamento/glissando control.
"Last priority" includes both "upper" and "lower" priority modes, so this should be fine for all players. The priority setting has always only applied to the unison mode.

2) Thanks for reporting the sustain bug.

1) Makes sense, last priority is a good compromise - personally I never needed the other options anyway.

2) No prob, looking forward to a fix!

Post Reply

Return to “Tubbutec”