Erica Bass Drum & Doepfer LC9 Problems

Cwejman, Livewire, TipTop Audio, Doepfer etc... Get your euro on!

Moderators: Kent, Joe., luketeaford, lisa

Post Reply
User avatar
Fugal
Learning to Wiggle
Posts: 9
Joined: Thu Jan 14, 2016 10:20 pm
Location: Seattle, WA
Contact:

Erica Bass Drum & Doepfer LC9 Problems

Post by Fugal » Wed Sep 18, 2019 4:32 pm

Hi all,

So I just bought a Doepfer LC9 with PSU3.

All of my modules are working very nicely, EXCEPT the Erica Bass Drum. For some reason, it sounds kind of weird and the pitch is not working properly - the lowest pitch knob setting sounds unusually high.

I tested it on my 4MS Row 40 to make sure the Erica Bass Drum module didn't break somehow, but it was working perfectly fine on this power supply.

Is there something I need to do or will the Erica Bass Drum simply just not work in this case??

Keltie
Veteran Wiggler
Posts: 690
Joined: Fri Apr 14, 2017 11:33 am

Post by Keltie » Thu Sep 19, 2019 5:06 am

Just wondering if it may be related to the doepfer cv/gate buss that runs through the power headers....if that’s even a thing with the Erica BD...

User avatar
ggillon
Veteran Wiggler
Posts: 513
Joined: Wed Feb 28, 2018 7:21 am
Location: Belgium

Re: Erica Bass Drum & Doepfer LC9 Problems

Post by ggillon » Thu Sep 19, 2019 7:00 am

Fugal wrote:Hi all,

So I just bought a Doepfer LC9 with PSU3.

All of my modules are working very nicely, EXCEPT the Erica Bass Drum. For some reason, it sounds kind of weird and the pitch is not working properly - the lowest pitch knob setting sounds unusually high.

I tested it on my 4MS Row 40 to make sure the Erica Bass Drum module didn't break somehow, but it was working perfectly fine on this power supply.

Is there something I need to do or will the Erica Bass Drum simply just not work in this case??

Was there anything patched in the pitch CV of the bass drum?

This is from their site:
"On this run of modules the Pitch & Decay CV inputs are inverted: rising CV will decrease pitch, falling - increase"



edit: I always thought the pitch of the BD wasn't going low enough to my taste. Since you say it's working fine on another PSU it makes me want to try it too to see if it gets better.

Only workaround for me to go lower is to send positive CV in the Pitch input (because of the inverted control mentioned above)

Post Reply

Return to “Eurorack Modules”