HELP Please. New DIY builder- Erica Synths VCA not working

From circuitbending to homebrew stompboxes & synths, keep the DIY spirit alive!

Moderators: Joe., lisa, luketeaford, Kent

Post Reply
User avatar
Beepblip
Learning to Wiggle
Posts: 4
Joined: Sun Feb 09, 2020 7:10 am

HELP Please. New DIY builder- Erica Synths VCA not working

Post by Beepblip » Wed Feb 12, 2020 7:24 am

I have built an Erica Synths Polivocks VCA sourcing my own components using the Erica BOM but it's not working properly. I've followed instructions for calibration with a sine wave in to CV1. There is sound but the trim pots don't do anything. On CV2 there is no sound - nothing. I'm working my way through the schematics and going over every component. Any advice greatly received.

User avatar
guest
Super Deluxe Wiggler
Posts: 3951
Joined: Mon Aug 19, 2013 11:49 am

Re: HELP Please. New DIY builder- Erica Synths VCA not working

Post by guest » Wed Feb 12, 2020 1:20 pm

ill pull up the schematics and see what i can find, but in the meantime i would suggest reflowing your solder joints. its pretty quick to do, and 80% of the time thats the problem. pay particular attention to ground connections, and use flux if they arent coming out right.
openmusiclabs.com

User avatar
guest
Super Deluxe Wiggler
Posts: 3951
Joined: Mon Aug 19, 2013 11:49 am

Re: HELP Please. New DIY builder- Erica Synths VCA not working

Post by guest » Wed Feb 12, 2020 2:40 pm

if one side works and not the other, you can try swapping ICs to see if its a bad IC. perhaps comparing voltages on the good and bad ICs would help narrow down the issue.
openmusiclabs.com

User avatar
Beepblip
Learning to Wiggle
Posts: 4
Joined: Sun Feb 09, 2020 7:10 am

Re: HELP Please. New DIY builder- Erica Synths VCA not working

Post by Beepblip » Thu Feb 13, 2020 4:07 pm

Thanks for the tips, resoldered and checked for earth, it's now working. Thanks.

Post Reply

Return to “Music Tech DIY”