audio crackles with mojave

Reaktor, MAX/MSP, VST/AU, etc. A place for all things soft....

Moderators: Kent, Joe., luketeaford, lisa

Post Reply
User avatar
mpl
Common Wiggler
Posts: 106
Joined: Wed Nov 19, 2014 11:36 am
Location: Glasgow

audio crackles with mojave

Post by mpl » Wed Sep 16, 2020 12:33 pm

ever since i updated to mojave i have been suffering from crackles and pops when playing audio from safari and when using quick look on audio files.I am using firefox which seams to play audio ok but id like to fix it.Logic and reaktor play fine, its as if the stock apple audio driver is the problem,Ive looked for caches to empty etc
Anyone else having simmiler problems?
mac pro 2009(5.1) 10.14.6

User avatar
bobbylandry
Common Wiggler
Posts: 190
Joined: Fri Oct 17, 2014 2:16 pm
Location: Chattanooga, TN / Cambridge, MA
Contact:

Re: audio crackles with mojave

Post by bobbylandry » Wed Sep 16, 2020 1:32 pm

This was a super widespread issue that, for me and most people at least, was fixed. I'm pretty sure 10.14.6 was the final Mojave release and you're still getting it? What interface? How is it connected?

Separate from the widely reported Mojave audio issue you can get crackles and pops with mismatched sample rates, which may be obvious. I've also had issue just playing back, say, 96k files in Finder when my interface had a different sample rate. This isn't something that usually would cause an issue but at some point did for me. If Logic and Reaktor are working fine it might be something similar.

User avatar
mpl
Common Wiggler
Posts: 106
Joined: Wed Nov 19, 2014 11:36 am
Location: Glasgow

Re: audio crackles with mojave

Post by mpl » Wed Sep 16, 2020 4:14 pm

Im using a fire face 400 with the latest drivers' run at 44.1k and have a few other bits all linked digitally,It all worked fine till i updated.It is an old mac that i got a metal compatible graphics card and a ssd for system disc.
It does sound like a sample rate thing or buffer overruns type thing.
I'll try unhooking all the digital stuff to see if that makes a difference ,then try unplugging fire face and trying the internal out.

User avatar
bobbylandry
Common Wiggler
Posts: 190
Joined: Fri Oct 17, 2014 2:16 pm
Location: Chattanooga, TN / Cambridge, MA
Contact:

Re: audio crackles with mojave

Post by bobbylandry » Wed Sep 16, 2020 4:29 pm

Ah interesting I think the issues I had with crackling also happened with an old firewire interface but that was on 10.11 El Capitan which I've never updated cause the interface drivers won't work after that. So probably not helpful unfortunately.

You could try opening Audio/Midi preferences and making sure everything in that list is set to the same sample rate as the interface. When you open Logic or Reaktor, since you can set the sample rate in there, it might work fine cause that sample rate matches your soundcard. But I think that with nothing connected my Mac Mini defaults to 48k for its internal speaker and audio out, so maybe if that doesn't match your soundcard it could be causing an issue even if it shouldn't.

I'm really just guessing at things to check but that sounds like something I'd try.

Does RME's settings app or whatever it's called work with the FF400? That's been helpful for me since it shows lock/sync and what sample rates connected things are at.

User avatar
mpl
Common Wiggler
Posts: 106
Joined: Wed Nov 19, 2014 11:36 am
Location: Glasgow

Re: audio crackles with mojave

Post by mpl » Fri Sep 18, 2020 1:52 pm

After more testing,I’ve narrowed it down to the ff400 driver(at least I think so) all works fine when I unplug the ff400 and use the internal and out.no crackles.
On the rme web site there is a video about loading the driver with apples gatekeeper, and how to allow it to load. I’ve tried lots of things to install the driver but I can’t get the gatekeeper to give me an alert so I can authorise it properly.and yet everything functions properly ie total mix and settings,hmmm

Post Reply

Return to “Music Software”