MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

ADDAC207 - New Firmware: Issues / Reports
MUFF WIGGLER Forum Index -> ADDAC System Goto page 1, 2  Next [all]
Author ADDAC207 - New Firmware: Issues / Reports
ADDAC System
Dear all,

hope everyone is well. Following up the ADDAC207 threads we decided to create 2 threads for these matters!

This thread will be used to Report issues with the latest Firmware released. In order to avoid already known issues, please read through the comments and make sure you have the latest firmware installed before posting any reports.

For any Firmware upgrades related issues: errors, problems, connections, etc, please go to this thread instead:
https://www.muffwiggler.com/forum/viewtopic.php?p=1689582#1689582

With these 2 threads we can separate any issues that may arise from these processes.


RELATED LINKS (edited August 9th):
ADDAC System
Thought of also posting a list of what has been done in terms of corrections to the initial released firmware:

. Several minor details have been polished
. Greatly improved CV inputs detection
. Corrected all issues with gates in detection
. Corrected all issues with Trigger Repeat function
. Automatic CV input recognition on channels 2,3,4 now will only track Channel1 after 10seconds of 0v is received
. Added a button to disable the Channel1 control over other Channels
- This can be accessed from the "Trig.R." Menu (Button7)
- Toggling button 2 on/off: On (track Ch1), Off (no tracking)
meatbeatz
Going by the log above, if the most recent update address the triggering and channel interaction issues I will be one happy chap. I have a show coming up and I'd be stoked to be rocking the 207! Thanks for taking the time to look at this.
Hirsbro
with the latest firmware (I believe?) this: ADDAC207_FIRMWARE_HEX_J3.hex
I am getting some timing issues, sound almost like shuffle some times


this is "bypass" straight from the trigger source (trigger riot) straight to the env



both wave files have been moved in order to make the first note start at the same point
__ag
Hello,
Thanks for the report, will look into it in the next days!
all the very best
andre
__ag
Hello all,

Just updated the Firmware to version J_5, this will correct the timing issues reported by Hirsbro.

The reaction time between gate in and output is now about 1 millisecond.

all the very best
andre
Paranormal Patroler
That's great news Andre. Looking forward to checking it out! Will this also fix the multiple triggers issue?
Hirsbro
__ag wrote:
Hello all,

Just updated the Firmware to version J_5, this will correct the timing issues reported by Hirsbro.

The reaction time between gate in and output is now about 1 millisecond.

all the very best
andre


thumbs up
meatbeatz
Hirsbro, I haven't had a chance to upgrade yet but can you tell me whether triggering s&h style with CV's (LFO's for example) on multiple channels is working without interaction between channels?
__ag
Hello,

I read through the last comments in the other thread and made a new update (J_6) to save the CH234 slave to 1 setting in overall memory, so now it should keep your pre-defined setting after startup.

And yes with this new setting channels 234 will never be listening to channel one!

all the very best
andre
Fastus
Is there any chance there will be a definitive, fully tested update rather than these ad hoc releases? I was going to pickup my unit from Control last Saturday after they installed the j_3 release, but then there was a j_5 update. Now there's a j_6.

Kind of makes it difficult to know when the unit really is ready to go...
Paranormal Patroler
__ag wrote:
And yes with this new setting channels 234 will never be listening to channel one!


But we still get the chord production working, right? I mean when nothing is plugged on inputs 2,3,4.
Hirsbro
Fastus wrote:
Is there any chance there will be a definitive, fully tested update rather than these ad hoc releases? I was going to pickup my unit from Control last Saturday after they installed the j_3 release, but then there was a j_5 update. Now there's a j_6.

Kind of makes it difficult to know when the unit really is ready to go...


I suppose there will be at some point, when ppl seas to report issues, I'm happy to help getting there if I can, testing the new firmware releases, (when I got the time confused )
Hirsbro
meatbeatz wrote:
Hirsbro, I haven't had a chance to upgrade yet but can you tell me whether triggering s&h style with CV's (LFO's for example) on multiple channels is working without interaction between channels?


Will test this, I do not have a s/h option atm but I suppose I can use mt Z8000 and/or a-149.. will report back
Refund
the updating process is pretty painless once you've got the serial adapter
Hirsbro
Made a test of the j_6 firmware today
Had all 4 quantizers going each with different clocks (1/1, 1/2, 1/3 and 1/4)
Ant tbh its been the best performances so far I could not spot any interactions between channels and did not notice timing issues (well my ear did not so did not test further)
BUT when each channel had rested for some time strange things started to happen, seems like its become far more sensitive to voltage changes or something because all the channels started to fire of gates randomly as the video show.
That said it was by far the best and virtually perfect performances form the 207
flo
So probably you had it rest for more than the specified 10 seconds?

Anyways, this is great news! Will look into buying one of these bad boys soon hihi
Hirsbro
flo wrote:
So probably you had it rest for more than the specified 10 seconds?

Anyways, this is great news! Will look into buying one of these bad boys soon hihi


Yes that's my theory, it was still registering voltage changes it seems, even from the precision adder without any attenuation, perhaps its a good thing I dunno suppose I could increase the idle time, sometimes you need all or some of the channels to be quiet for much longer than 10 sec
Fastus
Refund wrote:
the updating process is pretty painless once you've got the serial adapter


OK - so I have to buy an FTDI board so I can be an unpaid beta tester for an expensive & complex module. Whole point of modular for me was to get away from this computer/software BS... very frustrating
meatbeatz
Hirsbro wrote:
meatbeatz wrote:
Hirsbro, I haven't had a chance to upgrade yet but can you tell me whether triggering s&h style with CV's (LFO's for example) on multiple channels is working without interaction between channels?


Will test this, I do not have a s/h option atm but I suppose I can use mt Z8000 and/or a-149.. will report back


By S&H I mean feeding each CV input a different CV source then trigger each of the 4 gate inputs with a different clock source (div/mult or euclidian etc.) That way the quantizer will sample each incoming voltage upon receipt of a trigger pulse and at that moment quantize the voltage to the nearest note in the selected scale. So in essence you are S&Hing incoming voltages (except the output voltage is quantized). This is how I use my A-156 most the time.
Refund
Fastus wrote:
Refund wrote:
the updating process is pretty painless once you've got the serial adapter


OK - so I have to buy an FTDI board so I can be an unpaid beta tester for an expensive & complex module.


I feel your pain, If this wasn't such a richly featured module that no other quantizer comes close to, I probably would have just returned it myself.

the FTDI adapter costed me about $20, the postage to send it back to addac from australia probably would have cost about that, but this way *I* have control over the module maintenance, and can update it as further revisions and fixes come out.

For me, being able to do the process myself has alleviated about 99% of the fears I have about this module glitching out on me in particular useage cases, since now I can do something about it.

edit: just for the benefit of any other australians out there, I got this adapter from jaycar and it worked just fine, also I had to google to find drivers for it.

http://www.jaycar.com.au/productView.asp?ID=XC4241
ben_hex
Are you offering the option to return units for firmware upgrades?
NS4W
Beware that the related links section above is not reflecting the latest firmware! Version J9 can be accessed here: https://www.muffwiggler.com/forum/viewtopic.php?p=1830712#1830712

(Kinda messy with all these different threads and pieces of information scattered all over the place)
overjoid
Hello - I love my ADDAC case and these quantizers. I did the J9 update, but there is still an accidental gatemode switching that can occur after 60 seconds.

__ag wrote:
Hello,

I read through the last comments and made a new update (J_6) to save the CH234 slave to 1 setting in overall memory, so now it should keep your pre-defined setting after startup.

So with that setting off channels 234 will never be listening to channel one, with this long intervals between gates will not be a problem.

all the very best
andre


From the manual (last updated July 2013):

"This Gate in ON/OFF detection is made in software.
After the detection goes On, and if the user removes
the gate in jack it will automatically goes to Off after
60 seconds. If the user want to reset voices before the
60 seconds period Button 6 (Gate L) can be pressed at
the same time as the voice number button (1 to 4).
For example to Reset voice 2 Gate In, the user needs to
press button 2 and 6 at the same time.
This will resume the behavior without regarding the
Gate In until a new jack is plugged in."
______________________________________________________________________ ______________________________________

OK ---- So, the interval creation and gate detection are different things.

As of the current OS, the "CH234 slave to 1 setting" has only taken care of the accidental mode switching that happens when sending 0V CV to "in" 2, 3, or 4.
The "no-gate-in-patched"-detection is still on a 60 second timer, so "gate detection" issues have not been resolved for anyone who wants their input gates to be spaced wider than 60 seconds.

I did a simple test:
Medium slow LFO into CV "in" (set the speed so you can kind of see it moving up and down on the quantizers LEDs);
make a single trigger pulse happen into "gate in" (start a stopwatch now if you'd like);
This trigger switches the quantizer into triggered operation and stops the quantizing of every step of the lfo and holds the value from the triggered moment;
now wait. . . . . . . . . at 60 seconds the quantizer "goes crazy" (switches back to untriggered mode of operation) . . . .
it stops thinking that I have a cable plugged into "gate in", but the cable is still plugged in.

Doesn't work for slow music (you won't make it past the 15th bar at 60bpm); I think it's why random outputs are sometimes happening for some people; this situation can definitely interrupt any nice long drone note.

It would be very very helpful to have another "Trig.R." Menu item to declare "I will be using gates", or "auto detect" (which already works for "I won't be using gates").

please,
thank you,
all the very best,
Roy
freq_divider
Just did the firmware update K 3 via windows using the update kit that's available now on the ADDAC website. The very modestly priced kit got shipped in no time at all, updating was smooth, everything fine, thanx Andre!
MUFF WIGGLER Forum Index -> ADDAC System Goto page 1, 2  Next [all]
Page 1 of 2
Powered by phpBB © phpBB Group