MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Slaving RH-301 to MIDI
MUFF WIGGLER Forum Index -> KOMA Elektronik  
Author Slaving RH-301 to MIDI
albiedamned
I've been having success using my RH-301 as a master clock. I have a Pamela's Workout slaved to it via DIN Sync (with a DIN to dual 1/8" breakout cable) and it's very solid. But now I'm trying to use my DAW as the master clock via MIDI. I have the MIDI out on my audio interface (a Presonus 1818VSL) connected to the MIDI in on the RH-301, and the Pamela's still connected to the RH-301 via DIN Sync. The RH-301 is in external mode. When I start the DAW playing, the RH-301 and Pamela's start, but the tempo on the Pamela's wanders up and down across a range of about 10 bpm. I know MIDI clock is not the most reliable, steadiest clock source, but is it really that bad? Is there any other way I could sync to my DAW without getting Expert Sleepers? I really don't want to get ES because it's expensive and uses up HP.
osterchrisi
Uff, 10BPM is quite a lot. Which program/DAW are you using for sending the MIDI clock? If it is possible I would suggest that you turn off any unnecessary MIDI information being sent and send the clock alone. I know of many people solving a wonky Ableton MIDI clock (in any context) by turning off any other MIDI messages being sent.

Let me know if this helps. If not, let's look further.
albiedamned
Hi, thanks for the reply. I'm using Presonus Studio One 2 (latest version) and a Presonus 1818VSL interface. The RH301 is connected directly to the MIDI out of the 1818VSL. T
There are no other DIN MIDI devices connected, but there are several USB MIDI devices. But the RH301 is the only device configured in Studio One to get MIDI clock. I'm testing using an empty song, so there are no other MIDI messages being sent. And I configured Studio One to only send on channel 1 to the RH301.
abstraktor
MIDI clock by itself is fine for most purposes - any errors that occur are usually software ones - I'd recommend a systematic approach.
Is the Koma synching up correctly to the MIDI clock? If it is then the problem will be with Koma's translation to sync24.
If the MIDI clock is unstable with the Koma then test it with another device that you can synch up with. If it's still bad then the problem will be with your MIDI interface or your DAW. If you can send MIDI clock out through your USB MIDI devices and it's stable then it's your DIN MIDI interface that's the problem (usually a MIDI driver issue). If it's bad even through USB MIDI then it's either a DAW Bug or could be an overall MIDI driver bug.
If you can get a hold of another DAW app, test the MIDI clock with that -if it's stable then the problem is with Studio One.
arnoux
Hey there, I guess the problem here is Pamela, I'm in the same situation and I guess Pamela is a good master but not a good slave, I had problems syncing the module the way you are doing, with a dinsync-to-minijacks converter from my drum machine, PAM was often slightly out of time.
Try to check your Pam syncronized by an LFO in your modular, same LFO driving an envelope for a percussive sound and PAM spitting out a multiplication/division for another drum sound.

Try in exemple to use your RH-301 enslaved to your DAW and then sync with that something else, an envelope, a drum module or something like that and see if that way is stright..

I have problem with Pamela using the RH-301 as master so generally I use Pam as master setting a multiplication x24 and enslaving the RH-301 and from there my RYTM or anything else..
albiedamned
I'm pretty sure that Pamela is not the problem. When the RH-301 is the master, Pamela syncs perfectly via DIN Sync. I strongly suspect that the problem is the quality of the MIDI clock produced by my DAW.

I tried out some more things last night. I discovered that if I disconnected my two USB MIDI devices, things improved a little. But not a lot - I still saw swings of of 5-7 bpm.

Then I downloaded a free little VST called Sync Unit DC (http://www.rv0.be/sync-unit/legacy/sync-unit-dc). It sends out clock and run signals through two outputs on my audio interface. Because my interface isn't DC coupled, the run signal doesn't work. But I was able to get the clock signal to work by first amplifying it quite a bit and then sending it into the external clock input of the RH-301. This produced a very tight sync, as you would expect since it's based on audio not MIDI and thus is sample-accurate.

This approach might be good enough for me. I really just want a way to make sure my modular and my DAW are at the same tempo so I can record overdubs. I don't mind starting and stopping the RH-301 manually. And as long as the overdub parts I record are at the right tempo, it's easy enough to slide them around in the DAW to get them to start at the right place if my timing on hitting the start button isn't perfect.
os
Hurrah for software that generates tight clock via audio smile

You could make yourself a run signal with a little DIY cable and http://www.expert-sleepers.co.uk/siwaacencoder.html
albiedamned
Yeah I've read through that page on your site before. I'm not a DIY'er though. You should turn that into a product and sell it. Although that might cut into your module sales.
MUFF WIGGLER Forum Index -> KOMA Elektronik  
Page 1 of 1
Powered by phpBB © phpBB Group