disting mk3 problem

Discussion and support for Expert Sleepers' Silent Way software and hardware.

Moderators: Kent, os

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

How to calibrate the ES DISTING mk3 -3V stable source -

Post by Dean Amo » Thu Dec 10, 2015 12:45 pm

Hello,

Just received a Disting mk3 that unfortunately doesn't seem to work correctly.

Have a strong noise coming out from both audio outputs and i m not able to perform almost none of the functions proposed by the module - (a video has already been posted describing the same type of issue that i do have with my module)

I saw that a new calibration could probably fix the problem - i d like to make a try before i send it back for replacement or warranty.
The procedure talks about a 3V stable accurate source - where should i take this source from? could you please suggest any?

I am not sure to understand correctly the procedure ...

thnx for your help

regards

Dean Amo

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Thu Dec 10, 2015 1:34 pm

If you install the new firmware, that will at least let you know if you need to recalibrate or not.

Where did you buy this disting, by the way?

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Thu Dec 10, 2015 2:04 pm

Thnx for your answer -

i bought it a juno downloads UK - (they are out of stocks now) - i am wondering what would be the best way to proceed for exchange or warranty..

the new firmware didn't change the situation - still noise on VCO and other algorithms - no delay - no filter - and wired general behavior of the module.

what about this 3V stable reference that has to be plugged to the X jack? what should i use any idea?

Thnx in advance

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Thu Dec 10, 2015 2:41 pm

I'll split this off to a separate thread.

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Thu Dec 10, 2015 2:44 pm

Are you absolutely confident that you applied the firmware update? Do you see v3.1 indicated in the startup sequence? If it's not clear to you, shoot a video on your phone or something and post it.

There are any number of ways of creating a 3V reference. For example, you might use a MIDI/CV converter, outputting a pitch 3 octaves up from its 0V position.

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Illustration of the problem and procedures followed

Post by Dean Amo » Fri Dec 11, 2015 7:50 am

noise problem .


Boot sequence : before microcard procedure


after micro sd procedure :


calibration :


i used a doepfer A190 3 for 3V but i am not really sure i did well - (just used the CV note output of the A190 into the X input of the disting ...

Hope it will help to determine and fix the problem

thnx
[/video]

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Fri Dec 11, 2015 7:57 am

The second boot sequence video shows the firmware version is still at v3.0, so you don't have the new firmware installed.

In the calibration video, you only connected the reference input to X. You need to connect it to Y also, after the LED flashes again.

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Fri Dec 11, 2015 8:05 am

so i dont really get how to install the FW - i did copy the file in a micro SD card straight into it (no sub folder and there is only this file into the micro SD) - then i followed the procedure -

I can t read how to see what FW is installed ... what would be the correct display with 3.1 fw?

thnx

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Fri Dec 11, 2015 8:09 am

The startup sequence is described here:
http://expert-sleepers.co.uk/distinguse ... ml#startup

The relevant bit is
all 8 at once
1 + major firmware version number as binary on a/b/c/d (a is LSB)
all off
1 + minor firmware version number as binary on a/b/c/d (a is LSB)
1 + flash a twice
so after all 8 flash, you're currently seeing a 3 (a & b on, c & d off) followed by a 0 (a-d all off).

For v3.1, you'll get the 3, then a 1 (a on).

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Fri Dec 11, 2015 8:29 am

can t perform the upgrade of the fw - i really dont get what i am doing wrong. ....

would be great if you make a video to illustrate with the new fw the boot sequence --- just to compare -

maybe a video for calibration and FW update would be help full : here is what i have as boot sequence . so guess i can make the disting copy the file from the micro sd ... is there a way we could perform this together step by step?? skype / tel ...

here is what i guet after the fw perform - i can t see where / when it is displayed...

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Fri Dec 11, 2015 8:32 am

sorry i dint put the link


Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Fri Dec 11, 2015 8:46 am

getting nervous not to be able to f¡perform the fw update ... nothing to fancy to do.. maybe i am not that smart :)

thnx for your help

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Fri Dec 11, 2015 9:30 am

Here's a video:

[video][/video]

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Fri Dec 11, 2015 11:17 am

here is my sequence :

[

[/video]

assuming that i have copied the image.hex into the micro sd card (micro SD has been formated in MSDOS) - file straight into the drive (no sub folder)

i perform it well but.....

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Fri Dec 11, 2015 1:42 pm

Are you quite sure you downloaded the 3.1 version and not the 3.0 version?

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Sat Dec 12, 2015 1:45 pm

Hi!

you re right!! thnx for pointing this out to me - downloaded the 3.1 FW

Now here is the FW upgrade process and boot sequence but i m still not sure it worked ---

here is the illustration :





[

any suggestion?[/video]

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Sat Dec 12, 2015 1:47 pm

Yes, that shows 3.1 is installed now.

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Sat Dec 12, 2015 1:49 pm

wonderfull!! thnx for your help !!!!! so second thing to do is to recalibrate the module on 3V stable right?

regards

dean

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Sat Dec 12, 2015 1:51 pm

Yes, if it needs it. If you've already calibrated on v3.0 you don't need to recalibrate on v3.1.

Dean Amo
Learning to Wiggle
Posts: 11
Joined: Thu Dec 10, 2015 12:26 pm
Location: BARCELONA

Post by Dean Amo » Sat Dec 12, 2015 3:02 pm

working like a charm now"!!! a big thank you for this precious help -
No need to ship it back --- Great piece of gear btw and it sounding really really nice!!


ES disting mk3 rules!!!

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Sat Dec 12, 2015 3:43 pm

Good to hear, thanks.

dujour808
Learning to Wiggle
Posts: 2
Joined: Mon Aug 24, 2015 7:44 am

Thanks this also helped me alot!

Post by dujour808 » Sun Jan 10, 2016 10:02 am

Thanks this also helped me alot!
:hihi:

beyondness
Learning to Wiggle
Posts: 3
Joined: Fri Apr 03, 2015 8:35 am
Location: London

Post by beyondness » Tue Jan 12, 2016 6:04 pm

Bought some random Micro SD card from Currys, pre-formatted with exFAT filesystem.
Copied the unzipped v3.1 image.hex file on it using OSX, then followed the firmware update instructions as written on the ES web site, line by line - my Disting ran through some boot cycle but did not stop to wait for me to release the S encoder to start the actual update process. Instead, LEDs a & b flashed alternately in the end after the rest of the spectacle while I was still holding down the S encoder, just like they should after a successful update.
Needless to say, rebooting the Disting did not reveal 3.1 firmware being present.
Then I decided to reformat my Micro SD card to FAT32 using a Linux system suspecting that there was some issue reading the image.hex file properly although I never saw LEDs 3 & c flash alternately to indicate that the firmware file could not be found on the card.
So, after reformatting, I copied image.hex on the card and tried to update the Disting again.
This time things appeared to work better - booting paused to wait for me to release the S encoder before preceding to update the module, just as seen in the videos.
The boot sequence now showed 3.1 firmware installed - I was filled with joy - but when I started to go through the algorithms, I noticed that the v3.1 Reference Guide does not match with the algorithm layout in my Disting.
That can't be right, can it?

User avatar
os
Super Deluxe Wiggler
Posts: 13582
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Wed Jan 13, 2016 4:20 am

How mysterious. You're not just confusing the two banks of algorithms? How are the algorithms arranged?

beyondness
Learning to Wiggle
Posts: 3
Joined: Fri Apr 03, 2015 8:35 am
Location: London

Post by beyondness » Wed Jan 13, 2016 6:20 pm

os wrote:How mysterious. You're not just confusing the two banks of algorithms? How are the algorithms arranged?
and of course I was confusing the two banks :)
classic case of idiot user - seems like i'm off to a good start on this forum :D

anyway, if there's anything for me to contribute here it's maybe that if other people should run into a similar issue with reading the firmware image off their Micro SD card with their Disting, then according to my experience the filesystem type of the card can be a potential culprit. either that or the operating system you copy the file on the card with.

at least in my case having copied the image.hex file on a 64G exFAT micro SD card using OSX did not provide me with a working firmware update medium.

please correct me if i'm wrong, os
I haven't noticed any mention about supported filesystem formats that the Disting understands, so maybe the above could be relevant to someone...

Post Reply

Return to “Expert Sleepers”