MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Live 9 issue affecting Silent Way VSTs - info and workaround
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author Live 9 issue affecting Silent Way VSTs - info and workaround
os
I've become aware of an issue in Live 9 and its VST hosting which affects the correct operation of Silent Way plug-ins that drive the ES-4/40/5.

Previous versions of Live are unaffected, as are Audio Units.

Basically, Live mutes the outputs of VST plug-ins when it detects their output has fallen below a certain level, assuming the signal is an audio signal and therefore is too quiet to be useful.

The Silent Way plug-ins however output non-audio signals where every bit matters, so this behaviour is undesirable.

The result is that if SW plug-ins are only driving
- output/expansion header 5 on the ES-4 or ES-40, to
- expansion headers 3 & 6 on the ES-5
then Live might decide to mute the outputs.

I'm talking to Ableton about this, and they're being quite helpful. If this issue affects you and you'd like to add your voice to the request for an early resolution, please contact their support quoting my 'Case ableton1503245'.

They've provided a workaround, which is to edit the Live options file:
https://www.ableton.com/en/help/article/optionstxt-file-live/

and to insert the following line:
-_AudioOffTimeInSamples=691200000

Then once the plug-in has 'woken up' Live once by outputting a 'strong' signal, Live won't shut it off.
tom moody
Thanks for this fix! I created the Options.txt file and Output 5 of the ES-4 is working normally.
ipassenger
Hi,

Could this be related to the sync issue I mentioned a while back with ES5 + Ableton Live 9 (when using a negative clock offset and the ES5, the sync doesn't start for a loop or two) ?

Cheers

Ross
os
If the sync was on ES-5 headers 3 or 6, then yes.
ipassenger
Its midi clock sync to my Elektron MD/MnM (one midi thru to the other as the clock sync delay is roughly the same for both of em) just on one of the main ES5 outs.

I had figured it was to do with the way Live had changed latency handling on plugins etc but when I saw this I wondered.
nrvana8775
I realized that 2.5.5 was causing issues with my ES3. Would the above have the same effect on the ES3?
os
No. The ES-3 is basically using regular audio, so being shut down when the output is very low wouldn't be a problem.
neoxtrope
This workaround also resolved an issue I was having sending a "sparse" (one 1/16th per bar) SW Step LFO to ES-5 socket 8 via the SW ES-5 Controller.

It would play on the first loop then give up unless I opened the Step LFO editor. It would also play fine if I added more non-zero steps.
Matos
Is this still an ableton issue or has it been resolved?
os
I believe it's still an issue.
neoxtrope
Sorry, should have said - this was in Ableton 9.7.1.
Tilmann
seems so...
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group