MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Euroduino programming issues
MUFF WIGGLER Forum Index -> Circuit Abbey  
Author Euroduino programming issues
whyterabbyt
How do, Im wondering if anyone else has had the same problems as Im having with a Euroduino. I built one a few months back, and its working fine, and Ive just built a second one and the breakout board, and Ive run into a few issues.

The first issue was with the programmer cable; looked like the black and blue wires were the wrong way round on the 6-pin header. I did email CA about this at the beginning of the month, and got a single reply which might have led somewhere, but although Ive asked back twice I got no further reponse

In the end, having discovered that it was really just a nonstandard-wire-colouring FTDI cable, I part-dismantled the cable and rewired it. However after that I started running into problems trying to programming the Arduino. Im not unfamiliar wth Arduinos, so I was able to test the cable works by reprogramming a Boarduino so Im pretty sure Ive got that sorted, but Im still getting the same problem with the Mini Pro, the all-too-common

Quote:
stk500_recv() programmer is not responding


Has anyone ese had this problem? As far as I can tell this might be indicative of a missing bootloader (which I believe I can rectify with a USBTiny programmer and AVRDude) but if there's a known solution that's different it'd be nice to know.
jacobmackie
replying to follow
whyterabbyt
Preamble:
Its been a long time since I asked this, because I sort of gave up in the end and just my Euroduino with the existing firmware, but Ive finally got around to jumping through all the hoops to get this sorted.
Thought I might as well document it in case its of any use?

Took a while, Ive run into problems with FTDI cables, something strange happening to my USBTiny, and a crapload of other stuff, but after a morning of going back to first principles I now have the Micro Pro on my Euroduino set up so that I can program it properly with the CA-supplied USB cable and hopefully the breakout board. I'll be doing the same to my other Euroduino in a bit.

The Cable:
Firstly, as I originally said, it looks like the USB cable that I was supplied with, wasnt wired up properly. So I needed to rearrange the wiring on the 6-socket header that plugs into the Micro Pro. I checked what it should have been by popping open the shell and reading the PCB legends, then swapping the pins around in the header as appropriate.

This is how I believe my my cable should be wired up, and I tested it by making sure it worked for programming a BoardArduino. This bit I did way back, though, and Ive lost the notes I took, but this is how it is:s

USB PCB

RED 5v
BLACK GND
WHITE RXD
GRN TXD
BLUE CTS
YELLOW RTS

Header to the Mini Pro

BLACK BLK
BLUE GND
RED VCC
GREEN RXD
WHITE TXD
YELLOW GRN



No bootloader = no serial = no easy reprogramming

That was all well and good, but as I said, I couldnt actually reprogram the Mini Pro, and I figured out that that was because there wasn't actually a working bootloader installed to allow it to be be reprogrammed.

That took me all around the houses, trying to get the bootloader on it.

Failures : bootloaders need ISP, ISP programmers suck, deciphering ISP connections sucks more

you can skip this bit... wink
I tried a USBTiny, but even after sussing what connections to make (given that just about every diagram of 6-pin and 10-pin ICSP cable connections out there seems to omit to bother to explain which side is considered 'up', and yes it matters thanks) it seemed erratic, to the point where it wouldn't even work with a regular Arduino.
Then I tried a cheap USBAsp, and after even more faff trying to get the pin connections sorted, well wouldnt you know it, there's a firmware bug which can only be resolved if you reprogram it. Which needs a working USBAsp.... (http://blog.lincomatic.com/?p=1480)
And that was a full morning gone, just like that.

Success : an ancient Arduino as ISP

Finally, I gave up trying to use a dedicated ISP programmer, and instead uploaded the Arduino ISP code onto an actual Arduino board, which happened to be an absolutely ancient one, an ArduinoNG, and manually hooked it up to the Mini with jumper wires.

I used the diagram from here to hook up the Mini to the NG, the primitive way with jumper cables.



The Arduino IDE was current, 1.8.5, so in Tools> the Board was set to 'Arduino Pro or Pro Mini', Processor was set to 'Atmega328P, (5V,16Mhz, )', the port was set to the COM port the NG was visible on, and and 'Programmer' was set to 'Arduino as Programmer'
And of course its 'Upload with Programmer' to get that to work, rather than 'Upload'

Lo and behold that actually did sodding work, and I was actually able to upload the Blink example onto the Mini. Wish I'd started with that, instead of faffing around with half-baked ISP programmers.

A happy ending

Anyway, once I got that working, I was then able to install a bootloader on the Mini Pro (Tools>Burn Bootloader), and at that point, I disconnected the Mini from the NG, connect the now-fixed USB cable and was able to successfully upload the original Circuit Abbey dual-LFO sketch onto the board without any further problems.
MUFF WIGGLER Forum Index -> Circuit Abbey  
Page 1 of 1
Powered by phpBB © phpBB Group