noob updating SH MK2 firmware with a mac

Digital Audio Electronics - discussion & support.

Moderators: Kent, solidox, governor blacksnake

Post Reply
we_squirm
Common Wiggler
Posts: 148
Joined: Mon Dec 22, 2014 2:05 am

noob updating SH MK2 firmware with a mac

Post by we_squirm » Sat Jan 21, 2017 5:44 pm

hey all,

not the best at computers but i just bought a pickit 3 to update my SHmk2. i have a macbook, no access to a pc, so i was wondering if someone could give a easy step by step way to do it.

i used the search function and the only thing mac related i found was instructions saying"command line only" which doesn't mean much to me other than i know its an app on my computer. plz help, and don't make fun of me. thanks!

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sat Jan 21, 2017 6:13 pm

Let me muffinwiggle that for you:
viewtopic.php?t=165472

we_squirm
Common Wiggler
Posts: 148
Joined: Mon Dec 22, 2014 2:05 am

Post by we_squirm » Sat Jan 21, 2017 6:23 pm

mt3 wrote:Let me muffinwiggle that for you:
viewtopic.php?t=165472
i saw that page. only reference to mac i saw said "command line only." don't really know what that all means, but yeah. okay. thx

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sat Jan 21, 2017 6:59 pm

we_squirm wrote:
mt3 wrote:Let me muffinwiggle that for you:
viewtopic.php?t=165472
i saw that page. only reference to mac i saw said "command line only." don't really know what that all means, but yeah. okay. thx
Ok, thanks for the feedback.
I didn't notice the main link was buried in the "Getting Help" section:
http://www.auxren.com/2016/07/updating- ... onics.html

we_squirm
Common Wiggler
Posts: 148
Joined: Mon Dec 22, 2014 2:05 am

Post by we_squirm » Sun Jan 22, 2017 10:05 pm

this is what's happening to me:

Target device was not found (could not detect target voltage VDD). You must connect to a target device to use PICkit 3.
2017-01-22 22:13:06 -0500 - Programming failed
Pass Count: 0

I followed the steps very carefully. any ideas?

User avatar
noisejockey
Super Deluxe Wiggler
Posts: 1565
Joined: Tue Sep 09, 2014 8:15 pm
Location: SF Bay Area, CA, USA
Contact:

Post by noisejockey » Sun Jan 22, 2017 10:31 pm

I just happened to do this today myself with a Mac. I followed Auxren's instructions.

Make sure it's a USB 2.0 port, not USB 3.0. It didn't work with my Mac Pro's USB 3 hub, but it worked with my MacBook Air on a USB 2.0 port.

Download the MPLab IDE installer, but only install the IPE portion. Use the IPE and not the Terminal/command line as per Auxren's instructions.

Make sure you power the SH from your rack. Plug the PicKit into the module before you hit Program.

Worked for me under OS X 10.11.

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sun Jan 22, 2017 11:35 pm

we_squirm wrote:this is what's happening to me:

Target device was not found (could not detect target voltage VDD). You must connect to a target device to use PICkit 3.
2017-01-22 22:13:06 -0500 - Programming failed
Pass Count: 0

I followed the steps very carefully. any ideas?
Ha. I had that issue myself. Check page 3 of the other thread (Dec 3 10:29pm). Basically your Pickit is connected backwards:
mt3 wrote: Had some drama along the way.
I had the orientation of the PicKit connected backwards to the SH, which lead to the following cryptographic message:
"Target device was not found (could not detect target voltage VDD). You must connect to a target device to use PICkit 3.
2016-12-03 21:28:18 -0800 - Programming failed"

Reverse orientation of the Pickit doesn't damage anything, but does succeed in making you feel stupid and momentarily thankful to random imaginary deities.

Also make sure the status LED on the Pickit is green. Otherwise check USB cable connections are tight.

we_squirm
Common Wiggler
Posts: 148
Joined: Mon Dec 22, 2014 2:05 am

Post by we_squirm » Mon Jan 23, 2017 12:59 am

finally got it. thanks for the help.

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Mon Jan 23, 2017 1:10 am

we_squirm wrote:finally got it. thanks for the help.
:harvestman:

Post Reply

Return to “The Harvestman”