MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Fried Sprott
MUFF WIGGLER Forum Index -> Ciat-Lonbarde  
Author Fried Sprott
shinko
I had a comical puff of smoke after plugging my Sprott in backwards. Two resistors at the top look burnt out - but nothing else looks damaged, and strangely it still seems to work normally? (Which I did to test but then pulled out of the rack.)

Anyone dealt with this? Could I replace those resistors and be good as new? Haven't emailed Peter yet. Any recs are appreciated!

Dead Banana
smog
I hooked up one of my Denum backwards are fried two of its resistors. It was still putting out audio but the range was all off and the lights weren't acting normal so I powered down and took a look d'oh! I emailed Peter and he said I could replace or jump with through hole 10 ohm resistors or just bare wire so long as I power it up correctly. There were through hole's on the circuit board so I soldered in 10 ohm resistors and its back to normal.

Hope that helps.
shinko
Thanks much, very helpful!

d'oh!
erkahulle
I think I made the same mistake with the Denum (hooking it up backwards) and now it is not working. But mine isnt working at all except for a blue backlight. You are mentioning a Peter who helped you with your problem. Is this someone I could email about this? I bought mine second hand.
oberdada
erkahulle wrote:
You are mentioning a Peter who helped you with your problem. Is this someone I could email about this? I bought mine second hand.


That would be monsieur Blasser himself.

Nice module when it works.
erkahulle
Aha! Haven't done proper research on him. Thanks!
erkahulle
Does anyone know if it is possible to get hold of the Denum schematics?
MUFF WIGGLER Forum Index -> Ciat-Lonbarde  
Page 1 of 1
Powered by phpBB © phpBB Group