MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Reaktor 6 plugin problem not found in standalone
MUFF WIGGLER Forum Index -> Music Software  
Author Reaktor 6 plugin problem not found in standalone
echopraxia
Anybody have the issue where they can easily send signal to their ES3 with the standalone version of Reaktor 6, but it doesnt send in the plugin version? Have the correct outputs enabled in cubase, should be able to send it out the same I would imagine. Same problem in FL studio. on Windows 10
listentoaheartbeat
Happy to help, but need more info. Can you post an Ensemble (compressed as a ZIP) that shows how you route the signals in Reaktor?
echopraxia
listentoaheartbeat wrote:
Happy to help, but need more info. Can you post an Ensemble (compressed as a ZIP) that shows how you route the signals in Reaktor?


I'm really just using the default "Blocks New" preset and adding outputs up to 18. my interface is a focusrite scarlett 18i20, so outs 11-18 are set to my ES3s 1-8 jacks. The additional outs work in the standalone app, but not in the plugin. Does that make sense? if its still unclear ill send the .ens.
skyshaver
Reaktor outs do not have access to the sound card when being used in the plug in. They are routed internally in the DAW according to the channel being used and its routing. So if you have Reaktor set to out 17-18 but the channel in the DAW is set to go out 3-4 it's not going to work. Try having your CV go out 1-2 in the default "Blocks New" ens in the plugin and then directing the channel it's on in Cubase to out 11-12 on your sound card and see if that works. Also most DAWS don't allow plug-ins/channels to have access to more than 2 audio outs. Live allows you access to Reaktors mixer as audio ins on other audio channels so you can set up multiple outs in Reaktor on 1 channel and then use multiple channels to address the sound card 2 outs at a time. I don't how the routing would work in Cubase.

I hope that makes sense.
listentoaheartbeat
Check section "Creating Instrument Output Channels for KONTAKT in Cubase" in this article, it explains how to add additional output channels for multi-channel plug-ins in Cubase.

Create an equal number of outputs in the Reaktor plug-in, and you are ready to go. The first two outputs from Reaktor are sent to the original instrument track, the other outputs are sent to the additional output channels you created. As skyshaver explained, Reaktor does not talk to your audio interface directly in this scenario, it talks to your DAW.
echopraxia
skyshaver wrote:
Reaktor outs do not have access to the sound card when being used in the plug in. They are routed internally in the DAW according to the channel being used and its routing. So if you have Reaktor set to out 17-18 but the channel in the DAW is set to go out 3-4 it's not going to work. Try having your CV go out 1-2 in the default "Blocks New" ens in the plugin and then directing the channel it's on in Cubase to out 11-12 on your sound card and see if that works. Also most DAWS don't allow plug-ins/channels to have access to more than 2 audio outs. Live allows you access to Reaktors mixer as audio ins on other audio channels so you can set up multiple outs in Reaktor on 1 channel and then use multiple channels to address the sound card 2 outs at a time. I don't how the routing would work in Cubase.

I hope that makes sense.


okay so that did make sense and it works now, thank you 1000x because this really pushed a lot of this forward for me.

listentoaheartbeat wrote:
Check section "Creating Instrument Output Channels for KONTAKT in Cubase" in this article, it explains how to add additional output channels for multi-channel plug-ins in Cubase.

Create an equal number of outputs in the Reaktor plug-in, and you are ready to go. The first two outputs from Reaktor are sent to the original instrument track, the other outputs are sent to the additional output channels you created. As skyshaver explained, Reaktor does not talk to your audio interface directly in this scenario, it talks to your DAW.


I can't do some of the first steps like you can in Kontakt with Reaktor, no browser tab for instance. Am I misunderstanding something?
echopraxia
also, when using Reaktor fx like we talked about, how do you get midi pitch/gate information to the plugin and then through the ES3?
listentoaheartbeat
echopraxia wrote:
listentoaheartbeat wrote:
Check section "Creating Instrument Output Channels for KONTAKT in Cubase" in this article, it explains how to add additional output channels for multi-channel plug-ins in Cubase.

Create an equal number of outputs in the Reaktor plug-in, and you are ready to go. The first two outputs from Reaktor are sent to the original instrument track, the other outputs are sent to the additional output channels you created. As skyshaver explained, Reaktor does not talk to your audio interface directly in this scenario, it talks to your DAW.


I can't do some of the first steps like you can in Kontakt with Reaktor, no browser tab for instance. Am I misunderstanding something?


I pointed you to a specific section of that article, see above.
echopraxia
Just wanted to let both of you guys know that I got this figured out pretty well now and I couldn't have done it without your help, it really means a lot to me because I've really hit a new level of reach in the modular world. Thank you!
listentoaheartbeat
w00t
skyshaver
Rockin' Banana!
rean1mator
doesn't work the same between stand alone vs plugin mode. atleast in ableton.

the audio outputs in stand alone are automatically mapped to how your audio interface is mapped.

in plugin mode you have to create the plugin track + create additional audio tracks and then route all the audio appropriately in each track. I had to create a group that included the reaktor plugin + an audio track for each output of the es-3 and then send audio from the plugin track to the entire group. if you don't create the group then you can only send audio to one output and won't be able to utilize all your es-3 outs. man stoked i figured this out because it works beautifully and really opens up your options. between blocks and silent way plugin.
senamental
Does anybody know how to route this in Logic X? Works like a charm in Standalone mode but when I try to calibrate my modular oscillator in the DAW with the Pitch CV Out block, the inputs are not reading. Must be a workaround similar to that in Ableton. Thanks ahead of time.
MUFF WIGGLER Forum Index -> Music Software  
Page 1 of 1
Powered by phpBB © phpBB Group