MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Disting Mk4 MIDI Playback question(s)
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author Disting Mk4 MIDI Playback question(s)
lematt
Hi,

I have a few questions about the disting mk4 midi functions:

- does the disting mk4 allow for clocked midi playback right away ? or does it need a custom firmware upload ?

- can we expect a firmware update that would allow to work with a midi playlist of something like 99 files ? or is it impossible ?

- what maximum length for the midi files ? are we limited ?

Thanks !
os
MIDI playback is in the initial mk4 firmware.

The file count may be increased in future, but it will take some juggling things around.

There is no maximum length (other than the FAT32 file size limit).
Lengai
I followed the manual for clocked MIDI. I saved all files in 0 format. Created a .txt file and loaded algorithm J1. I trigger the clock from Pam’s and no file playback. I used the file name for the text file in J1. Don’t understand why nothing happens. Ay ideas?
os
Could you zip and post the files (MIDI and playlist) here?
Lengai
os wrote:
Could you zip and post the files (MIDI and playlist) here?


I will when I can get some time to do it.

In the meantime (if this helps) the MIDI files are 0 format and .mid files. Exporting from Cubase at 480 resolution (there is no option for 24 and I can go well beyond 480 - not sure where the 4.10 algorithm J-1 caps out for resolution or what is the best match if any).

Clock is coming from Pamela's NEW Workout into the X jack on the Disting. I ran A to pitch and B to gate and neither outputs a voltage when using J-1. I have the Disting 5 pin MIDI expander and that does not output MIDI when using J-1 either.

I'm using Disting firmware 4.10 and the manual. The video accompanying it is for a MK3 module and the text file is named different than the 4.10 manual - midi-playlist.txt

The text file is written out per J-1 in the manual like this (file name is midi-playlist.clocked.txt):

disting playlist v1
-loop=1
A11.mid
A12.mid
A13.mid
A14.mid
B11.mid
B12.mid
C01.mid

That's it. The manual says default settings and per-file settings are optional so I went with the header and list of MIDI files.

I was making a list of the MIDI files and trying to set it globally as loop since the MIDI files are loops. Do I need to remove the -loop=1? Or, should I add -loop=1 for each individual MIDI file?

Any advice would be a great help.
os
If you would attached the files I'm sure I'll find the problem right away.
Lengai
Thank you, I appreciate your help. I will try to get them up here tonight after I get off of work.
Lengai
Here is the .zip file of the .txt file and the MIDI files I tried to play using J-1. I tried a couple of times to get it to work. Clock lights up X just fine, but Nothing happens with A and B to play the file.
os
Your playlist was using legacy Mac line endings, which are unsupported.

Try the attached version, which I've fixed.
Lengai
os wrote:
Your playlist was using legacy Mac line endings, which are unsupported.

Try the attached version, which I've fixed.


That's a first. I'll have to look that up. Thank you for the help. I will try it out later today and let you know.
Lengai
Is there an easy answer as to how you removed the legacy Mac line endings? Appears to be an edit to the text file?
os
I used BBEdit (an excellent text editor that makes it clear what sort of line endings you're using).
Lengai
Thank you smile
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group