MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Latency Issues When Running Synth Through Ableton
MUFF WIGGLER Forum Index -> Music Software  
Author Latency Issues When Running Synth Through Ableton
newo
Hi all,

Recently I have been running into trouble as I prepare to preform with my 6U 84HP Eurorack. I wish to plug it into my Alesis IO4 interface, as I do without error in my home studio, and run it through Ableton on my laptop, however anytime the synth is running in Ableton a slow degradation of quality occurs until the sound is barley audible. It almost sounds like a bit crusher, not sure if thats helpful info at all. Surprisingly Ableton is not showing any irregular CPU usage and the program runs fine when producing without the synth.

Here are my PC Specs:

OS Name Microsoft Windows 10 Pro
Version 10.0.15063 Build 15063
System Name DV6T-6100
System Manufacturer Hewlett-Packard
System Model HP Pavilion dv6 Notebook PC
System Type x64-based PC
System SKU LM720AV
Processor Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz, 2001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date Hewlett-Packard F.1B, 10/5/2011
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 13.3 GB
Total Virtual Memory 18.3 GB
Available Virtual Memory 15.8 GB

Thanks,
Newo
Robscorch
First off have you optimized your Windows 10 for DAW work? Go google this and do a few of these things if you haven't already. Of course the obvious go look up Alesis IO4 issues.

Additionally I have been having tremendous Live issues lately it's not just one thing or another it's something different for all of us it seems. I've almost decided to try something else for right now due to all the Live issues I have been working through.

Also have you tried resetting your Live as suggested here on the Ableton website?
preferences.cfg can cause quite a few issues on Windows machines currently.

Another thing you can do is take the multi-core processing off which helped me tremendously. Go to the options tab and go to preferences. When the window comes up go to the cpu tab and select the multi-core/multiprocessor support off.

Hope this helps some, but honestly at least for me Windows 10 and Ableton Live are not playing well. I have a Focusrite Scarlett 6i6 and it's been the pits lately as well. It's an older model the newer ones may not have similar issues at all.

You can also try making sure you have no USB conflicts this plays hell with audio period.
Vortico
This is 99% likely an ASIO driver issue. Go to the audio settings in Ableton and make sure that ASIO -> *something with IO4 in the name* is selected. If DirectX or MMS is selected you'll have horrible latency and sample rate conversion issues. If ASIO is selected, uninstall the drivers, go the Alesis' website and download the latest, and reinstall. If all else fails, try ASIO4ALL.
vdd
If it is not the Driver, the other 1% could be the signal level.
How do you connect your Rack to the audio interface? You should be aware, that the signal level is way beyond line level.
Your audio interface expects something like -10 or +4dbU. This is a magnitue lower than the level of a modular system, which will be around 10V/pp.
Try to attuniate the output signal of your synth. If the distortion-effect is gone, then you know that the inputs were driven too hard.
newo
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!
TS
Yeah, your buffer filled up.
Shledge
Sounds like you're not using ASIO. I can reach a buffer of 64 samples without issue on Ableton, and that's with a PC that's using a 2012 era CPU.
Robscorch
newo wrote:
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!


Dude I don't believe you have to go 44.1... go into Windows adjust that up to 44800 in the configuration. Then do the same for Ableton now if your having any drop outs or issues go back, but you should be getting better results than this with a quad core at least hardware wise.

I'm thinking your having conflicts and like said maybe over driving the input a bit, but that should be slowing your machine down any it will just sound like digital dog poop and get all clippy. MY ASS IS BLEEDING
newo
Robscorch wrote:
newo wrote:
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!


Dude I don't believe you have to go 44.1... go into Windows adjust that up to 44800 in the configuration. Then do the same for Ableton now if your having any drop outs or issues go back, but you should be getting better results than this with a quad core at least hardware wise.

I'm thinking your having conflicts and like said maybe over driving the input a bit, but that should be slowing your machine down any it will just sound like digital dog poop and get all clippy. :omg:


Yeah you're totally right I easily should be able to go to 44800, however, I can't seem to figure out how to configure it in windows, I found this reddit thread, but there are so many sound devices I don't know which to adjust... https://www.reddit.com/r/audioengineering/comments/3fnk5b/psa_for_wind ows_10_users_set_your_windows_sample/
newo
Robscorch wrote:
newo wrote:
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!


Dude I don't believe you have to go 44.1... go into Windows adjust that up to 44800 in the configuration. Then do the same for Ableton now if your having any drop outs or issues go back, but you should be getting better results than this with a quad core at least hardware wise.

I'm thinking your having conflicts and like said maybe over driving the input a bit, but that should be slowing your machine down any it will just sound like digital dog poop and get all clippy. :omg:


Nevermind, I got it. I will try 24 bit 448 and keep the sample size at 2048, hopefully it works, thanks!
newo
Robscorch wrote:
newo wrote:
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!


Dude I don't believe you have to go 44.1... go into Windows adjust that up to 44800 in the configuration. Then do the same for Ableton now if your having any drop outs or issues go back, but you should be getting better results than this with a quad core at least hardware wise.

I'm thinking your having conflicts and like said maybe over driving the input a bit, but that should be slowing your machine down any it will just sound like digital dog poop and get all clippy. :omg:


Ok so I adjusted the system sound to 448, but in Ableton and ASIO I am not having an option for 448 it only gives me 441, 220, 882, 17640...
Robscorch
newo wrote:
Robscorch wrote:
newo wrote:
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!


Dude I don't believe you have to go 44.1... go into Windows adjust that up to 44800 in the configuration. Then do the same for Ableton now if your having any drop outs or issues go back, but you should be getting better results than this with a quad core at least hardware wise.

I'm thinking your having conflicts and like said maybe over driving the input a bit, but that should be slowing your machine down any it will just sound like digital dog poop and get all clippy. MY ASS IS BLEEDING


Ok so I adjusted the system sound to 448, but in Ableton and ASIO I am not having an option for 448 it only gives me 441, 220, 882, 17640...


hmmm..... That should be an option what version of Live are you running currently? Your Alesis card does effect this, but I've never had that NOT be an option in Ableton. I've run literally 20-30 different sound cards teaching Ableton to folks and I can't recall once where 448 isn't an option.

I'm 2 versions behind myself seems to be the most stable right now in my system.
newo
Robscorch wrote:
newo wrote:
Robscorch wrote:
newo wrote:
All fixed, just had to play around with some settings. Ended up changing the Rate down to 44100 and the sample size to 2048. Thanks for all of your inputs!


Dude I don't believe you have to go 44.1... go into Windows adjust that up to 44800 in the configuration. Then do the same for Ableton now if your having any drop outs or issues go back, but you should be getting better results than this with a quad core at least hardware wise.

I'm thinking your having conflicts and like said maybe over driving the input a bit, but that should be slowing your machine down any it will just sound like digital dog poop and get all clippy. :omg:


Ok so I adjusted the system sound to 448, but in Ableton and ASIO I am not having an option for 448 it only gives me 441, 220, 882, 17640...


:hmm: That should be an option what version of Live are you running currently? Your Alesis card does effect this, but I've never had that NOT be an option in Ableton. I've run literally 20-30 different sound cards teaching Ableton to folks and I can't recall once where 448 isn't an option.

I'm 2 versions behind myself seems to be the most stable right now in my system.


It's Live 9.7.2, I believe it's the most recent update, not sure. I set my system at 88200 24 bit, as well as ASIO and kept the sample size at 2048 and everything is running brilliantly. Loaded up a pretty busy project file and ran my synth without the slightest pop or crucnch!
Infinity Curve
You shouldn't have to have your sample size nearly that high - that is likely adding huge in/out latency to your system. Bring it down until you are getting breakup and pops, then back it off just enough until they stop.

I run at 96khz, 24bit with something like 128 sample size and my in/out latency is around 4ms, which is pretty much imperceptible, at least to me. With your sample size set to such a large amount, I would expect your in/out latency is more like 30-40ms if not more, which would be noticeable if you were playing a midi clip from the DAW to the external instrument and then listening to the incoming audio track, the audio track would be slightly delayed from your internal DAW tracks, especially noticeable with drums or clock sync'd sequences like arps or something. At that kind of latency, if you were to press a key in the DAW to trigger a note on the external unit, you would hear/feel the delay. Not ideal

It's a fine balancing act between what your CPU and interface can handle, but ideally you want to try and get things as low as you can with what you have to work with. Might be worth trying the ASIO4ALL drivers rather than the Asio drivers that come with your interface, sometimes improves things as well.
newo
Infinity Curve wrote:
You shouldn't have to have your sample size nearly that high - that is likely adding huge in/out latency to your system. Bring it down until you are getting breakup and pops, then back it off just enough until they stop.

I run at 96khz, 24bit with something like 128 sample size and my in/out latency is around 4ms, which is pretty much imperceptible, at least to me. With your sample size set to such a large amount, I would expect your in/out latency is more like 30-40ms if not more, which would be noticeable if you were playing a midi clip from the DAW to the external instrument and then listening to the incoming audio track, the audio track would be slightly delayed from your internal DAW tracks, especially noticeable with drums or clock sync'd sequences like arps or something. At that kind of latency, if you were to press a key in the DAW to trigger a note on the external unit, you would hear/feel the delay. Not ideal

It's a fine balancing act between what your CPU and interface can handle, but ideally you want to try and get things as low as you can with what you have to work with. Might be worth trying the ASIO4ALL drivers rather than the Asio drivers that come with your interface, sometimes improves things as well.


Huh I have been drumming on my launchpad with a patch ion the Eurorack running and I haven't experienced the delay, but I do think you are right, I need to find a happier medium. Thanks! here's an example: https://www.instagram.com/p/BW0S_uIBmL6/?taken-by=pma.newo
newo
Infinity Curve wrote:
You shouldn't have to have your sample size nearly that high - that is likely adding huge in/out latency to your system. Bring it down until you are getting breakup and pops, then back it off just enough until they stop.

I run at 96khz, 24bit with something like 128 sample size and my in/out latency is around 4ms, which is pretty much imperceptible, at least to me. With your sample size set to such a large amount, I would expect your in/out latency is more like 30-40ms if not more, which would be noticeable if you were playing a midi clip from the DAW to the external instrument and then listening to the incoming audio track, the audio track would be slightly delayed from your internal DAW tracks, especially noticeable with drums or clock sync'd sequences like arps or something. At that kind of latency, if you were to press a key in the DAW to trigger a note on the external unit, you would hear/feel the delay. Not ideal

It's a fine balancing act between what your CPU and interface can handle, but ideally you want to try and get things as low as you can with what you have to work with. Might be worth trying the ASIO4ALL drivers rather than the Asio drivers that come with your interface, sometimes improves things as well.

Rad, through it back down to 128 and I am at 6.8 ms in and out
Infinity Curve
Boom! thumbs up

It will make a difference when you get to recording stuff, so the audio recordings will still be relatively tight to the grid
Robscorch
Love hearing that you got it. This is something we all deal with it's a trade off for sure. thumbs up
MUFF WIGGLER Forum Index -> Music Software  
Page 1 of 1
Powered by phpBB © phpBB Group