MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Broken Make Noise MMG Freq Poti
MUFF WIGGLER Forum Index -> Eurorack Modules  
Author Broken Make Noise MMG Freq Poti
m:o
Hi
lately my MMG produces weird crackling noise when turning the Freq Knob.
It seems the Poti is an Alpha B10K with d-shaft and not so hard to replace by myself (warranty ran out).

Could anyone say if this one here is the right 10K pot?
https://www.thonk.co.uk/shop/alpha-9mm-pots-dshaft/

is there any other supplier in Germany for that pot?
(Make Nosie support has not answered my request yet)

THX!
pitri
ha, i have the same problem on mine!
Interresting- is it throughout scratchy? mine has is only at 1 o`clock.
wavedepletion
Same problem here. My MMG Freq knob suddenly started crapping out after about 2 years. It would crackle and pop when moving between 9 and 12 o'clock. Wouldn't happen when changing the cutoff Frequency via CV, so I knew it had to be the pot.

I was too impatient to contact Make Noise and mail it in for repair. So I fired up my soldering iron and replaced it myself with the Alpha B10k Linear pot from Thonk. The difference is MN uses a shorter plastic D-shaft, and the Thonk one is slightly taller with a metal d-shaft. So the knob sits a little higher off the panel. But it works fine and only took a few minutes.
Mikeyg3k
I sent mine into MN they fixed it and got it back to me quickly.
nolongerhuman
Yep, it happened to mine as well. Make Noise had it fixed and shipped back in less than a week. It sounds like it might be a common thing.
plainjanefrancis
nolongerhuman wrote:
Yep, it happened to mine as well. Make Noise had it fixed and shipped back in less than a week. It sounds like it might be a common thing.


Was yours under warranty? If not, any chance you could say how much it cost? I've never noticed the problem because I generally use CV to change the filter, but I'd like to know if it's low cost enough to go ahead and send it in razz
yellowecho
The Freq and HP/LP knobs on my MMG crackle :(

Did they repair the pots for free when ya'll mailed them?
BaloErets
I'll just jump in to say that mine displays this noise w/ the freq. pot as well.
nolongerhuman
plainjanefrancis wrote:
nolongerhuman wrote:
Yep, it happened to mine as well. Make Noise had it fixed and shipped back in less than a week. It sounds like it might be a common thing.


Was yours under warranty? If not, any chance you could say how much it cost? I've never noticed the problem because I generally use CV to change the filter, but I'd like to know if it's low cost enough to go ahead and send it in razz


I guess technically it would have been, it was 9 months old at the time, but they didn’t ask or seem concerned about it. Make Noise has pretty fantastic service.
JonathanBedrava
Weird! Same thing happened to mine. I sent it out a couple of weeks ago and am still waiting for word. Maybe they are working through their holiday backlog?
wavedepletion
My Mode potentiometer is now crackling also, just a few weeks after replacing the Frequency pot. So weird that these are all dying. Maybe the MMG is just so good that we're constantly fiddling with it and wearing them out.

No biggie though, still my favorite filter. And I'm glad I have lots of extra b10k linear pots laying around. thumbs up
stefOT
Got the same problem here with almost all my MN modules...
Is the b10k linear pots are the good ones for replacement on MN pots ?
are they on thonk as well ?

is it that complicated or confusing to fix this by our own ?
like , just buy a bunch of plots at thonk and fire the solder ?
seriously, i just don't get it
JakoGreyshire
I wonder if fader lube would clean out the pots and remove some dirt that is causing contact crackle? I used to get wah pedals from guitar players that thought the wahs were dead and crackling... I would just clean the pots and they'd be as good as new....

Could be the pots though I guess... anyone know more about the actual pots? are they shite?

seriously, i just don't get it seriously, i just don't get it
plainjanefrancis
Had the same problem. Contacted MN, they repaired mine for 50 bucks this week. <3
debolish
+1 on the crackling. sad banana
wavedepletion
stefOT wrote:
Got the same problem here with almost all my MN modules...
Is the b10k linear pots are the good ones for replacement on MN pots ?
are they on thonk as well ?

is it that complicated or confusing to fix this by our own ?
like , just buy a bunch of plots at thonk and fire the solder ?
seriously, i just don't get it


Replied to your PM. But for the sake of others: Yes the Alpha B10k Linear pots (D-Shaft) from Thonk will work. Note the input attenuation pot at the top is a B100k. They are almost the same - The stock MN ones are a little shorter and have a black plastic d-shaft, vs the slightly taller metal d-shaft ones from Thonk. With the Thonk ones the knob may not quite sit flush with the panel. Doesn't bother me though.

I haven't had one of these Thonk pots go bad on me yet.


JakoGreyshire wrote:
I wonder if fader lube would clean out the pots and remove some dirt that is causing contact crackle? I used to get wah pedals from guitar players that thought the wahs were dead and crackling... I would just clean the pots and they'd be as good as new....

Could be the pots though I guess... anyone know more about the actual pots? are they shite?

seriously, i just don't get it seriously, i just don't get it


I tried the fader lube thing before replacing mine. Doesn't work - theres no room at all between the shaft and the body to get any liquid sprayed in.

Can confirm this is a common problem with MN - had more pots go "scratchy" since posting earlier. Just wick out the old solder, pull'em out and replace them (or send it to MN).
JakoGreyshire
^ Thanks...

thumbs up thumbs up
eltnet
+1 crackling on filter + freq attenuverter…
MN said that is not common…


is it the same linear 10k pot for attenuverter ?
thx


edit: already tried to clean it with contact cleaner / lubricant without success.
Chartreuse-J
Easy fix, real easy, take the knobs off and face plate, spray offending crackiling pot with electronic cleaner (got mine at autozone) and wala no more crackle, works for switches too!

Pot will have more friction after clean, use non-conductive di-electric grease to re-lube pot.
MUFF WIGGLER Forum Index -> Eurorack Modules  
Page 1 of 1
Powered by phpBB © phpBB Group