Stillson Hammer II Power Issues?!

Digital Audio Electronics - discussion & support.

Moderators: Kent, solidox, governor blacksnake

Post Reply
m:o
Common Wiggler
Posts: 121
Joined: Wed Apr 09, 2014 3:58 am

Stillson Hammer II Power Issues?!

Post by m:o » Wed Aug 02, 2017 7:02 am

Hi
i just got a used SHII and got power issues since i put it in my System.
A Synthrotek Super Power Blue (3A +12V) is powering my system with alot headroom.
https://www.modulargrid.net/e/racks/view/484546

Sometimes the system powers up fine, sometimes i will get a full on flickering light show. Around 50/50. I moved the SHII around on the flying bus boards and read about placing it nearest on a connector to the power supply. Nothing did help. Before getting the SHII i never got any power issues.

can anyone help?

best
mo

User avatar
Robscorch
Super Deluxe Wiggler
Posts: 1762
Joined: Sat Mar 08, 2014 11:52 am
Location: Just this side of hell Texas
Contact:

Post by Robscorch » Sun Aug 06, 2017 2:59 am

Synthrotek power supply is your first kinda issue. I had nothing, but problems with the one I had and since went back to good old fashioned Doepfer. Mine was causing all sorts of noise that almost sounded like aliasing and when you started to push 2A it would flicker shut off and act goofy. This is to be expected look at the specs on the blue... 2.5A is the draw and your approaching 2000 with your current set up. I like to leave a bit more room then that these days you maybe overloading it a bit. Leaving at least a full amp open is a good idea due to the intensive draw of some digital and power hungry VCA's. CHECK that wall-wart as well these things are notorious for failing and causing noise issues with these sorts of power supplies. They are the devil.

One think to do is go one module at a time removing them and see if there is another culprit besides the SHII. If you don't already have a multi-meter I suggest you get one of these (doesn't have to be expensive I have a radioshack and fluke) and start probing your rails a bit to see what sort of values your getting out of the them. If your not comfortable enough with this don't do it you can hurt yourself so there is MY end of liability. Best of luck I hope you can find the root cause. It's kinda like mechanics you don't just go off replacing things half cocked on a sheer guess. Try to eliminated things one at a time and remember that these sorts of things happen and it's always a good idea to have a proper power supply. After all the power is the heart of your system not the modules you stuff in it. :tu:

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sun Aug 06, 2017 6:01 pm

I have a pair of Synthrotek Deluxe power modules and have had no issues personally.

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sun Aug 06, 2017 6:17 pm

The Bel Power Solutions HDCC-150W-AG is highly recommended on the Metasonix subforum.
$241
http://www.alliedelec.com/bel-power-sol ... /70005997/

User avatar
Robscorch
Super Deluxe Wiggler
Posts: 1762
Joined: Sat Mar 08, 2014 11:52 am
Location: Just this side of hell Texas
Contact:

Post by Robscorch » Sun Aug 06, 2017 7:35 pm

mt3 wrote:I have a pair of Synthrotek Deluxe power modules and have had no issues personally.
The latest ones are supposedly better. Check the supply.

User avatar
sackley
Veteran Wiggler
Posts: 704
Joined: Sat May 04, 2013 8:00 am
Location: Somewhere in the Connecticut woods...
Contact:

Post by sackley » Sun Aug 06, 2017 7:53 pm

Likewise. Been using Deluxe power for quite some time with no issues, but it's just a 6u x 84hp case, so shouldn't be pushing the limits.

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Sun Aug 06, 2017 8:29 pm

A good rule of thumb is to load the PSU down with no more than 80% of what it's rated for.
So a 2A PSU should power no more than 1.6A of modules.

m:o
Common Wiggler
Posts: 121
Joined: Wed Apr 09, 2014 3:58 am

Post by m:o » Mon Aug 07, 2017 6:49 am

Thanks so far.

The new Synthrotek Super Power supplies are well received around here.
Also, in total i have 1A headroom, which is 1/3rd of the overall specs and therefore not "pushing" the boundaries.

In General, are fixed powerboards more reliable/better than flying bus boards? As i said, i never had power issues before. Also, when there is insufficent supply or another problem with the power and the modules, why does it works sometimes ?

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Mon Aug 07, 2017 11:08 am

Complicated question. Complicated answer.

In general you want star busboards.
Lots of threads discussing these issues.

m:o
Common Wiggler
Posts: 121
Joined: Wed Apr 09, 2014 3:58 am

Post by m:o » Thu Aug 10, 2017 5:04 am

So far, thanks for your help.

Thinking about building a new case with 2 Doepfer PSU3`s - ditching the Flying Bus boards completely.

best

User avatar
mt3
Super Deluxe Wiggler
Posts: 2889
Joined: Thu Oct 09, 2014 11:18 pm
Location: vancity
Contact:

Post by mt3 » Fri Aug 25, 2017 3:57 pm

Some good Hinton knowledge:
viewtopic.php?t=187749

Post Reply

Return to “The Harvestman”