MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

VSTs, OSX, and "unidentified developer"
MUFF WIGGLER Forum Index -> Music Software  
Author VSTs, OSX, and "unidentified developer"
Manresa
I recently upgraded to a new Mac because my old one took a catastrophic fall and have been working my way through installing my plugins for Ableton. I’ve been downloading from each developer’s site and a few are giving the error "can’t be opened because it is from an unidentified developer".

I know there’s a workaround, but even if I get the installer to run and can see the VST in my Library the plugin isn’t recognized by Ableton. (AUs are seen but won’t run, and won’t validate in MainStage.)

I’ve tried tech support but haven’t heard back after more than a day.

Has anyone else had this problem? Is there a solution (other than crossing my fingers and being patient)?

thanks
analogue01
When installing and you get that pop-up just go to settings > security & privacy. Then unlock using the admin password and underneath where it says "allow apps... etc" you should be allowed to approve the specific unidentified thing you want to install.
Manresa
analogue01 wrote:
When installing and you get that pop-up just go to settings > security & privacy. Then unlock using the admin password and underneath where it says "allow apps... etc" you should be allowed to approve the specific unidentified thing you want to install.


Thanks.

I’ve gotten that far, and the installer runs, but Ableton won’t recognize the VST (but does see others from the same developer that didn’t have a warning when opened.) The AU version is visible in Ableton, but doesn’t show up in a track.

Just dragging the VST over from my old install doesn’t work either, despite no copy protection.

It’s weird.
nostalghia
Is the VST you're having the problem with 64 bit, or 32 bit?
What version of Ableton, and what OS X version running on the Mac?

I updated to Cubase 9 (Artist) when I got a newer iMac (running El Capitan) to replace my old Mac Pro. This latest version of Cubase no longer supports 32 bit VSTs.
Most of my old plug ins now have an available 64 bit version on the developer's download page, but a few did not-old VSTs that are no longer supported by the dev, never were upgraded to 64 bit.
Manresa
nostalghia wrote:
Is the VST you're having the problem with 64 bit, or 32 bit?
What version of Ableton, and what OS X version running on the Mac?

I updated to Cubase 9 (Artist) when I got a newer iMac (running El Capitan) to replace my old Mac Pro. This latest version of Cubase no longer supports 32 bit VSTs.
Most of my old plug ins now have an available 64 bit version on the developer's download page, but a few did not-old VSTs that are no longer supported by the dev, never were upgraded to 64 bit.


OS X 10.12.6
Ableton 9.7.3

Absolute brand-new fresh install of Ableton on new, factory fresh Mac. The only other software (aside from plugins) I’ve installed on the Mac are Chrome & Native Access.

Both plugins are 64-bit.
Manresa
I got responses from both developers—one helped me diagnose the problem (I’m an idiot) and the other confirmed that the plugin is indeed broken on newer Macs. The good news is it will be updated soon. Huzzah!

Thanks for helping me out.
MUFF WIGGLER Forum Index -> Music Software  
Page 1 of 1
Powered by phpBB © phpBB Group