MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Waldorf XT buttons intermittently working
MUFF WIGGLER Forum Index -> Music Tech DIY  
Author Waldorf XT buttons intermittently working
thewizmusic
Was wondering if anyone could help with this problem I am having. The power button doesn't shut off it only counts down but doesn't stay shut off. The utility button I have to wiggle to change the options. All other buttons are fine. I replaced 2 transistors because they looked slightly heated/ melted but just barely. I don't really see anything other than that and I don't want to start replacing everything. Do those buttons actually go bad or would it be resistors other capacitors or diodes?

Any ideas why a hold power button would not stay powered down?

Thank you for any and all assistance
thewizmusic
does someone atleast have a component list for the XT?
krazh
not comprehensive but hope this helps.
thewizmusic
Krazh,

You are the sh!t! Thank you so much! More than what I needed but absolutely perfect!

Thank you so much again!
krazh
thewizmusic wrote:
Krazh,

You are the sh!t! Thank you so much! More than what I needed but absolutely perfect!

Thank you so much again!



hope you managed to get it sorted.
best.
thewizmusic
Hey thanks again! I took it to a repair shop but the guy isn't sure which board handles the power and which is the main board or if they both handle power!? You have any idea?

Thanks again!
Starspawn
thewizmusic wrote:
Hey thanks again! I took it to a repair shop but the guy isn't sure which board handles the power and which is the main board or if they both handle power!? You have any idea?

Thanks again!


If he is not sure about that you shouldnt let him handle your synth.
thewizmusic
You have a slight point if it's an ideal world. If you know someone who specializes in the XT I would be happy to go with them. I did notice he first was saying that a board should be possibly be replaced but the synth is working minus some button glitchiness. That seems general component problems not major chips or the board.

To be fair:
These synths do not have much info regarding repairs out there. I would believe with some info that's searchable someone could locate the problem but cautiousness and looking for clarity is not a bad thing. I've done some repairs myself and maybe there is some general system a pro can use but for me every board is different. I will give it some time he said he won't touch it unless he confirms with me to do the work.
krazh
thewizmusic wrote:
Hey thanks again! I took it to a repair shop but the guy isn't sure which board handles the power and which is the main board or if they both handle power!? You have any idea?

Thanks again!


well, sorry to hear that.
the schematic on pages 11 & 10 of the document seem to offer some clues.

folks at The Analog Lab might be able to help, not had direct experience with them though.
MUFF WIGGLER Forum Index -> Music Tech DIY  
Page 1 of 1
Powered by phpBB © phpBB Group