MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Problem with SD card playback on dusting Mk 4
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author Problem with SD card playback on dusting Mk 4
Migrigsynth
Hopefully somebody can help me out on this because I'm pulling my hair out trying to figure out what I'm doing wrong. For some reason when I go to the I-1 algorithm for SD card audio playback the audio files will not play. The SD card is a brand new card formatted according to the directions for audio playback on the Disting. I've tested the card in the K-1 mode for wavetable the VCO playback and everything works fine so I know it's not a card issue.
The audio files that I'm trying to play were downloaded from Tom Whitwell's website for the Radio Music module. Here is the website address for reference: "https://github.com/TomWhitwell/RadioMusic/wiki/Audio-for-the-SD-Card" . The files were originally in RAW format and I converted them in Audacity to 16 bit 44 kHz files. I created a playlist according to the directions on the Disting website but cannot for the life of me figure out why the files are not playing. Would there be a reason why converting from RAW format would cause any problems?

Any help on this would be greatly appreciated in addition to any suggestions I might try next.
os
Could you zip up and attach the playlist, and one of the wav files?
Migrigsynth
Thanks for the quick response. As soon as I get home from work I'll attach a zip file. thumbs up
Migrigsynth
Please see file attached above.

Thanks for your help
os
Your playlist has a weird mix of line endings:
Migrigsynth
Wow, all those extraneous endings were not visible when I was editing the file. I'm using OS Xs text edit in plane text mode. I'll have to use a different text editor. What program would you recommend to edit plaintext playlists? I see you're using TextWrangler.

Thanks
os
I recommend TextWrangler.
Migrigsynth
Well, first off thank you. Second, sorry to waste your time. I downloaded TextWrangler and used that to edit the file and immediately noticed that there were extraneous characters for carriage returns. Needless to say, I edited the file with that program, saved it, loaded it into the Disting and it worked like a charm. I should've checked this in the first place but being a complete rookie that I am I looked right past it. d'oh!

Thanks very much OS thumbs up

In addition to you awesome support, your module is pretty fantastic! Presently I own the Disting mk4 and Silent Way that I use with Reaktor on a Macintosh. Even has a very inexperienced Wriggler I can see that both products were well thought out.
You just gained another supporter! thumbs up thumbs up thumbs up
LGR
Hi OS,

Thanks for the latest firmware upgrade is really great.
I have been trying to figure out the following issue on the dual audio playback (I7).

Lest say I only monitor output A so every time I have a trigger on both inputs at the same time (X and Y) I can hear the sample for the related output plus an a click or an artefact from the y trigger. I tried several triggers and gates and configurations with no success. Does the read speed on my micro SD card create this issue?

Thank you,
LGR
os
Yes, card speed will affect this. Also if you can use mono samples, things will tend to work better.

I've also made some performance improvements to the code, which I should be able to release soon.
DukeOfPrunes
os wrote:
Yes, card speed will affect this. Also if you can use mono samples, things will tend to work better.

I've also made some performance improvements to the code, which I should be able to release soon.


Thanks!
LGR
Thank you OS! Guinness ftw!
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group