FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 

Burning PH Roms on Mac OS X
MUFF WIGGLER Forum Index -> The Harvestman Goto page 1, 2  Next [all]
Author Burning PH Roms on Mac OS X
So... I am going round in circles and all I really need is PK3CMD for Mac!

Anyone got a clue? Or preferably a link to a little application that I can run and burn these things!

Or even Linux would do... smile

Just no Windows!
Yet to get the time to do this myself.
I didn't have any info in the general pickit thread? Can't use the same process as for updating modules?
Regrettably no, I might have missed it, but it seems this crucial part of the step is skipped!

It's really quite irritating because I know I am just a command away from being able to finally make this happen.

In other news, I updated all the firmwares and replaced the flimsy film screens on PH mk][ and SHmk][ with the nice new ones from the IME shop - well worth the effort! They look a million times better - well that's probably because they are smile

A bit of a faff, but whatever... they are done now!

I was very pleased to see the AB came with the new style screen by default.
Thanks - yeah, that's the thread I've been following...

Sorry, I should clarify, I have pickit3 - so pk2cmd won't work!

pk3cmd is nowhere to be found - although I believe it is meant to exist somewhere!

seriously, i just don't get it
Ah, I think that's programmer banter. pk2cmd means "pickit to command line"!
Try it and report back!
Seems there is nothing in the sea of crappy half baked information out there that provides even the slightest clue about using this with a 3 and the IPE says 'not supported' when I hold the cursor over the device drop down. It actually lists a whole bunch of stuff that's not supported.

I have found a download of an Intel compiled version of pk2cmd that seems to work, but that gives the error message no pickit2 found :(

I'm giving up and ordering a Pickit2 - there may be a chance of it working with that!
Maybe Guv'n'r can chime in...
Pk3cmd discussion:

Looks like you need MPLAB installed.
Maybe... ???

That forum discussion is about Windows .exe and the second one I found too and i have MPLab installed and updated to latest version. No joy!

The thing that surprises me most is that on the microchip developer support pages a search for 'pk2cmd' returns zero results.

I mean come on...

I finally found a compiled version of pk2cmd on a google group that someone had done a few years ago, it seems to run and provide meaningful error messages that imply that a Pickit2 will work.

It's only £18 delivered from Amazon... and it's on it's way!

Hehe... crazy stuff smile

I'm not that bothered about creating my own SSWF, I can do that to my hearts content in far easier ways elsewhere, I would just like to have a different selection on the PHmk][ so I don't have the repeating group. It's unlikely I'll even bother after that, maybe one day if I feel a burning need, but I am already happy with the standard banks so another 6 different ones will provide enough exploration for years to come.
I think MPLAB is a gui wrapper of pk3cmd.
Can you right click on MPLAB app and "show package contents "?
Good idea - thanks - I looked and at least I confirmed this from the PK3CMD readme:

Operating System Support List:

Microsoft Windows 7 Professional/ Windows 8 Professional/ Windows 10 Professional:

Still couldn't find an executable though!
mt3 791065
Thanks, had a quick look and there just seems to be a lot of posts and even more confused people out there grin

I have packed everything away now, it's quite late and I have an early start in the morning and a very long day ahead. I'll try again when the picket2 turns up, maybe at the weekend!

Thanks for all the suggestions - really appreciate your efforts smile
/Applications/microchip/mplabx/v4.00/docs/Readme\ for\ PK3CMD.htm

is a file discussing pk3cmd.
It says:
"PK3CMD is a 32-bit command-line interface to MPLAB PK3CMD device programming support. The PK3CMD tool is provided for legacy users (MPLAB IDE v8.xx) for backward script compatibility. It will not be enhanced with new features. Please use the IPECMD going forward for all future functionality."

/Applications/microchip/mplabx/v4.00/docs/Readme\ for\ IPECMD.htm

IPECMD replaces it and runs on all OSes.
Oooh missed that - good find!!!

It's like a bizarre treasure hunt screaming goo yo

I can't do anything at theoment, but will try and find some time sooner rather than later to try and work this out.

Did either of you get this working? I'm having a hell of a time!

I have access to a Mac on 10.12 (upgradable if needed) and a Windows 10 laptop.

I started on Mac, got MPLAB IPE up and running, but couldn't get my Pickit3 to be detected.

Tried to download firmware in the IDE, realized that neither of them supported Pickit3s for 25Lc512 on the current version (4.15), so went to an old one (2.something). No luck and just kinda got lost. Checked my usb and saw it (with SN) loud and clear.

Moved to a PC - went through the various Pickit 3 utilities there and found out about the Pickit3 standalone programmer and scripting thing (and alternate firmware). I installed the alternate FW and was able to get it to read and verify my blank chips after writing back the read contents and very occasionally write _something_ - like I could change a blank chip to having some data on it, but not the rom I was trying to write. I tried various power things - 0, 1.1 (from checking the programmer), 3.3, and 5v, and all the same results - it didn't seem like I was actually interfacing with the data on the chip.

Moved back to the Mac with the firmware updated, found this thread, messed around with ipecmd. I could run it from the MPLAB package, and it would complete without any options specified (just the chip and hex and pickit 3 specified, and would throw errors if I messed those up), but as soon as I added a write or a verify to it, it would hang forever (I had to ctrl+c out of the java).

That's where I am now - Pickit3 is in programmer mode, can load hexes, can't write them. What am I missing? Does it need to be in MPLAB mode for the command line stuff to work?

Running (from my MPLAB's Java folder)
java -jar ipecmd.jar -TPPK3 -P25LC512 -F/path/to/my/rom.HEX -M
StudentsOfTheFuture are you only burning ROMs?
Do you have any Harvestman modules you could update firmware to test out?
Only roms so far, I think my PH the newest (would that work?), and I have a MK1 Zorlon and HD but I'd rather leave as-is if possible.

Buddy's got a Disting so there's that in the mix...

I was reading through the Stillson guide and I think my Check function is working-ish, cause that's where I got the 1.1v from - check communication w/ my programmer board hooked up.

And got a (fake) Pickit2 on the way just in case.
StudentsOfTheFuture wrote:
I think my PH the newest (would that work?).

Yes PHmk2 works excellent for testing the pickit.

The latest firmware is version 2.5, which is the first to display the version on startup.
If no version is displayed, you're using an older firmware.
Try updating the firmware to help isolate the issue(s).

I didn't mention, but I have not had the time to burn ROMs yet.
Trying to update my 2.52 PH to ... 2.52 (but that should work other than not actually doing anything right?) I get...

java -jar ipecmd.jar -P33FJ128GP310A -F/path/to/pistonFW252/pistonmk2v252.hex -M -TPPK3
Logging location is set to default
Connection Failed.
Connection Failed.
Programming Target Failed.

Which is the closest I've gotten to anything so far!

Dumb question but what direction do you face the programmer on the PH? I tried both and got the same thing but I figure it probably does make a difference.

Also, I get:

Available Tool List
1 PICkit3 S.No : None (VID 04D8, PID 900A)


Tried w/ the same syntax on the programmer boars and I get the infinite hang after "Logging location is set to default".
I hate having to point you to over to another thread, but look here:

Yes, the direction of the programmer matters (USB-to-computer side primarily).
After you've connected the pickit to the PHmk2, the module then needs to be powered on.

I realize the GUI is probably just syntactic GUI sugar, but did you try MPLAB IPE with the PHmk2?
Yeah - I'm literally wondering which way is up on the PH MK2 hihi

I didn't see the handy pin 1 marker like on the programmer board.

Read the first post of that thread through a couple times and missed it but if its in there I'll check again (thanks for compiling everything - there's a LOT of good info there and I wouldn't have made it this far without it!)

I'll run through via the IPE - definitely couldn't hurt! Occurred to me that my Pickit's still in stand-alone mode so I might want to switch it back too. That would be a real dumb explanation.
MUFF WIGGLER Forum Index -> The Harvestman Goto page 1, 2  Next [all]
Page 1 of 2
Powered by phpBB © phpBB Group