ROT8

Support and discussion for Antumbra modules and DIY builds

Moderators: Kent, antumbra

Post Reply
User avatar
antumbra
Common Wiggler
Posts: 71
Joined: Fri Mar 20, 2015 5:21 pm
Contact:

ROT8

Post by antumbra » Wed Nov 15, 2017 12:26 pm

Discussion regarding the Antumbra ROT8 module.

http://antumbra.eu/modules/rot8

Image



Videos about ROT8 in action:

[video][/video]

[video][/video]
www.antumbra.eu
soundcloud.com/monolitmusic

User avatar
synthetek
Wiggling with Experience
Posts: 475
Joined: Fri Jun 05, 2015 3:32 am
Location: Orange County, California
Contact:

Post by synthetek » Tue Mar 27, 2018 2:16 pm

I am almost done building a Rot8 1.1 PCB and just noticed that C2 is not in the BOM or build doc. Anyone know what's supposed to go at C2?
Thanks

User avatar
synthetek
Wiggling with Experience
Posts: 475
Joined: Fri Jun 05, 2015 3:32 am
Location: Orange County, California
Contact:

Post by synthetek » Thu Mar 29, 2018 10:25 pm

I found the answer to this, C2 should be left unpopulated on the 1.1 PCB

User avatar
Spastic_Colon
Learning to Wiggle
Posts: 44
Joined: Mon Nov 06, 2017 2:11 pm
Location: London

Post by Spastic_Colon » Sat Mar 31, 2018 3:24 am

Just ordered my mouser BOM for V1.1. This will be my first ‘proper’ module build. Couldn’t be starting with a cooler looking module.

Zek
Common Wiggler
Posts: 57
Joined: Sun Nov 20, 2016 5:09 am
Location: Brussels

Post by Zek » Fri Apr 20, 2018 1:30 am

Just finished building one yesterday. I haven't tested it with sound yet, but everything seems to work fine as the switches and leds are working well together, regarding the manual. Firstable I would like to thank David for his listening and supporting.
It's an easy build, no small parts or tricky stuff, just pay attention to the orientation of IC'S, leds etc... It's not a beginner build, but if you have quite a few smd builts behind you it's ok.
I had trouble concerning the flashing, but it's not because of the module but because of my laptop. I use virtual box on mac and it took me 2 days to see that Windows wasn't seeing the programer. Anyway, after I fixed it it was easy.
On Antumbra's website there's an explanation with AVRDudess, which I couldn't use because of all that shit, so I used Atmelstudio. If you need some advice to use it feel free to pm me or you can follow this http://www.markfrancombe.com/wordpress/ ... ram-chips/
I will play with it now! It's a really good looking sequencer, the panel is nice, good quality, and it's really cheap to build!

User avatar
pix
Veteran Wiggler
Posts: 673
Joined: Fri Jul 31, 2009 2:40 pm

Post by pix » Sat May 26, 2018 7:20 am

looking for cheaper programmers I found these two on amazon with good reviews. Any reason why they won't work?





User avatar
Spastic_Colon
Learning to Wiggle
Posts: 44
Joined: Mon Nov 06, 2017 2:11 pm
Location: London

Post by Spastic_Colon » Tue Sep 04, 2018 6:41 am

Hey guys, I appear to have successfully built my Rot8, but am struggling with the flashing (not something i've done before). I'm using a Twarm.com AVR ISP MkII, and trying to run it through AVRDUDESS. It doesn't seem to be picking up the MCU (which i'm guessing is the controller). Please help!

User avatar
Spastic_Colon
Learning to Wiggle
Posts: 44
Joined: Mon Nov 06, 2017 2:11 pm
Location: London

Post by Spastic_Colon » Tue Sep 04, 2018 12:26 pm

I keep getting this message;

Timestamp: 2018-09-04 18:25:14.320
Severity: ERROR
ComponentId: 20100
StatusCode: 131103
ModuleName: TCF (TCF command: Device:erase failed.)

Failed to start programming session before chip erase:Failed to enter programming mode. Error received from tool:
Target not detected

Squash
Learning to Wiggle
Posts: 7
Joined: Mon Jul 02, 2018 7:13 am
Location: London

Step buttons not working

Post by Squash » Fri Oct 19, 2018 11:51 am

Hi All,

I have built a ROT8 today and managed to get it flashed correctly.

However, all seems to work except the step buttons. They do not seem to respond at all on any menu page.

The only mistake that I know of was forgetting to solder the left side of U1 before powering up (oops) which I have since soldered. Turns out these pins corresponded to all of the outputs (Qa-Qh) as well as the chip's ground pin. Could this have damaged this shift register chip?

Any support would be greatly appreciated!

Thanks!
Squash

Squash
Learning to Wiggle
Posts: 7
Joined: Mon Jul 02, 2018 7:13 am
Location: London

Post by Squash » Sat Oct 20, 2018 6:50 am

Reflowed the Atmega Chip and the CD4021 and it works! Woo!

Also, I previously experienced a problem similar to autodafe in another thread;
-the intro "animation" loads up very slow compared to what I have seen in videos
-all 8 leds just blink indedinitely and nothing happens...
For reference this was sorted by ensuring the Fuse codes were written during flashing (they have to be actively set and set to write in AVRDudess)

Loving the module now, thanks Antumbra!

Squash
Learning to Wiggle
Posts: 7
Joined: Mon Jul 02, 2018 7:13 am
Location: London

argh!

Post by Squash » Wed Dec 12, 2018 6:29 pm

Just built my second one of these, as I love the first!

Finished the build over an hour ago, been pulling my hair out trying to get it to stop blinking and work properly. Messing with fuse codes, reflowing, oscilloscope probing etc.

Finally it came to me - the last line of the build doc: "On the first run, you have to reset the module."

The reset command - holding buttons A and C - is printed in the manual but not right there on the build doc! :doh:

Ah well, still a great module!

eoele
Learning to Wiggle
Posts: 19
Joined: Fri Sep 14, 2018 12:59 pm
Location: Tx

How good is it?

Post by eoele » Thu Jan 24, 2019 9:39 am

I've been trying to find a modular sequencer to replace my sq1 and this looks nice but can't find good videos about it. Would you say the Rot8 is a decent all around sequencer for a small system?

User avatar
dub halley
Learning to Wiggle
Posts: 10
Joined: Sun Sep 01, 2013 4:23 am
Location: Rennes France
Contact:

Re: How good is it?

Post by dub halley » Thu Feb 07, 2019 3:46 pm

eoele wrote:I've been trying to find a modular sequencer to replace my sq1 and this looks nice but can't find good videos about it. Would you say the Rot8 is a decent all around sequencer for a small system?
Hi
I have just finished to build mine.
It's a very cool sequencer, well thought, compact and efficient.
He do the job, in a smart way ... :love:


DIY topic :

I'd some trouble at the beginning... But Solve now thanks to David :hail:

1 - Finished the build.
2 - Flash the module.
2 - Put on, see the leds blinking in a sequence, cool, it work :-)
3 - But not :-( the seq was not able to follow the lfo in the clock in. He work, but not fine.
4 - Did the reset with the 2 buttons A and C. Still not good...
5 - Saw that the start animation was still very very slow... it's not the same in the youtube demo video ...
5 - Ok, there is a quartz, the CPU clock.
6 - Mesure both pins, noise les less than 10mV ... Ok, no clock, so I start to check the caps next to, seem to be ok, i change the quartz, no more results ...
7 - David they me, "flash the module carrefully, and be focuses on the fuses"
He is right. The quartz work, and the start animation are good now ... :yay:
The seq now, follow perfectly the clock in, it's really a nice seq :-D
I should do a vidéo ... :deadbanana:

It's very tricky to play with fuse, I was not concentrated enough ... :ripbanana:
But .... one more skill now :-)

Thank you David :tu:

tangence
Learning to Wiggle
Posts: 3
Joined: Tue Feb 20, 2018 6:32 pm
Location: Austin, TX

Re: How good is it?

Post by tangence » Tue May 14, 2019 9:04 am

dub halley wrote:3 - But not :-( the seq was not able to follow the lfo in the clock in. He work, but not fine.
...
It's very tricky to play with fuse, I was not concentrated enough ... :ripbanana:
But .... one more skill now :-)
I have my module built and flashed. Startup animation works fine, but it is not receiving clock at the input. I am not sure if I incorrectly flashed/set fuses, or if I've run into a hardware issue regarding the clock input. Will disassemble to check all solder joints relating to clock input.

User avatar
dub halley
Learning to Wiggle
Posts: 10
Joined: Sun Sep 01, 2013 4:23 am
Location: Rennes France
Contact:

Post by dub halley » Wed May 22, 2019 9:59 am

Hi
I don't have the schematic, so I can't help you, where to check if the clock arrive to the ATmega328.

But I advise you to reburn the IC and be carreful with the fuses.

Otherwise, If it don't work, you could ask David from antumbra ...
antumbramodular@gmail.com

Good luck !! :tu:

kynsi
Learning to Wiggle
Posts: 26
Joined: Wed May 15, 2013 2:20 am

Re: ROT8

Post by kynsi » Mon Dec 30, 2019 2:44 pm

Does anyone have a BOM for PCB release 1.5? I'm building the lastest pusherman boards (v1.5) and resistor r52 is not on the BOM...

bman
Learning to Wiggle
Posts: 15
Joined: Sun Jul 28, 2019 5:59 pm

Re: ROT8

Post by bman » Thu Jan 02, 2020 4:03 pm

I emailed the creator asking the same question, but shortly afterward I figured out that he just split the LEDs across two resistors in parallel instead of one in series. In my build I used a 100ohm on R52 (same as R42) and they aren't excessively bright or hot. When he emailed me back he recommended 270ohms for R52 and R42, which probably makes mores sense since there are fewer LEDs after each resistor.

kynsi
Learning to Wiggle
Posts: 26
Joined: Wed May 15, 2013 2:20 am

Re: ROT8

Post by kynsi » Sat Jan 04, 2020 7:01 am

Yes, the bom has now been updated as well. One suggestions I have is to use at least 1/4 Watt 270 Ohm resistors, not 1/10th Watt..
As the current running through the leds is around 20mA the resistor will need to dissipate roughly max 0.12Watt (6V * 20mA).

AlterX
Learning to Wiggle
Posts: 24
Joined: Sat Jun 22, 2019 5:00 pm
Location: North East UK

Re: ROT8

Post by AlterX » Sun Jun 07, 2020 3:54 pm

Just finished my ROT8 this evening. All seems good, start up sequence was good 1st time...now no smillie :-( Red LEDS are out. Buttons works fine, Seq runs, CV output is good. When clock is fed in, sequence seems to run very slow, with a fast clock from O_C. Would it be back to a re-flash and check fuses?

User avatar
antumbra
Common Wiggler
Posts: 71
Joined: Fri Mar 20, 2015 5:21 pm
Contact:

Re: ROT8

Post by antumbra » Mon Jun 08, 2020 6:16 pm

AlterX wrote:
Sun Jun 07, 2020 3:54 pm
Just finished my ROT8 this evening. All seems good, start up sequence was good 1st time...now no smillie :-( Red LEDS are out. Buttons works fine, Seq runs, CV output is good. When clock is fed in, sequence seems to run very slow, with a fast clock from O_C. Would it be back to a re-flash and check fuses?
I'd think that could be a solution, also reflowing components. Are the green leds working?
www.antumbra.eu
soundcloud.com/monolitmusic

AlterX
Learning to Wiggle
Posts: 24
Joined: Sat Jun 22, 2019 5:00 pm
Location: North East UK

Re: ROT8

Post by AlterX » Fri Jul 10, 2020 5:23 pm

Sorted. Thanks you

Post Reply

Return to “Antumbra”