FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 

Oberheim DSX - Sometimes it works, sometimes it doesn't
MUFF WIGGLER Forum Index -> General Gear  
Author Oberheim DSX - Sometimes it works, sometimes it doesn't
Hello fellow MW's

I recently acquired an Oberheim DSX (hoping to live the dream)

It all seems to work fine on some occasions (created a few sequences), then on others it doesn't power up correctly (Screen does not show opening text, and different lights light up - random each time) It seems to lose memory at this stage too.

This unit is a later one (date codes of late 84' on the TX and some ICS).
It has factory 3.04 eeproms installed.

So far i have:
Tested all voltages with a multimeter - all within tolerance.
Battery shows 4.3V (new battery).
I reseated all ICs,
Swapped RAM chips around so 1st RAM chip in particular was swapped - no change in behaviour.

The failed boot appears to be totally random at this point - i cant pinpoint what is causing it.

I suspect some sort of a startup issue (power sequence timing?)

Google tells me that that this has occurred in other peoples machines, but cant find any known issues.

I have a newly acquired scope at my disposal to help in testing.

Would anyone have any suggestions for things to check?

I'll try the service manual recommendations:

Check Clock,
Check Reset,
Replace support ICS,
Swap Ram etc
Run test EPROM

Any suggestions would be welcome!

Mine had the same problem for years. Cold boot would bring up a blank screen or a number 1 if I remember correctly. After it warmed up a bit, it could be turned off and then back on and work correctly. Like I said it did this for years, then finally stopped booting all together. I sold it on eBay as not working. Hopefully someone more skilled than me got it going again. I also have a Sequential Circuits Drum Traks that has MIDI and works perfectly so it wasn't a huge loss for me to see it go. Best of luck getting yours going.
older gear that has this problem (OSCar is another one) typically has a timing circuit that holds the reset line to the CPU until the power is stable.

Unfortunately, the components in that reset circuit age and therefore the timing changes and you get the sporadic good/bad power up sequences. Grab a set of schematics, find the CPU, look for the reset line, and replace any transistors and caps in that part of it.

Not a guarantee that it's the problem, but it's certainly one area that could be the root cause. (unstable voltages with lots of ripple could be an issue as well, use a scope if you have one to see if the voltages are steady; a DVM may not show it).
Thanks for your replies!

Old Gear Guy, i was thinking it was something like a timed startup sequence,
you've helped me narrow down where i want to search.

I'll also scope the voltages as it hasn't been recapped and looks unused for quite a while ~ just acquired a scope, so an EE friend will hopefully be able to give me a lesson on how to use one

I'll do my homework with the schematic and post my findings here soon.

These seem to sell non working quite often, so hopefully if i can identify the problem, it might help other users down the track.

Hi Old Gear Guy,

So i had a bit of time to study the service manual.
Wondering if i should be looking at the reset circuit or wait circuit?

Seems that the Reset Circuit is a Schmitt Trigger - just finding out what that actually is? Does the Capacitor in that circuit C14 (6.8Uf) 'time' the trigger?
Will try and measure pin 26 of the Z80 (reset) for a positive transition upon power up (as suggested in the service manual), and or swap out the parts in the Reset circuit.

Thanks for your suggestions so far,

Here's a quick 'get a Z80 running' post that might be of interest: Z80 startup

The WAIT pin is used for slow memory and I/O devices to tell the Z80 that they need more time to complete their operation, so it should be OK as long as it's being held HIGH (it's active LOW - the bar across the top means that, so it will force the Z80 to sit and wait if the line voltage is LOW).

Don't forget to check the cleanliness of the +/- power and make sure ground is really grounded with no stray signal/power on it as well.

and for completeness, here's an old school page describing all the Z80 pins: Z80 pin description
The Real MC
oldgearguy wrote:
Note on the RESET pin there is an additional signal coming in from somewhere else in the DSX (the * by the word RESET outside the CPU is an indicator used by Oberheim to say this signal is coming from somewhere else in the schematic) that should be checked as well.


The * prefix (sometimes the "/") is a universal symbol that the signal is active at logic low. That has been schematic convention since the 1960s.

There is no other signal from somewhere else affecting the reset circuit. First off, you don't direct couple TTL outputs; you can only direct couple current sources, and TTL devices are not current sources they are voltage sources.

The *RESET label to the left of the pin on the schematic only indicates that this signal is the source to other circuits on the diagram. Not every line leading from the left is an input, especially in dense logic circuits.
Thanks for the correction, off to clean up the post so others aren't mislead. Not sure what I was thinking about when posting that....
Thank you all for chiming in. I have learnt a lot from your suggestions, and have found avenues to study online.

I just acquired my scope (Rigol DS1054z), and have just begun studying how to measure things with it. (Have only done a few synth calibrations with one, but i had an EE friend who helped get the scope in the right mode for each test)
I apologize in advance if i have misunderstood the advice given above.

I measured the voltage on the 'wait' pin of the Z80 upon power up:
When machine off: 0V. When powered up: 3V. This is the same whether the machine has a failed boot, or a successful one. (power cycled it a few times until i got a good boot up)

I measured the voltage on the 'reset' pin of the Z80.
When the machine is off, or unplugged entirely: 4V
When machine is switched on, it goes to 5V. Failed boot (successive power cycles didn't get me a good boot, so not sure if the behaviour would be same)

According the the Z80 docs Old Gear Guy posted, i think that
both pins (reset and wait) should be Active Low? Does this mean that the Z80 will execute a wait or reset command when a 'low' (0V) power is applied to the respective pins?
Therefore do the reset and wait pins need to be held high (3-5V) for them to be off (they need to be off when the machine is working right?)

If so, would that suggest that my wait and reset circuits are working correctly?

Sorry if i have this wrong or back to front?

I also tried to measure ac ripple. Assuming i've measured correctly, i have 100mV of ripple. Sounds high to me. There is a single 3300 uf cap for smoothing?, i have a spare on hand so perhaps i can install that and check for ripple again.

Thanks again for helping me understand!

Disco Computer
Did more testing today.

It was bugging me that the Reset Pin was 4V with the machine switched off (or even unplugged) I would expect it to be 0V and immediately go high on power up.
This led me to explore the schematics - I couldn't see anywhere where the reset circuits connect to +5m (5V memory power).
I figured that somehow the reset pin is getting power from the battery.

I figured i'd disconnect the battery to see if that would allow the dsx to boot. Sure enough, it boots every time with the battery disconnected!

Now the fun begins:

Pulling the board revealed a heap of mods (wire jumpers everywhere and a few caps etc). I can see that they all look like factory mods - thin black wires, and caps that are identical to the oberheim ones).

I think i see where a few of the notorious RCA 4011s would connect the z80 reset line to the +5M power if they were shorting out (as RCA's do) so i'll pick some up tomorrow to swap out.

Hopefully that solves my issue..


On my PCB, one of the pins on U44 (RCA 4011) is tied to the reset line of the Z80, via a wire link. (not shown on my schematic)

Changing out this RCA chip for a new one has fixed the problem (power cycled the machine numerous times and correct boot every time).

My guess is that the RCA chip developed an internal short, which sent +5M to the reset pin (as this particular IC U44 is powered via the +5M line).

Before changing it out, i had +4V on the reset line, when not powered up.
Now i have 0V on the reset line when not powered up, and it goes high as normal when powered on.

Thanks for all the suggestions and help offered - particularly from therealmc and oldgearguy.

Your suggestions, gave me lots to learn, and i've learn't a few new competencies:

How Z80 reset and wait lines work
What active low and active high means,
How to check these with a scope.
How to check a clock line with a scope
- almost learnt how to check ripple with a scope (still figuring that one out)
Reminder of the RCA 4000 series chip issues.

Hopefully this thread helps someone out there.

Good deal. Glad you were able to track it down. Was spending time with family (and mostly off line), but I would have suggested as you guessed - 4v was problematic before power up.

Congrats on getting the DSX back up.

Turned on the machine the next day after it was seemingly fixed, and it does not boot (same as before). And like before, there now seems to be some voltage present (3.6v) on the reset pin when the machine is off.

Retracing my steps, it seems that changing out U44 didn't fix the issue, temporarily disconnecting the back up battery did?
Where it's confusing, is that with it reconnected, i definitely measured 0v before power up). Now, there is voltage on the reset pin whilst the power is off.
This indicates to me that somehow something is gradually storing and building up charger from the +5M line.

I notice that all of the parts near the battery have dull solder joins, whilst the remaining 90% of the board is spotless and the solder pads are still shiny.
I believe that the machine has suffered from battery acid leakage in the past.

Would it be feasible that perhaps something is not right due to the battery acid leakage, perhaps forming a cold solder joint somewhere, or damaging a part / trace, which has in turn created a situation where a capacitor or something is storing voltage / current and directing it to a place it doesn't normally go?

I think i've gotten somewhere in that i know why the machine wont boot (voltage on the reset pin when power off so it cant start active on bootup).

Just can't see how the battery voltage is getting to the reset pin (as the battery voltage only goes to circuits with the +5M designator on the schematics (memory, and a few other circuits)

As mentioned, on my board u44 (which draws power from the +5M line) is connected to the reset pin via a jumper (looks factory modded.)

I'll investigate further, and study the factory modification notes for clues.
If anyone has any suggestions of how to narrow down the search it would be fantastic!

Happy Holidays
Hello All,

I did yet more study and confirmed that my machine (being a late production run) has all the ECO (Engineering Change Orders / factory mods) in place.

One of them ECO215 is what seems to be connecting U44 to the reset pin (via pin 9).

My question for those more experienced, is do you see if this mod is dumping the battery / memory power +5M onto the reset pin of the Z80 - under normal conditions? would pin 9 be carrying +5M power? it is labelled PUP in the DSX schematics. Here are the relevant sections of the schematic:


U43/U44 PUP? circuit?

I pulled the battery once more, and as mentioned, the machine works as normal (0V without power). With battery installed I have voltage on reset pin, when power off.

I traced the voltage from the reset pin on the CPU, all the way back to the battery.
It travels along U44 then connects to U43, which then connects to the battery circuit.

The whole area where the battery circuit resides has had battery corrosion, and i can see all the solder joins are black / solder doesn't stick here.

Not sure if there is a problem with this circuit, or if the corrosion has created a cold solder join somewhere in this area, which in turn is putting battery power in the wrong place, which then travels through the mod, to the reset pin.

If anyone would be able to look at the schematics below it would be appreciated (might pick something up that i'm missing)

UPDATE: It's Fixed (hopefully)

So I cleaned all the battery corrosion (removed 30+ components near the battery that had been affected), using vinegar, distilled water, iso, which was very tricky to do - once clean, the contacts would appear dull again (as the corrosive substance kept making it's way out of the metal). After a couple of long soaks in vinegar (and use of a fibreglass pencil), the contacts were then perfect.

I then replaced all the parts, checked, double checked.
All appears to be working now - machine boots correctly, 0V on reset pin until power up.
One thing that still bothers me is that the battery is showing around 4volts when the machine is turned off. Don't know why a 3.6V battery charges up to 4V?
If anyone could measure the voltage across their battery with the power off it would be much appreciated!
DiscoComputer wrote:
Hello fellow MW's

Battery shows 4.3v (new battery).


Just out of curiosity, where did you get that battery from?
Also, v should be V if it stands for Volts. The devil is in the details, and I only hail the detail-orientated 3.6 Times a day. twisted

Hi M127,

Thanks for schooling me on v vs V. I've gone back and edited my posts to reflect this.

The battery is a generic 3.6v rechargeable. It came with the machine:

Apologies if this is a dumb question, but could the main 5V rail capacitor (3300uf) which is showing 0.6V make the battery appear to have 4V? (i haven't taken the battery out of circuit to measure it.
The Real MC
110mAH battery for 16 RAM ICs? Seem seriously underpowered.
I just had a quick read of this, I'm not familiar with the Oberheim DSX. One thought that popped into my head was "I wonder if he has checked the diodes?" Maybe, put the scope down and get the trusty multimeter out for a bit! hihi

Edit: Also, you would have got a lot more views on the subject if you put it in the Music Tech DIY section.
Hi Col,

Yeah good point! 1st thing i did was check all the diodes (checked out okay) and probe / trace power with multimeter. The scope only came out to check that i had a working clock / ac ripple etc.

Interesting point Real MC -
A check of the DSX service manual shows that the original battery is 4.8V (not 3.6) - I couldn't find any data on the part number to show what it's amperage was. Don't know if this is a problem.

I might have it wrong, but the datasheet seems to say that the standby current used by the Hitachi 6116P-4 is between 2 (typ)-50microamps (max). So my crude calculations tell me that with 16 chips and a 110mah battery, i should get 3437.5 hours if the memory chips all draw typical current, down to about 137.5 hours if they take maximum current for whatever reason.

Eitherway, you make a good point that perhaps i need a battery with more current, or i'll need to remember to power up the machine periodically when not in use.

Thanks for your help everyone!
Also, start lifting the legs of the capacitors and check the values haven't drifited. Any pics of the circuit board?
Hi Col,

Replacing all the parts near the battery (that had suffered from battery corrosion) seems to have solved the issue. I measured all the parts once removed, and they all checked out fine, so at this stage, i'd hazard a guess that the corrosion caused a cold solder joint somewhere, or that some of the mods on the back of the board had intermittently shorted out on some solder pads.

The unit has held up all week, so hopefully it is fixed 100%. Now to learn how to use it.

MUFF WIGGLER Forum Index -> General Gear  
Page 1 of 1
Powered by phpBB © phpBB Group