MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Ableton Live & sequencers, workaround for latency issues
MUFF WIGGLER Forum Index -> Music Software Goto page Previous  1, 2 [all]
Author Ableton Live & sequencers, workaround for latency issues
Jbone1313
henrry wrote:
w00t w00t w00t w00t
Huge immense THANK YOU man!!!
thumbs up

You saved my day!!!!! (many days actualy!!!)


Glad to help. It is so commonly misunderstood, and I myself struggled with this for so long, so I try to help others avoid the same struggles.

One comment: If I were you, I think I would USE the External Instrument device. It is generally a good thing if you are monitoring your hardware through Ableton.

The reason it is good is that it compensates the VARIABLE latency induced by various plugins in your set.

If you set the track delays manually yourself, it might be OK now, but later, if you add a plugin that induces latency, it will change the overall latency of your set, and then your shit will be off again.

If you are sequencing your hardware from Ableton and direct monitoring it (not through Ableton), then you probably do not need the External Instrument device.

Just keep the principles in mind and create simple tests.

If you are monitoring through Ableton, use Reduced Latency When Monitoring; use the External Instrument device; and, with exception of the External Instrument device, do not put latency inducing devices in the signal chain of that instrument (i.e. on the same track or in buses or sends that track goes through).
Jbone1313
And, why not monitor through Ableton? Then you can use all kinds of VST effects, etc.
WisdomWriter
iiiiinteresting. I use just simple midi and audio connection and was still gathering a bit of latency. i adjusted the offset to account for the latency but it still wasn't in sync. this gave me couple ideas. thanks all!
cs1729
I found this thread while I've been trying to figure this out, but I can't seem to get the settings right. Whether I use the ext inst/eff devices or negative midi delays, the recordings are always either a little late or pushed too early and cut off the part of the first beat.

I was wondering if it is because I'm trying to use ableton as a monitor/mixer and also send out that audio via ret tracks to hw effects then back in again.

The best results I was able to get were not using the ext devices, using reduced latency when monitoring and setting a neg midi delay. But that is confusing as well when you switch off monitoring.

Any other tips? Is this problem easier to deal with in cubase or reaper or another program?
gongondy
Yeah I can't for the life of me get this to work. It seems like everything is so inconsistent. I am clocking my modular from Live and an ES-8, turning the monitoring off, and using an external instrument, have delay compensation/low latency monitoring on. My recordings are still coming in way behind time. I'm also sending clocks from my Elektron Digitone to a Mutant Brain module and my recordings are behind but by MUCH less. The hardware latency parameter on the Ext Instrument device doesn't change a thing when i try to adjust it! I'm even recording at 32samples buffer time. I've been dealing with this for three years and I think I'm going crazy. I don't even know what I can buy or who i can pay to fix this for me. I was having this problem even before I bought I was using MIDI. I've been getting Jitter/Latency with just my ES8 and modular for as long as i've owned it. I've owned 2 ES8s, 2 computers, and many versions of Live. Nothing ever changed. Would any of these external sync devices even help me if i'm using both sync clocks and MIDI?
goldplate
Guys, I don't get this.

You have a solution provided in stating that it's the only one found from very much experiments and you come here to complain that you don't find the solution while you didn't fulfilled the requirements to get at it.

The solution may look shitty to put in place at first, but once it's done, it's right, you never have issues anymore, WHATEVER you do (regarding audio). You can use external hardware effects and latency inducer plug-ins at the same time and your monitoring, recordings and grid will always match, not "only if you enable this when you do this, etc." for every task.

Sorry but this thread is about the solution, not your issues about other ways to set up which miserably failed.

EDIT: OP was updated to include the eventual prior need to set the Driver Error Compensation right before setting anything else.
Panason
cs1729 wrote:
I found this thread while I've been trying to figure this out, but I can't seem to get the settings right. Whether I use the ext inst/eff devices or negative midi delays, the recordings are always either a little late or pushed too early and cut off the part of the first beat.

I was wondering if it is because I'm trying to use ableton as a monitor/mixer and also send out that audio via ret tracks to hw effects then back in again.

The best results I was able to get were not using the ext devices, using reduced latency when monitoring and setting a neg midi delay. But that is confusing as well when you switch off monitoring.

Any other tips? Is this problem easier to deal with in cubase or reaper or another program?


Don't use negative MIDI delays in Ableton- the only way a negative delay can work is by adding a positive delay to all the other tracks, and this will create problems. Nudge the MIDI data back instead.
It's ok to use negative delays for MIDI clock output (in Live's MIDI preferences) when syncing hardware sequencers/ drum machines) but not ideal.
I monitor through the DAW and seem to get the best results by NOT using Reduced Latency When Monitoring and by putting all external sound sources on External Instrument tracks. (Plugin Delay Compensation is always on). Then create another audio track to record the External Instrument but always monitor through the EI track.

The most important thing for MIDI timing is to be able to run your project with a Audio buffer size of 64 samples or less, which means having a decent CPU. This is because Ableton (at least on Mac) uses MIDI timestamping which sends the MIDI data out together with the audio. AFAIK.
Patch Me I'm Famous
Guys, thank you for this post! It is amazing and solved my problems. Rockin' Banana!

One Question maybe someone can help me with this.

if i use Expert Sleepers Silent Way as a Midi Clock it is rock solid tight.
if i use Ableton CV Tools as a Midi Clock its out of timing.


I think the problem would be solved if i can use the workaround from
goldplate wrote:

But how should i insert the Ext Audio Effect after the CV TOOLS plugin, CV Tools does not allow me the hear the output of the plugin!? :-(







I only use the demo version of Silent Way, so i can buy Silently now or wait for a workaround.
Does anyone got it running with Abelton CV Tools?

Thanks
MUFF WIGGLER Forum Index -> Music Software Goto page Previous  1, 2 [all]
Page 2 of 2
Powered by phpBB © phpBB Group