MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Information
Happy holidays! Please see the year-end funding drive post in the Announcements subforum. Thanks and all my love to you beautiful people.

Digitakt / FH-2 questions
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author Digitakt / FH-2 questions
Lecker909
Hi, sorry to hijack the thread but came on muffwiggler to ask in a new topic but can’t because I haven’t posted before.

I’m tying to use the digitakt to control the fh-2

I’m on firmware v1.2
Digitakt is 1.10

Basically what I want to do is modulate the attack on my basimilus to switch between a kick/snare. For the purpose of explaining the issue im trying to modulate between the extremes of the attack pot so from full ccw to cw.
I also want to be able to control pitch when triggering.

I created a configuration with base output 5, cv out, velocity-gate and trigger out.
I also set a mapping for cc70 to output 8.
So with this I have pitch from 5 (-/+ 5v), vel Control from 6 (-/+5v), trigger from 7 (0-10v) and cc70 from 8 (-/+5v)

So pitch and trigger work fine. Connecting output 8 to modulate the attack works correctly when I tweak it manually, but if I try step lock a value for it (say its default is ccw and I Param lock a single step to full cw), it’s as if the value received by the fh-2 is slightly lagging so rather than jumping to the full extreme it only reaches half way, then I can see from the led on output 8 that it’s now holding that value till the next note, which again because it seems to be lagging only half way through that note does it reach back to its expected full ccw position. So we end up with two notes sounding wrong, not just one.

I’m not sure what’s happening there. I’ve noticed the clocks are different between what the fh2 is displaying (I’ll have the digitakt set to 120bpm, the fh2 will show just under 118) but that’s just a guess.

So Then if I try to control this value via output 6 (vel gate), while I can’t get the full cw sound (seems to reach just before it at full 127 value), I at least get slightly better tracking when param locking steps. I.e the correct note will change and the next after will sound as expected (almost, as I said I can’t get the velocity value to match the full extremes of the pot). Except in this case every few bars I’ll hear one note where it manages to actually sound like it’s gone all the way to the full cw position.

I feel like this is not a great explanation :( sorry about that kind of hard to explain with text alone I’ll try record a video or something to explain. Hope somebody can help.

Thanks.
Lecker909
Ok took a bit of experimenting but I have found a solution to my problem.
It seems that gate or trigger fires slightly before a large cc value change can reach its new value fully.
That’s the conclusion I’ve come to after plugging either gate or trigger signal through maths channel 1 with rise set full CCW and triggering the bia with the output from the end-of-rise (eor) output. I’m guessing that it’s the tiny delay introduced by the maths function that means the value change and trigger are now in sync, meaning I can now step lock extreme values and hear the expectedly sounds.

Not sure if this would be considered a bug or something that could be solved straight on the fh-2 with maybe the ability to add an envelope to triggers/gates?

Hope that makes sense smile
os
Now you've posted that, I understand your first post a lot better!

So basically the problem is trying to use a CV to choose a sound, and relying on that happening 'at the same time' in some sense as the gate that triggers that sound.

In general that's not going to work. The CV needs to reach its new value before the gate fires. So you need to slightly delay the gate, or slightly advance the CV change.

This is a problem in all-modular setups, but when you add MIDI into the equation you've got the delay between MIDI messages to worry about, and the fact that the various messages might not always be sent in the same order.

There are various solutions but the envelope you suggest is one of them. Happily the FH-2 supports envelopes now.
Lecker909
Hurray!

Happy I got what I meant across smile

So is that possible via the “envelope out” setting in configuration -> midi/cv ?
The setting is shown in the v1.2 manual but it’s not on my device (which shows firmware v1.2). Can I update firmware via the standard usb connection or do I need a USB c ?
Lecker909
My bad read the manual again I need a usb stick!
Lecker909
Updated to 1.3.1
Envelope out option is now present.
Turned that on. Maths no longer needed woohoo!
Lecker909
Ok so envelope out is present, but I can’t seem to affect the adsr of this envelope. In my setup the envelope out is on output 2. So I thought If I go to presets > edit preset > envelopes > MIDI/CV-2 2
That i could mess with these values, but any changes I make don’t seem to have an effect.
I’m now on v1.3.1

Also since upgrading there is now an option for base gate to use in conjunction with the fhx 8gt. I don’t own one of these but when I changed this value (wasn’t aware of what it did at the time) i wasn’t able to set it back to its default of ‘1 None’ instead turning fully ccw i can reach ‘64 None’, which seems to sometimes break gate and I need to reload to get it working again. Seems like there might be an indexing bug there.
Lecker909
Ok stupid I should have thought about the fact that envelopes are “per voice of channel” which should have been clue enough that I’m not setting the envelope for output 2, I’m setting the envelope for whatever midi channel that output is being triggered by. That was actually channel 1.
So I am able to change the envelopes!

The other issue I mentioned with base gate still seems to be behaving strangely
KSBMusic
Not trying to threadjack you here, but I am also trying to get the FH-2 to play nicely with an Elektron groove box. When I connect my Rytm mkII to the USB A of the FH-2 and set the clock to the external mode, I am getting a 1.5bpm variation on the FH-2. For example, if the Rytm is set at 80bpm, the FH-2 is saying 81.5bpm. If I use the internal clock setting on the Fh-2, I am still getting that 1.5bpm variation but this time it adjusts the Rytm 1.5 beats downward. For example, if the FH-2 internal clock is set to 80bpm, the Rytm adjusts to 78.5bpm. I know that doesn't seem crazy but it's very obvious discrepancy when trying to multitrack a recording.

Os has been helping me to try to understand what I am getting wrong but it is still not working.

Can anyone help me to troubleshoot what could be the issue?

Thanks,

Kevin
Lecker909
Hey Kevin,

Yep mentioned that in my first post that I also have seen that discrepancy in listed bpm, roughly 1.5 bpm off the digitakt.

Where are you experiencing the lag though? I have midi channels set up on the digitakt to trigger several different drum sound oscillators in my rack - they sync fine with samples played on the digitakt.

Is it that you have an output on the fh2 set as clock and then into a sequencer on the rack? Is that tracking the bpm slower than it should? Could you try just making a midi track output a “click” track instead?
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group