FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 

ES-40 + ESX-8MD setup (teething problems)
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author ES-40 + ESX-8MD setup (teething problems)
I'm a new owner of an ES-40 + ESX-8MD setup, which I'm mostly hoping to use to get accurate clock out to my hardware sequencers.

I received the gear today and have been working for a few hours on getting it going. Made some progress, but not quite there yet!

I use:

MOTU 828 mk3 via USB
Using the latest MOTU ASIO driver
Windows Vista 32-bit OS computer running latest Reaper as DAW
Silent Way 2.7.0 software (I've tried both VST and VST3 plugins with same results described below)
The ESX-8MD says "version 2" on the board. I'm not sure whether this is the same as the "Mk2" model?
QY700 sequencer, among others

Current stage of achievement with the Expert Sleepers setup is:

I can get MIDI clock out to any desired output of the ESX-8MD
I can successfully do the check to make the output lights of the ESX-8MD come up one by one by entering 1, 2, 4, 8, 16, 32, 64, 128 in the software output box
I can get my QY700 to chase the clock coming from the ESX...sometimes

BUT the sync with QY700 as slave only works if I add at least 6dB to the track fader for the ES-40 (SPDIF) output in Reaper. If I leave the track fader at unity gain in Reaper the level displayed in the Reaper mixer panel for the sync signal when the DAW is playing is -42dB (all on the left side of the SPDIF stereo channel). At this level the QY700 never responds. I have nothing else routed to the SPDIF output of the MOTU from anywhere and can't find any other processing in the MOTU Cuemix (eg. output faders, EQ, dynamics, reverb) that should be affecting the level. The final SPDIF output level I see from within the Cuemix program is also -42dB.

Even with the 6dB or higher boost (I've tried up to 12dB), the QY700 doesn't always pick up the MIDI clock and position and start playing. It's quite unpredictable for me so far whether it will play at all, and from what position.

I've also noticed that when I hit play in the DAW, the steady red light to indicate clock output on the ESX-8MD doesn't always come on instantly. It seems when I start playback from the very beginning of the song, the light comes on instantly. However, when I start from another position (say, the start of bar 3), it can take roughly a bar (at 120BPM) before the light comes on.

To cover some other basic matters:

I know the QY700 to be entirely reliable when slaving to MIDI clock and MIDI control. I am very confident I have the correct settings on the QY700.

I have tried experiments with the audio set at 44.1k, 48k and 96k, with the same results

I'm currently using the ES-4 plugin in "unregistered" mode, although I did get a serial number with the purchase of the gear. I'll register soon, but in any case these problems don't seem to me like the kind of thing that can come out of a registration issue (?).

- - -

With all that, thank you for reading and I'd be very grateful if anyone is able to help me overcome these few teething problems.


Do not apply any gain on the track fader, or indeed anywhere. It must be a unity-gain, stereo track. Anything else is going to give unpredictable results.

I've also noticed that when I hit play in the DAW, the steady red light to indicate clock output on the ESX-8MD doesn't always come on instantly. It seems when I start playback from the very beginning of the song, the light comes on instantly. However, when I start from another position (say, the start of bar 3), it can take roughly a bar (at 120BPM) before the light comes on.

It waits until the start of a bar.
Thank you for the quick response, os.

Does the -42dB level i mentioned seem correct?

I've returned the track fader to unity gain and now i get no playback from the slave device at all. Can you offer any suggestions for things to do/check to resolve this?

I see mention in other posts about pan laws. Is there a recommended pan law setting?

Should I try another DAW?

Also, as a side matter, is "version 2" the same as "mk2" for the ESX-8MD?

Thanks again,

The level could be very low. Depends which header the ESX-8MD is connected to.

I'm not aware of a pan law issue in Reaper, but I'm not very familiar with it. If you have Live, or a demo of it, installed, that would be more familiar territory for me.

The mk2 PCB says "ESX-8MD v2.0" on it.
Thank you again Os.

Progress today.

I had been on header 1, switched to using header 2.
Also tried a different MIDI output port for good measure.

I now have the qy700 starting up whenever i press play in the DAW :-)
All happening with the track fader at unity gain.

I've set my timing offset by trial and error and now when recording I get the audio clicks from the qy700's internal metronome placed within about 4 samples either side of the grid in Reaper. I guess that's the QY's own jitter when clocked externally....not too shabby.

One small niggle remaining now:

If i go to the start of bar 1 or bar 2 in the DAW and press record, the QY gets triggered perfectly and its audio ends up on the grid. All good.

But if I go to the start of bar 3, 4, 5, 6, 7 or 8 in the DAW and press record, the QY gets triggered a 16th note too late. So the recorded audio is in perfect tempo sync but you can see/hear that the accented note of a 16th note click pattern is not recorded right at the start of each bar but one sixteenth note late.

Any ideas what could be causing this?

Ps. Loving what I'm hearing today of what the Expert Sleepers stuff can do. This is the kind of tightness i always hoped for, but never had before when a DAW was involved.
Odd. Are you using Song Position Pointer?
Yes, SPP is switched on.
It would be instructive to record the plug-in output (as audio) and see where the signal starts.
Hi again os,

As you suggested, I ran some tests recording the plug-in output as audio. The results are in the image below.

For this experiment (and only for this experiment):

    Silent Way output and the Reaper audio click track are both sent out of and looped back into the DAW simultaneously for recording (through left and right channels of the same SPDIF pair to ensure same roundtrip time)

    Recording is done using a Reaper latency compensation value confirmed to put both of these exactly on the grid (for tests 1 & 2 below)

    Reaper click is quarter notes, project tempo is 130

    For this test the Silent Way offset is set to 0.000 ms

Hope the below image works OK to relay the results...

And I hope you'll know what I mean by my various layman's terms. Of course I'm happy to clarify anything and/or get images of waveforms to help explain as needed.

I suspect your 'simple pulse' is the MIDI clock, and the 'multi spike' is the MIDI start message.

Hard to relate those results to the sequencer starting a 1/16th note late in some cases.
Thanks os,

I have now collected better data on the sequencer response to the sync signal and my earlier description from what I was hearing was not quite accurate. Sorry to add to the confusion.

Better info in another table coming up below...

For collecting this data:

    I returned to the original signal routing to send Silent Way signals to ES-40 and ESX-8MD as it was originally set up (using both channels of SPDIF output)

    I intended to make no other changes and record audio of the QY700 click track with recordings starting at bars 1, 2, 3, 4, 5, 6, 7 and 8 to show the associated results of the above tests

    However, with no offset used in Silent Way plugin, the QY700 would not start playing automatically. It would only start if I pre-armed the QY700 to play. So I returned the plugin offset to my previously used figure of 1.36 ms, at which point the QY700 began starting automatically again (no pre-arming required)

    QY click was set to 16th notes (click pattern is 1 accented beat followed by 15 unaccented beats)

    The general pattern observed was that the QY700 would be a little slow to emit its first note but catch up and spit out even 16ths forever after that. The problem, where there was a problem, was the placement of the beats.

My summary: in tests 1 and 2 below, everything worked perfectly. For all the rest, the sequencer started and remained out of time.

Did you try a different DAW (e.g. Live)?

I would also be interested to know what happened if you out the offset back to zero and enabled the "Delay Start" option.
Thanks os,

I tried putting the offset to zero and enabling the "Delay Start" option. With these settings, the QY700 did start up properly without needing to be pre-armed. So it made a difference in that sense.

In relation to the placement of audio, however, the result was still the same. Tests 1 and 2 were correct, and the following tests were out of time.

Earlier tonight I hooked the ES gear up to another computer that has Windows 7 64 bit and Digital Performer. I used all the same peripherals as before, including the same MOTU interface. On that setup, QY700 triggered correctly and I didn't get this weird issue of misplaced beats. So I think I can conclude the issue I've been having is based in Reaper and/or Vista 32 bit.

(One unexpected issue I noticed was that I had to leave the Silent Way plugin window always open in Digital Performer, otherwise it wouldn't generate any signal. But that wasn't such a big deal, in comparison...)

Unfortunately on that computer I have an issue where, for reasons I don't understand, roundtrip latency keeps changing (nothing to do with Expert Sleepers, it happens with all audio and in any DAW) and so it is impossible for me to get the compensation settings just right. That's what drove me to use my Vista system with Reaper again, where the latency is perfectly stable.

Tomorrow, I'll see if I can get any other DAW to test on my Vista system...or perhaps try something with a Windows 8 laptop.

Thanks for sticking with me through this....

I can confirm that Cubase 5 on the same Vista 32-bit computer is free of the weird timing issue experienced with Reaper.
Another update.

I now have a Digital Performer demo going on a freshly reinstalled windows 8 laptop and everything seems to be perfect. The DAW starts my QY700 fine (in fact, starts it immediately upon pressing play in all instances I've observed so far). There is no funny business going on with beats getting out of time, no matter which bar i start recording from. And recording latency is stable, so I've been able to setup things properly to get everything right on the grid. I've only tested for an hour or so, but it's great...touch wood!

I was hoping to collaborate on some projects with a friend using Reaper, but as things stand it looks like DP will become my regular DAW. I just want to get back to making music now, and actually use my new-found sync powers to create something.

If anything comes up that may provide a solution for use with Reaper, I'd love to know. I tried it on three different machines, with three different windows versions, and never got past the funky sync issues.

Thanks for your responses os.

OK, thanks for the update. I'll have to do some more testing myself in Reaper - it's not a DAW I habitually use.
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group