MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Information
Happy holidays! Please see the year-end funding drive post in the Announcements subforum. Thanks and all my love to you beautiful people.

Unipulse Roland TR-33 and Yamaha MR10 - some trig problems
MUFF WIGGLER Forum Index -> Tubbutec  
Author Unipulse Roland TR-33 and Yamaha MR10 - some trig problems
APiazu
Heya - enjoyed working with the unipulse mod and all works like a charm. So i wanted to post you some pics and some words on the process to share for the community. I will write some more stuff on modding the MR10 as well, upload some sounds from it an soso.. But for now you get the roland stuff + service manual, a picture of the machine!

By sheer coincidence the TR-33 and MR10 share the same length - and with the TR-33's big plate with lots of space on top, it is just asking to have the MR10 mounted there. It even had space enough for a breakout box on top of that as well! So the MR10 and the TR-33 got merged into one - with the unipulse feeding them both! (i used 15 of the 16 triggers of the unipulse, so there is room for a tiny expansion)

I only seem to have one weird bug at the moment. It answers to midi from ableton, which goes thru my mpc 2000xl into unipulses midi socket. Works like a charm! However, when i try to sequence the unipulse from the mpc, the unipulse reacts very rarely - and the mpc sequences all my other hardware with no problems! ... Will try some more testing, but seems like a weird problem.. Have any suggestions?

ROLAND TR-33:

You access the voice generator board by unscrewing the panel on the back. The trigger points are located at different points on the edge of the board, they are all marked with letters - S (snare), BD (bass drum) and so on (You can look up the rest in the service manual, i attached to this post). We found 8 different trigger points for the sounds in the machine. Maracas and High Hat share the same trigger point because they are sharing the same path of synthesis (has probably been sent different pulses to change the characteristics of the sound) - the same with Rim shot and cowbell.

If you want to do further modding on the TR-33, the service manual provides rich details on working with decay, pitch and other things - all the mods we did are described in the service manual. We had to detach a few wires, prolong them and solder them back on, so that we could flip the board and gain access to the backside. For most of the mods, we put potentiometers on to the existing variable resistors, so that they work in parallel (except for the bass drum, where we detached a fixed resistor and replaced it with a potentiometer) - works well, but it should be considered desoldering the variable resistors and replacing them entirely with you’re own potentiometers.

APiazu
The unipulse trigs normally when i play it from a keyboard that passes thru the mpc. When i try recording a sequence on the mpc with the keyboard and then play it back, it only responds to a few very rare notes. I even tried taking out the unipulse and the mpc of my setup, hooked it up to a power outlet that only ran those two machines - same problem occurring.

I also tested running midi from the configuration program for the unipulse thru the mpc into the unipulse. It only trigs very rarely, but when i run midi from ableton thru the mpc into the unipulse it trigs with rock hard steadiness (Configuration program and ableton runs thru the same midi to usb hardware). When i run midi from the configuration program straight to the unipulse (skipping the mpc as a thru channel) it runs steadily.

I can't seem to wrap my head around what the problem is here. I don't have any other sequencers to test it out with - anybody had some similar problems with other hardware sequencers used on the unipulse?
tubbutec
Hi,

can you monitor the midi coming out from the MPC? I believe I once saw strange midi coming from an MPC, but do not remember what is was..

great work !!
APiazu
Thanks, and thank you for making such tools available! Bought the mody/poly mod for my mono poly. Very exciting stuff indeed.

Can't see anything but note on and off when i monitor the output of the mpc. Hmmm
tubbutec
Honestly no idea why this is happening.

At first I thought it might be a hardware incompatibility, but you wrote you can send from Ableton through the MPC which kind of rules this out. Is this soft-through or 'real' midi through?
Very strange. Honestly I am out of ideas what to try
APiazu
Yeah it makes no sense to me either. I guess i would call it "real" midi thru - into a midi track on the mpc and from there on out. If i record that sequence on to the mpc and then play it back from there, the problem occurs.
APiazu
have you heard of anybody else having similar problems? I just remembered that i had similar problems while we were soldering - i was sequencing it with a machinedrum. The Unipulse reacted in a similar way to that of the Mpc 2000. You have any clues as to whether it could have something to do with the Unipulse?

best
APiazu
I could imagine you're busy - but it would be nice if you would share some thoughts...

So, i ran through all the solderings and everything tests out well. I think the problem is, that the unipulse doesn't recognise note off from my MPC (and i just have to mention that nothing is wrong with my MPC, it has always been highly reliant in stability as a midi sequencer with all the gear that i have ever owned).

The unipulse recognises the first note from the mpc and then no more. If i then send two notes from my keyboard (which it always recognises AND the keyboards midi out goes into the mpc), then the unipulse reacts to one note from the mpc again.

I have no idea what to do.. as i said earlier the MPC sends out note on and off as it should so it must be some kind of hardware incompability in the unipulse.

Again i want to mention, that we had problems sequencing it with the machinedrum as well. My friend who also owns a unipulse told me that he have had problems sequencing it with other elektron products as well..
APiazu
you don't have any interest in looking into this or giving a more specific guess to what the problem might be?

I have to say, it disappoints me that you ignore my problems. I did pay you a somewhat large sum of money (uni pulse and mody poly) at least you could show some kind of interest in this case?
tubbutec
HI,
honestly out of ideas. I don't have access to your MPC. I even had uniPulse running with a MPC (don't remember which one) on a trade faire and it worked great.

Quote:
I think the problem is, that the unipulse doesn't recognise note off from my MPC


uniPulse only reacts to note on messages on the triggers, note offs are ignored. I have no idea what the MPC does differently then other machines.
I can think of two specialities with midi:

running status
and
sending note off as note on with velocity 0

but both are correctly managed by uniPulse.

Quote:
as i said earlier the MPC sends out note on and off as it should so it must be some kind of hardware incompability in the unipulse


Quote:
If i then send two notes from my keyboard (which it always recognises AND the keyboards midi out goes into the mpc)


So your midi keyboard goes to the MPC midi in and from the MPC midi out to the uniPulse? And that works, but if the MPC sends its own midi, it does not? Correct?
Then it is very likely not a hardware issue, but one with the midi protocol. However no idea what this might be.

if you can, send me a short dump from a midi monitor program, like midiOx
MUFF WIGGLER Forum Index -> Tubbutec  
Page 1 of 1
Powered by phpBB © phpBB Group