MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

FH-1+FHX-1+FHX-8CV
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author FH-1+FHX-1+FHX-8CV
Grimulkan
Hi Os,

I have an FH-1 with 4 FHX-1s, to which I just added 3 more FHX-8CVs (can't buy FHX-1 new anymore). Is this configuration supposed to work? The 8CVs don't respond at all the way the FHX-1s do. The sockets light up blue, but they don't respond to the corresponding MIDI CC faders.

I did set the 8CV 1/2/3 jumpers corresponding to the last 3 expander slots as per the manual (selection jumper setting seems same between FHX-1 and 8CV). I also used the additional 4/5 jumpers for fixed bipolar operation on the FHX-8CV, if that matters. I daisy chained the data bus the same way as the FHX-1s in the following order:
FH-1 --> FHX-1 --> FHX-1 --> FHX-1 --> FHX-1 --> FHX-8CV --> FHX-8CV --> FHX-8CV
Any other software/hardware settings I missed? Should I use a different order?

BTW, some feedback: the FHX-8CVs only included 2 jumpers in the package (at least from Perfect Circuit in CA, USA). Not sufficient if you want it to occupy 8th expansion slot and enable full bipolar operation (need 5 jumpers for that).
os
That should work. There's no point using the jumper for bipolar operation as the FH-2 will overwrite the jumper setting as soon as it turns on.

There's a menu item under misc for 'test FHX-8CV'. That will drive the outputs on an FHX-8CV in expansion slot 1. Might be worth a try.

Also - are any or all of the FHX-8CVs flashing all their LEDs 5 times shortly after power up? If so that would indicate no connection to the FH-2.
Grimulkan
os wrote:
Also - are any or all of the FHX-8CVs flashing all their LEDs 5 times shortly after power up? If so that would indicate no connection to the FH-2.

Thanks for the response Os. They are indeed flashing on power up!

Note I am NOT using an FH-2 but an FH-1. Was your response addressed to FH-2? Is the configuration I'm trying to run (with FH-1) supposed to work? Maybe I need to update firmware on the FH-1...

I mean, I already have all these FH-1 and FHX-1 related modules, and I want to expand. I'd rather avoid having to sell my FH-1 and replace with FH-2.
Grimulkan
Just installed the latest FH-1 firmware, but situation did not change :( So that wasn't it...

Edit: Also tried disconnecting all FHX-1s so it is only:
FH-1 --> FHX-8CV (with jumper for expansion 2).
No joy :( The 8CV still flashes.

The FH-1 should support the 8CV... why else would there be manual jumper voltage settings on the 8CV if not for the FH-1? So I must still be missing something.
os
Sorry, missed that you were using an FH-1.

So yes, the flashing at startup would be expected. The FHX-8CV won't respond to the FH-1 until after that point.

But then it should just work as an FHX-1.
Grimulkan
Thanks, I'll just ignore the flashing lights. However, it still doesn't work.
Here are my exact connections:

FH-1 GT2 --> FHX-8CV GT1
FHX-8CV jumper position in 3, no other jumpers
All modules connected to same PSU and powered on at the same time

Power up... lights flash on 8CV
If I send MIDI Ch 1 CC7, the 8th output on the FH-1 responds (so MIDI is working)
If I send MIDI Ch 1 CC8 - CC15, no response from FHX-8CV
If I swap 8CV for FHX-1 with same jumper position & connection to GT1, the FHX-1 responds correctly to CC8-15
If I try any of my other 8CVs, no response (so it's not the specific unit)

I checked for "response" 3 ways: on an external scope, via an ES-6 input and of course by watching the LEDs.

What am I missing?

Edit: I also swept CCs from 0-31 on channels 1 and 2, just to see if anything got the 8CV to respond. No luck. The modules are powering up at least - could they be broken in some other way?
os
Sounds like all the FHX-8CVs are simply broken but that seems very unlikely. They're all tested before they leave the factory.

Just to avoid any possibility of confusion could you post a photo of how you have the jumpers on the FHX-8CV and how you have the cables plugged in to it and the FH-1?
Grimulkan
Will post the pics later today.

I was very careful to avoid connecting power to the data pins, so pretty sure that didn't happen. They do still power up. The only user-related errors I can think of:
* Selection jumpers in the wrong order
* GT1 and GT2 connections interchanged
Don't think I did these, but could either mistake have damaged all 3 units in one go?

All 7 expansions (including 4 FHX-1s) were on the same daisy chain, so I don't think it was a PSU short or something like that because the other modules still work. But is it possible for a misconnected jumper or swapped GT on the 1st 8CV (5th expansion) to damage all the others downstream?
Grimulkan
Here is the pic.
High resolution: https://imgur.com/BTPyzKm (click again on the image for full resolution)

os
That looks OK.

I think you'd better send me the FHX-8CVs to check. Email me.
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group