ES-5/ESX-8MD question

Discussion and support for Expert Sleepers' Silent Way software and hardware.

Moderators: Kent, os

Post Reply
geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

ES-5/ESX-8MD question

Post by geetee » Sun Jan 13, 2019 2:18 am

So i got an es-5 and a DJ-1000 cable to connect to my es-8, thinking i could send note messages to my MIDI hardware monosynth. turns out (or it seems), that es-5 can only send out midi sync using the Silent Way ES-5 controller plugin.

alright, so that got me thinking i will need ESX-8MD to connect to my es-5 to send out any MIDI messages (not only sync). however, the silent way es-5 controller plugin only supports MIDI sync, so would i only be able to send out MIDI sync with the ES-5/ESX-8MD combo?

i've seen a video from expert sleepers where this is done easy with es-4/esx-8md, because the es-4 controller plugin in silent way outputs MIDI note messages.

if the es-5 will give me the full midi cababilities with the esx-8md, how do i do it if the software for the es-5 doesn't support it?

User avatar
os
Super Deluxe Wiggler
Posts: 13353
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Sun Jan 13, 2019 8:29 am

turns out (or it seems), that es-5 can only send out midi sync using the Silent Way ES-5 controller plugin.
No, that's not the case.

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Sun Jan 13, 2019 1:56 pm

os wrote:
turns out (or it seems), that es-5 can only send out midi sync using the Silent Way ES-5 controller plugin.
No, that's not the case.
Ok, well that is a relief :)

i've been struggling getting it to work though,

i've managed to get a midi sync working in Ableton to my midi-fied tb-303. Only thing i needed to do was to set my es-5 controller plugin track to the 7/8 stereo output of my es-8, and then set the right midi channel in the es-5 plugin (in this case, midi channel 3), and also enabling "sync".

however, when try sequencing notes on the same track with the same settings (minus "sync", i've got that turned off), i get no response whatsoever.

My main DAW is Bitwig though, but even with the same settings/method there, i don't even get the sync working.

so i tried my unregistered ableton, to test this midi functionality in another DAW, and only got the sync working. But ofcourse I really want this to work in Bitwig, if possible.

BTW I have sample rate set to 48khz in both DAWs, like was recommended.

appreciate if you can help my n00b ass :)

User avatar
os
Super Deluxe Wiggler
Posts: 13353
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Sun Jan 13, 2019 2:49 pm

In Live, you'll need the MIDI channel to be '1', since Live always sends MIDI to plug-ins on channel 1. If you need channel 3 to the synth, you'd need to enable 'channelize' in the plug-in.

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Sun Jan 13, 2019 4:13 pm

os wrote:In Live, you'll need the MIDI channel to be '1', since Live always sends MIDI to plug-ins on channel 1. If you need channel 3 to the synth, you'd need to enable 'channelize' in the plug-in.
Awesome, that solved it in Ableton! :hail:

still not getting any luck with Bitwig, i have MIDI track channel on 1 & in the plugin i have it set on 1 aswell, and channelize: 3, just like in ableton. What could i be doing wrong?

User avatar
os
Super Deluxe Wiggler
Posts: 13353
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Mon Jan 14, 2019 3:10 am

Is the ES-5 Controller in Bitwig actually driving the right outputs? The 'Outputs' knob is a convenient way to debug this.

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Mon Jan 14, 2019 10:56 am

os wrote:Is the ES-5 Controller in Bitwig actually driving the right outputs? The 'Outputs' knob is a convenient way to debug this.
Output on the midi track with the ES-5 controller is set to ES-8 stereo 7/8 output, so it must be right?

I will check the Outputs knob when i get home from work later :)

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Mon Jan 14, 2019 3:58 pm

Ok so,

when i turn the Outputs 1 knob all the way to max value 255, i get red leds on all of the es-5 outputs.

as you can see, the midi track is set to output 7/8 on my ES-8. I've tried both with the 64bit version of silent way, and the VST3 version.


Image

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Mon Jan 14, 2019 8:32 pm

Ok, weird thing....

i got it finally to work by setting MIDI Out > Output to "Gates 1/3" in the ES-5 controller. I got MIDI notes working!

Which is good! but i'm confused how that makes sense, since i got the tb-303 plugged into ES-5 output 1. shouldn't the right setting be "Gates 1/1" then?

User avatar
os
Super Deluxe Wiggler
Posts: 13353
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Jan 15, 2019 3:18 am

It should.

Is the Bitwig track fader at 0dB? I vaguely remember that perhaps in Bitwig they default to -6dB or something.

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Tue Jan 15, 2019 8:25 am

Will check tonite.

also, even tho i got it working, there is a very noticeable latency. will test the latency in ableton also.

geetee
Common Wiggler
Posts: 154
Joined: Thu Jan 14, 2016 5:10 am
Location: Iceland

Post by geetee » Tue Jan 15, 2019 1:58 pm

os wrote:It should.

Is the Bitwig track fader at 0dB? I vaguely remember that perhaps in Bitwig they default to -6dB or something.
hah, no it wasn't, it's default at -10dB!

put it up to 0dB and now everything works as it should! it's responding on the right output setting "Gate 1/1" and the latency issue is fixed!

I just want to say thanks alot for taking the time to troubleshoot this for me, I appreciate it alot. I did purchase Bitwig for the purpose of using the ES-8 and friends, and i'm really happy that i got it working with MIDI. Now time for some music making :)

Post Reply

Return to “Expert Sleepers”